aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/iproute2
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/iproute2
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/iproute2')
-rw-r--r--recipes/iproute2/iproute2-2.6.18/iproute2-2.6.15_no_strip.diff25
-rw-r--r--recipes/iproute2/iproute2-2.6.18/new-flex-fix.patch83
-rw-r--r--recipes/iproute2/iproute2-2.6.20/ip6tunnel.patch10
-rw-r--r--recipes/iproute2/iproute2-2.6.20/man-pages-fix.patch13
-rw-r--r--recipes/iproute2/iproute2-2.6.20/new-flex-fix.patch83
-rw-r--r--recipes/iproute2/iproute2-2.6.20/no-strip.patch36
-rw-r--r--recipes/iproute2/iproute2-2.6.22/ip6tunnel.patch12
-rw-r--r--recipes/iproute2/iproute2-2.6.22/new-flex-fix.patch83
-rw-r--r--recipes/iproute2/iproute2-2.6.22/no-strip.patch36
-rw-r--r--recipes/iproute2/iproute2.inc31
-rw-r--r--recipes/iproute2/iproute2_2.6.18.bb8
-rw-r--r--recipes/iproute2/iproute2_2.6.20.bb12
-rw-r--r--recipes/iproute2/iproute2_2.6.22.bb11
13 files changed, 443 insertions, 0 deletions
diff --git a/recipes/iproute2/iproute2-2.6.18/iproute2-2.6.15_no_strip.diff b/recipes/iproute2/iproute2-2.6.18/iproute2-2.6.15_no_strip.diff
new file mode 100644
index 0000000000..496506960e
--- /dev/null
+++ b/recipes/iproute2/iproute2-2.6.18/iproute2-2.6.15_no_strip.diff
@@ -0,0 +1,25 @@
+--- ip/Makefile 2006/02/23 21:22:18 1.1
++++ ip/Makefile 2006/02/23 21:22:27
+@@ -16,7 +16,7 @@
+ rtmon: $(RTMONOBJ) $(LIBNETLINK)
+
+ install: all
+- install -m 0755 -s $(TARGETS) $(DESTDIR)$(SBINDIR)
++ install -m 0755 $(TARGETS) $(DESTDIR)$(SBINDIR)
+ install -m 0755 $(SCRIPTS) $(DESTDIR)$(SBINDIR)
+
+ clean:
+--- tc/Makefile 2006/02/23 21:23:52 1.1
++++ tc/Makefile 2006/02/23 21:23:57
+@@ -70,9 +70,9 @@
+
+ install: all
+ mkdir -p $(DESTDIR)/usr/lib/tc
+- install -m 0755 -s tc $(DESTDIR)$(SBINDIR)
++ install -m 0755 tc $(DESTDIR)$(SBINDIR)
+ for i in $(TCSO); \
+- do install -m 755 -s $$i $(DESTDIR)/usr/lib/tc; \
++ do install -m 755 $$i $(DESTDIR)/usr/lib/tc; \
+ done
+
+ clean:
diff --git a/recipes/iproute2/iproute2-2.6.18/new-flex-fix.patch b/recipes/iproute2/iproute2-2.6.18/new-flex-fix.patch
new file mode 100644
index 0000000000..2c04087839
--- /dev/null
+++ b/recipes/iproute2/iproute2-2.6.18/new-flex-fix.patch
@@ -0,0 +1,83 @@
+The tc command was failing to build due to flex errors. These errors are
+caused by an incompatible change to flex in recent versions, including the
+version shipped with OE.
+
+This fix is as per the one used by opensure:
+
+ http://lists.opensuse.org/opensuse-commit/2006-04/msg00090.html
+
+and simple renames str to prevent it conflicting.
+
+--- iproute2-2.6.16-060323/tc/emp_ematch.l 2006/10/30 22:46:29 1.1
++++ iproute2-2.6.16-060323/tc/emp_ematch.l 2006/10/30 22:47:26
+@@ -63,7 +63,7 @@
+
+ %}
+
+-%x str
++%x STR
+
+ %option 8bit stack warn noyywrap prefix="ematch_"
+ %%
+@@ -78,17 +78,17 @@
+ }
+ strbuf_index = 0;
+
+- BEGIN(str);
++ BEGIN(STR);
+ }
+
+-<str>\" {
++<STR>\" {
+ BEGIN(INITIAL);
+ yylval.b = bstr_new(strbuf, strbuf_index);
+ yylval.b->quoted = 1;
+ return ATTRIBUTE;
+ }
+
+-<str>\\[0-7]{1,3} { /* octal escape sequence */
++<STR>\\[0-7]{1,3} { /* octal escape sequence */
+ int res;
+
+ sscanf(yytext + 1, "%o", &res);
+@@ -100,12 +100,12 @@
+ strbuf_append_char((unsigned char) res);
+ }
+
+-<str>\\[0-9]+ { /* catch wrong octal escape seq. */
++<STR>\\[0-9]+ { /* catch wrong octal escape seq. */
+ fprintf(stderr, "error: invalid octale escape sequence\n");
+ return ERROR;
+ }
+
+-<str>\\x[0-9a-fA-F]{1,2} {
++<STR>\\x[0-9a-fA-F]{1,2} {
+ int res;
+
+ sscanf(yytext + 2, "%x", &res);
+@@ -118,16 +118,16 @@
+ strbuf_append_char((unsigned char) res);
+ }
+
+-<str>\\n strbuf_append_char('\n');
+-<str>\\r strbuf_append_char('\r');
+-<str>\\t strbuf_append_char('\t');
+-<str>\\v strbuf_append_char('\v');
+-<str>\\b strbuf_append_char('\b');
+-<str>\\f strbuf_append_char('\f');
+-<str>\\a strbuf_append_char('\a');
++<STR>\\n strbuf_append_char('\n');
++<STR>\\r strbuf_append_char('\r');
++<STR>\\t strbuf_append_char('\t');
++<STR>\\v strbuf_append_char('\v');
++<STR>\\b strbuf_append_char('\b');
++<STR>\\f strbuf_append_char('\f');
++<STR>\\a strbuf_append_char('\a');
+
+-<str>\\(.|\n) strbuf_append_char(yytext[1]);
+-<str>[^\\\n\"]+ strbuf_append_charp(yytext);
++<STR>\\(.|\n) strbuf_append_char(yytext[1]);
++<STR>[^\\\n\"]+ strbuf_append_charp(yytext);
+
+ [aA][nN][dD] return AND;
+ [oO][rR] return OR;
diff --git a/recipes/iproute2/iproute2-2.6.20/ip6tunnel.patch b/recipes/iproute2/iproute2-2.6.20/ip6tunnel.patch
new file mode 100644
index 0000000000..371de01c16
--- /dev/null
+++ b/recipes/iproute2/iproute2-2.6.20/ip6tunnel.patch
@@ -0,0 +1,10 @@
+--- iproute-2.6.20-070313/ip/ip6tunnel.c 2007/03/17 03:44:27 1.1
++++ iproute-2.6.20-070313/ip/ip6tunnel.c 2007/03/17 03:43:14
+@@ -33,6 +33,7 @@
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
+ #include <sys/ioctl.h>
++#include <linux/types.h>
+ #include <linux/ip.h>
+ #include <linux/if.h>
+ #include <linux/if_arp.h>
diff --git a/recipes/iproute2/iproute2-2.6.20/man-pages-fix.patch b/recipes/iproute2/iproute2-2.6.20/man-pages-fix.patch
new file mode 100644
index 0000000000..924d0ed4dc
--- /dev/null
+++ b/recipes/iproute2/iproute2-2.6.20/man-pages-fix.patch
@@ -0,0 +1,13 @@
+--- iproute-2.6.20-070313/Makefile 2007/03/17 04:24:45 1.1
++++ iproute-2.6.20-070313/Makefile 2007/03/17 04:27:39
+@@ -52,8 +52,8 @@
+ install -m 0644 $(shell find etc/iproute2 -maxdepth 1 -type f) $(DESTDIR)$(CONFDIR)
+ install -m 0755 -d $(DESTDIR)$(MANDIR)/man8
+ install -m 0644 $(shell find man/man8 -maxdepth 1 -type f) $(DESTDIR)$(MANDIR)/man8
+- ln -sf tc-pbfifo.8 $(DESTDIR)$(MANDIR)/man8/tc-bfifo.8
+- ln -sf tc-pbfifo.8 $(DESTDIR)$(MANDIR)/man8/tc-pfifo.8
++ ln -sf tc-bfifo.8 $(DESTDIR)$(MANDIR)/man8/tc-pfifo.8
++ ln -sf tc-bfifo.8 $(DESTDIR)$(MANDIR)/man8/tc-pbfifo.8
+ install -m 0755 -d $(DESTDIR)$(MANDIR)/man3
+ install -m 0644 $(shell find man/man3 -maxdepth 1 -type f) $(DESTDIR)$(MANDIR)/man3
+
diff --git a/recipes/iproute2/iproute2-2.6.20/new-flex-fix.patch b/recipes/iproute2/iproute2-2.6.20/new-flex-fix.patch
new file mode 100644
index 0000000000..af7272163e
--- /dev/null
+++ b/recipes/iproute2/iproute2-2.6.20/new-flex-fix.patch
@@ -0,0 +1,83 @@
+The tc command was failing to build due to flex errors. These errors are
+caused by an incompatible change to flex in recent versions, including the
+version shipped with OE.
+
+This fix is as per the one used by opensure:
+
+ http://lists.opensuse.org/opensuse-commit/2006-04/msg00090.html
+
+and simple renames str to prevent it conflicting.
+
+--- iproute-2.6.20-070313/tc/emp_ematch.l 2007/03/17 02:52:20 1.1
++++ iproute-2.6.20-070313/tc/emp_ematch.l 2007/03/17 02:54:01
+@@ -63,7 +63,7 @@
+
+ %}
+
+-%x str
++%x STR
+
+ %option 8bit stack warn noyywrap prefix="ematch_"
+ %%
+@@ -78,17 +78,17 @@
+ }
+ strbuf_index = 0;
+
+- BEGIN(str);
++ BEGIN(STR);
+ }
+
+-<str>\" {
++<STR>\" {
+ BEGIN(INITIAL);
+ yylval.b = bstr_new(strbuf, strbuf_index);
+ yylval.b->quoted = 1;
+ return ATTRIBUTE;
+ }
+
+-<str>\\[0-7]{1,3} { /* octal escape sequence */
++<STR>\\[0-7]{1,3} { /* octal escape sequence */
+ int res;
+
+ sscanf(yytext + 1, "%o", &res);
+@@ -100,12 +100,12 @@
+ strbuf_append_char((unsigned char) res);
+ }
+
+-<str>\\[0-9]+ { /* catch wrong octal escape seq. */
++<STR>\\[0-9]+ { /* catch wrong octal escape seq. */
+ fprintf(stderr, "error: invalid octale escape sequence\n");
+ return ERROR;
+ }
+
+-<str>\\x[0-9a-fA-F]{1,2} {
++<STR>\\x[0-9a-fA-F]{1,2} {
+ int res;
+
+ sscanf(yytext + 2, "%x", &res);
+@@ -118,16 +118,16 @@
+ strbuf_append_char((unsigned char) res);
+ }
+
+-<str>\\n strbuf_append_char('\n');
+-<str>\\r strbuf_append_char('\r');
+-<str>\\t strbuf_append_char('\t');
+-<str>\\v strbuf_append_char('\v');
+-<str>\\b strbuf_append_char('\b');
+-<str>\\f strbuf_append_char('\f');
+-<str>\\a strbuf_append_char('\a');
++<STR>\\n strbuf_append_char('\n');
++<STR>\\r strbuf_append_char('\r');
++<STR>\\t strbuf_append_char('\t');
++<STR>\\v strbuf_append_char('\v');
++<STR>\\b strbuf_append_char('\b');
++<STR>\\f strbuf_append_char('\f');
++<STR>\\a strbuf_append_char('\a');
+
+-<str>\\(.|\n) strbuf_append_char(yytext[1]);
+-<str>[^\\\n\"]+ strbuf_append_charp(yytext);
++<STR>\\(.|\n) strbuf_append_char(yytext[1]);
++<STR>[^\\\n\"]+ strbuf_append_charp(yytext);
+
+ [aA][nN][dD] return AND;
+ [oO][rR] return OR;
diff --git a/recipes/iproute2/iproute2-2.6.20/no-strip.patch b/recipes/iproute2/iproute2-2.6.20/no-strip.patch
new file mode 100644
index 0000000000..6490dadb07
--- /dev/null
+++ b/recipes/iproute2/iproute2-2.6.20/no-strip.patch
@@ -0,0 +1,36 @@
+--- iproute-2.6.20-070313/ip/Makefile 2007/03/17 05:17:30 1.1
++++ iproute-2.6.20-070313/ip/Makefile 2007/03/17 05:17:37
+@@ -16,7 +16,7 @@
+ rtmon: $(RTMONOBJ) $(LIBNETLINK)
+
+ install: all
+- install -m 0755 -s $(TARGETS) $(DESTDIR)$(SBINDIR)
++ install -m 0755 $(TARGETS) $(DESTDIR)$(SBINDIR)
+ install -m 0755 $(SCRIPTS) $(DESTDIR)$(SBINDIR)
+
+ clean:
+--- iproute-2.6.20-070313/misc/Makefile 2007/03/17 05:18:20 1.1
++++ iproute-2.6.20-070313/misc/Makefile 2007/03/17 05:18:26
+@@ -27,7 +27,7 @@
+ lnstat: $(LNSTATOBJ)
+
+ install: all
+- install -m 0755 -s $(TARGETS) $(DESTDIR)$(SBINDIR)
++ install -m 0755 $(TARGETS) $(DESTDIR)$(SBINDIR)
+ ln -sf lnstat $(DESTDIR)$(SBINDIR)/rtstat
+ ln -sf lnstat $(DESTDIR)$(SBINDIR)/ctstat
+
+--- iproute-2.6.20-070313/tc/Makefile 2007/03/17 05:17:42 1.1
++++ iproute-2.6.20-070313/tc/Makefile 2007/03/17 05:17:54
+@@ -70,9 +70,9 @@
+
+ install: all
+ mkdir -p $(DESTDIR)/usr/lib/tc
+- install -m 0755 -s tc $(DESTDIR)$(SBINDIR)
++ install -m 0755 tc $(DESTDIR)$(SBINDIR)
+ for i in $(TCSO); \
+- do install -m 755 -s $$i $(DESTDIR)/usr/lib/tc; \
++ do install -m 755 $$i $(DESTDIR)/usr/lib/tc; \
+ done
+
+ clean:
diff --git a/recipes/iproute2/iproute2-2.6.22/ip6tunnel.patch b/recipes/iproute2/iproute2-2.6.22/ip6tunnel.patch
new file mode 100644
index 0000000000..a00a7e79da
--- /dev/null
+++ b/recipes/iproute2/iproute2-2.6.22/ip6tunnel.patch
@@ -0,0 +1,12 @@
+This fix is needed when building with uclibc
+
+--- iproute-2.6.20-070313/ip/ip6tunnel.c 2007/03/17 03:44:27 1.1
++++ iproute-2.6.20-070313/ip/ip6tunnel.c 2007/03/17 03:43:14
+@@ -33,6 +33,7 @@
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
+ #include <sys/ioctl.h>
++#include <linux/types.h>
+ #include <linux/ip.h>
+ #include <linux/if.h>
+ #include <linux/if_arp.h>
diff --git a/recipes/iproute2/iproute2-2.6.22/new-flex-fix.patch b/recipes/iproute2/iproute2-2.6.22/new-flex-fix.patch
new file mode 100644
index 0000000000..af7272163e
--- /dev/null
+++ b/recipes/iproute2/iproute2-2.6.22/new-flex-fix.patch
@@ -0,0 +1,83 @@
+The tc command was failing to build due to flex errors. These errors are
+caused by an incompatible change to flex in recent versions, including the
+version shipped with OE.
+
+This fix is as per the one used by opensure:
+
+ http://lists.opensuse.org/opensuse-commit/2006-04/msg00090.html
+
+and simple renames str to prevent it conflicting.
+
+--- iproute-2.6.20-070313/tc/emp_ematch.l 2007/03/17 02:52:20 1.1
++++ iproute-2.6.20-070313/tc/emp_ematch.l 2007/03/17 02:54:01
+@@ -63,7 +63,7 @@
+
+ %}
+
+-%x str
++%x STR
+
+ %option 8bit stack warn noyywrap prefix="ematch_"
+ %%
+@@ -78,17 +78,17 @@
+ }
+ strbuf_index = 0;
+
+- BEGIN(str);
++ BEGIN(STR);
+ }
+
+-<str>\" {
++<STR>\" {
+ BEGIN(INITIAL);
+ yylval.b = bstr_new(strbuf, strbuf_index);
+ yylval.b->quoted = 1;
+ return ATTRIBUTE;
+ }
+
+-<str>\\[0-7]{1,3} { /* octal escape sequence */
++<STR>\\[0-7]{1,3} { /* octal escape sequence */
+ int res;
+
+ sscanf(yytext + 1, "%o", &res);
+@@ -100,12 +100,12 @@
+ strbuf_append_char((unsigned char) res);
+ }
+
+-<str>\\[0-9]+ { /* catch wrong octal escape seq. */
++<STR>\\[0-9]+ { /* catch wrong octal escape seq. */
+ fprintf(stderr, "error: invalid octale escape sequence\n");
+ return ERROR;
+ }
+
+-<str>\\x[0-9a-fA-F]{1,2} {
++<STR>\\x[0-9a-fA-F]{1,2} {
+ int res;
+
+ sscanf(yytext + 2, "%x", &res);
+@@ -118,16 +118,16 @@
+ strbuf_append_char((unsigned char) res);
+ }
+
+-<str>\\n strbuf_append_char('\n');
+-<str>\\r strbuf_append_char('\r');
+-<str>\\t strbuf_append_char('\t');
+-<str>\\v strbuf_append_char('\v');
+-<str>\\b strbuf_append_char('\b');
+-<str>\\f strbuf_append_char('\f');
+-<str>\\a strbuf_append_char('\a');
++<STR>\\n strbuf_append_char('\n');
++<STR>\\r strbuf_append_char('\r');
++<STR>\\t strbuf_append_char('\t');
++<STR>\\v strbuf_append_char('\v');
++<STR>\\b strbuf_append_char('\b');
++<STR>\\f strbuf_append_char('\f');
++<STR>\\a strbuf_append_char('\a');
+
+-<str>\\(.|\n) strbuf_append_char(yytext[1]);
+-<str>[^\\\n\"]+ strbuf_append_charp(yytext);
++<STR>\\(.|\n) strbuf_append_char(yytext[1]);
++<STR>[^\\\n\"]+ strbuf_append_charp(yytext);
+
+ [aA][nN][dD] return AND;
+ [oO][rR] return OR;
diff --git a/recipes/iproute2/iproute2-2.6.22/no-strip.patch b/recipes/iproute2/iproute2-2.6.22/no-strip.patch
new file mode 100644
index 0000000000..6490dadb07
--- /dev/null
+++ b/recipes/iproute2/iproute2-2.6.22/no-strip.patch
@@ -0,0 +1,36 @@
+--- iproute-2.6.20-070313/ip/Makefile 2007/03/17 05:17:30 1.1
++++ iproute-2.6.20-070313/ip/Makefile 2007/03/17 05:17:37
+@@ -16,7 +16,7 @@
+ rtmon: $(RTMONOBJ) $(LIBNETLINK)
+
+ install: all
+- install -m 0755 -s $(TARGETS) $(DESTDIR)$(SBINDIR)
++ install -m 0755 $(TARGETS) $(DESTDIR)$(SBINDIR)
+ install -m 0755 $(SCRIPTS) $(DESTDIR)$(SBINDIR)
+
+ clean:
+--- iproute-2.6.20-070313/misc/Makefile 2007/03/17 05:18:20 1.1
++++ iproute-2.6.20-070313/misc/Makefile 2007/03/17 05:18:26
+@@ -27,7 +27,7 @@
+ lnstat: $(LNSTATOBJ)
+
+ install: all
+- install -m 0755 -s $(TARGETS) $(DESTDIR)$(SBINDIR)
++ install -m 0755 $(TARGETS) $(DESTDIR)$(SBINDIR)
+ ln -sf lnstat $(DESTDIR)$(SBINDIR)/rtstat
+ ln -sf lnstat $(DESTDIR)$(SBINDIR)/ctstat
+
+--- iproute-2.6.20-070313/tc/Makefile 2007/03/17 05:17:42 1.1
++++ iproute-2.6.20-070313/tc/Makefile 2007/03/17 05:17:54
+@@ -70,9 +70,9 @@
+
+ install: all
+ mkdir -p $(DESTDIR)/usr/lib/tc
+- install -m 0755 -s tc $(DESTDIR)$(SBINDIR)
++ install -m 0755 tc $(DESTDIR)$(SBINDIR)
+ for i in $(TCSO); \
+- do install -m 755 -s $$i $(DESTDIR)/usr/lib/tc; \
++ do install -m 755 $$i $(DESTDIR)/usr/lib/tc; \
+ done
+
+ clean:
diff --git a/recipes/iproute2/iproute2.inc b/recipes/iproute2/iproute2.inc
new file mode 100644
index 0000000000..8c8519f230
--- /dev/null
+++ b/recipes/iproute2/iproute2.inc
@@ -0,0 +1,31 @@
+DESCRIPTION = "kernel routing and traffic control utilities"
+HOMEPAGE = "http://linux-net.osdl.org/index.php/Iproute2"
+SECTION = "base"
+LICENSE = "GPL"
+DEPENDS = "flex-native bison-native"
+
+# Set the DATE in the .bb file
+SRC_URI = "http://developer.osdl.org/dev/iproute2/download/${P}-${DATE}.tar.gz"
+
+S = "${WORKDIR}/iproute2-${PV}-${DATE}"
+
+inherit update-alternatives
+
+EXTRA_OEMAKE = "CC='${CC}' \
+ KERNEL_INCLUDE=${STAGING_KERNEL_DIR}/include \
+ DOCDIR=${docdir}/iproute2 \
+ SUBDIRS='lib tc ip' \
+ SBINDIR=${base_sbindir}"
+
+do_install () {
+ oe_runmake DESTDIR=${D} install
+ mv ${D}${base_sbindir}/ip ${D}${base_sbindir}/ip.iproute2
+}
+
+FILES_${PN} += "/usr/lib/tc/*"
+FILES_${PN}-dbg += "/usr/lib/tc/.debug"
+
+ALTERNATIVE_NAME = "ip"
+ALTERNATIVE_PATH = "${base_sbindir}/ip.iproute2"
+ALTERNATIVE_LINK = "${base_bindir}/ip"
+ALTERNATIVE_PRIORITY = "100"
diff --git a/recipes/iproute2/iproute2_2.6.18.bb b/recipes/iproute2/iproute2_2.6.18.bb
new file mode 100644
index 0000000000..d442a091db
--- /dev/null
+++ b/recipes/iproute2/iproute2_2.6.18.bb
@@ -0,0 +1,8 @@
+PR = "r3"
+
+require iproute2.inc
+
+SRC_URI += "file://iproute2-2.6.15_no_strip.diff;patch=1;pnum=0 \
+ file://new-flex-fix.patch;patch=1"
+
+DATE = "061002"
diff --git a/recipes/iproute2/iproute2_2.6.20.bb b/recipes/iproute2/iproute2_2.6.20.bb
new file mode 100644
index 0000000000..e72dfccdde
--- /dev/null
+++ b/recipes/iproute2/iproute2_2.6.20.bb
@@ -0,0 +1,12 @@
+require iproute2.inc
+
+PR = "r2"
+DATE = "070313"
+
+SRC_URI_append = " file://new-flex-fix.patch;patch=1 \
+ file://ip6tunnel.patch;patch=1 \
+ file://man-pages-fix.patch;patch=1 \
+ file://no-strip.patch;patch=1"
+
+S = "${WORKDIR}/iproute-${PV}-${DATE}"
+
diff --git a/recipes/iproute2/iproute2_2.6.22.bb b/recipes/iproute2/iproute2_2.6.22.bb
new file mode 100644
index 0000000000..1ee0ce7ab2
--- /dev/null
+++ b/recipes/iproute2/iproute2_2.6.22.bb
@@ -0,0 +1,11 @@
+require iproute2.inc
+
+PR = "r1"
+DATE = "070710"
+
+SRC_URI_append = " file://new-flex-fix.patch;patch=1 \
+ file://ip6tunnel.patch;patch=1 \
+ file://no-strip.patch;patch=1"
+
+S = "${WORKDIR}"
+