aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ipsec-tools
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ipsec-tools
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ipsec-tools')
-rw-r--r--recipes/ipsec-tools/files/gcc-4.2.patch47
-rw-r--r--recipes/ipsec-tools/files/racoon-search-missing.patch17
-rw-r--r--recipes/ipsec-tools/ipsec-tools.inc49
-rw-r--r--recipes/ipsec-tools/ipsec-tools_0.6.6.bb3
-rw-r--r--recipes/ipsec-tools/ipsec-tools_0.6.7.bb3
5 files changed, 119 insertions, 0 deletions
diff --git a/recipes/ipsec-tools/files/gcc-4.2.patch b/recipes/ipsec-tools/files/gcc-4.2.patch
new file mode 100644
index 0000000000..573f242e65
--- /dev/null
+++ b/recipes/ipsec-tools/files/gcc-4.2.patch
@@ -0,0 +1,47 @@
+Index: ipsec-tools-0.6.7/src/racoon/var.h
+===================================================================
+--- ipsec-tools-0.6.7.orig/src/racoon/var.h 2004-11-21 03:16:59.000000000 +1100
++++ ipsec-tools-0.6.7/src/racoon/var.h 2007-06-06 12:21:41.000000000 +1000
+@@ -76,9 +76,9 @@
+ do { \
+ if (getnameinfo((x), sysdep_sa_len(x), (y), sizeof(y), (z), sizeof(z), \
+ NIFLAGS) != 0) { \
+- if (y) \
++ if (y != NULL) \
+ strncpy((y), "(invalid)", sizeof(y)); \
+- if (z) \
++ if (z != NULL) \
+ strncpy((z), "(invalid)", sizeof(z)); \
+ } \
+ } while (0);
+@@ -87,7 +87,7 @@
+ do { \
+ if (getnameinfo((x), sysdep_sa_len(x), (y), sizeof(y), NULL, 0, \
+ NIFLAGS) != 0) { \
+- if (y) \
++ if (y != NULL) \
+ strncpy((y), "(invalid)", sizeof(y)); \
+ } \
+ } while (0);
+Index: ipsec-tools-0.6.7/src/racoon/eaytest.c
+===================================================================
+--- ipsec-tools-0.6.7.orig/src/racoon/eaytest.c 2005-06-29 08:38:02.000000000 +1000
++++ ipsec-tools-0.6.7/src/racoon/eaytest.c 2007-06-06 12:22:59.000000000 +1000
+@@ -311,7 +311,7 @@
+
+ printf("exact match: succeed.\n");
+
+- if (dnstr_w1) {
++ if (dnstr_w1 != NULL) {
+ asn1dn = eay_str2asn1dn(dnstr_w1, strlen(dnstr_w1));
+ if (asn1dn == NULL || asn1dn->l == asn1dn0.l)
+ errx(1, "asn1dn length wrong for wildcard 1\n");
+@@ -321,7 +321,7 @@
+ printf("wildcard 1 match: succeed.\n");
+ }
+
+- if (dnstr_w1) {
++ if (dnstr_w1 != NULL) {
+ asn1dn = eay_str2asn1dn(dnstr_w2, strlen(dnstr_w2));
+ if (asn1dn == NULL || asn1dn->l == asn1dn0.l)
+ errx(1, "asn1dn length wrong for wildcard 2\n");
diff --git a/recipes/ipsec-tools/files/racoon-search-missing.patch b/recipes/ipsec-tools/files/racoon-search-missing.patch
new file mode 100644
index 0000000000..eebcb87017
--- /dev/null
+++ b/recipes/ipsec-tools/files/racoon-search-missing.patch
@@ -0,0 +1,17 @@
+Older versions of openssl don't provide all the required crypto code.
+To handle this case ipsec-tools includes it's own version of the
+required crypto code but it fails to add it the search path so
+compilation fails. Fix it here since OE currently have an older
+version of openssl.
+
+--- ipsec-tools-0.6.6/src/racoon/Makefile.am 2006/08/17 05:10:57 1.1
++++ ipsec-tools-0.6.6/src/racoon/Makefile.am 2006/08/17 05:12:08
+@@ -9,7 +9,7 @@
+
+ adminsockdir=${localstatedir}/racoon
+
+-INCLUDES = -I${srcdir}/../libipsec
++INCLUDES = -I${srcdir}/../libipsec -I${srcdir}/missing
+ AM_CFLAGS = -D_GNU_SOURCE @GLIBC_BUGS@ -DSYSCONFDIR=\"${sysconfdir}\" \
+ -DADMINPORTDIR=\"${adminsockdir}\"
+ AM_LDFLAGS = @EXTRA_CRYPTO@ -lcrypto
diff --git a/recipes/ipsec-tools/ipsec-tools.inc b/recipes/ipsec-tools/ipsec-tools.inc
new file mode 100644
index 0000000000..ed265f12ed
--- /dev/null
+++ b/recipes/ipsec-tools/ipsec-tools.inc
@@ -0,0 +1,49 @@
+DESCRIPTION = "IPsec-Tools is a port of KAME's IPsec utilities to the \
+Linux-2.6 IPsec implementation."
+HOMEPAGE = "http://ipsec-tools.sourceforge.net/"
+SECTION = "console/network"
+LICENSE = "BSD"
+DEPENDS = "virtual/kernel openssl readline flex"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ipsec-tools/ipsec-tools-${PV}.tar.bz2 \
+ file://racoon-search-missing.patch;patch=1 \
+ file://gcc-4.2.patch;patch=1"
+
+inherit autotools
+
+# Options:
+# --enable-adminport enable admin port
+# --enable-rc5 enable RC5 encryption (patented)
+# --enable-idea enable IDEA encryption (patented)
+# --enable-gssapi enable GSS-API authentication
+# --enable-hybrid enable hybrid, both mode-cfg and xauth support
+# --enable-frag enable IKE fragmentation payload support
+# --enable-stats enable statistics logging function
+# --enable-dpd enable dead peer detection
+# --enable-samode-unspec enable to use unspecified a mode of SA
+# --disable-ipv6 disable ipv6 support
+# --enable-natt enable NAT-Traversal (yes/no/kernel)
+# --enable-natt-versions=list list of supported NAT-T versions delimited by coma.
+# --with-kernel-headers=/lib/modules/<uname>/build/include
+# where your Linux Kernel headers are installed
+# --with-readline support readline input (yes by default)
+# --with-flex use directiory (default: no)
+# --with-flexlib=<LIB> specify flex library.
+# --with-openssl=DIR specify OpenSSL directory
+# --with-libradius=DIR specify libradius path (like/usr/pkg)
+# --with-libpam=DIR specify libpam path (like/usr/pkg)
+#
+# Note: if you give it the actual kernel headers it won't build, it actually
+# needs to point at the linux-libc-headers version of the kernel headers.
+#
+EXTRA_OECONF = "--with-kernel-headers=${STAGING_INCDIR} \
+ --with-readline \
+ --with-openssl=${STAGING_LIBDIR}/.. \
+ --without-libradius \
+ --without-gssapi \
+ --without-libpam"
+
+# Sometimes it attempts to use y.tab.c before it is actually
+# generated. Note that the failure case is very rare, but it does
+# happen.
+PARALLEL_MAKE = ""
diff --git a/recipes/ipsec-tools/ipsec-tools_0.6.6.bb b/recipes/ipsec-tools/ipsec-tools_0.6.6.bb
new file mode 100644
index 0000000000..1ccc60c18d
--- /dev/null
+++ b/recipes/ipsec-tools/ipsec-tools_0.6.6.bb
@@ -0,0 +1,3 @@
+PR = "r1"
+
+require ipsec-tools.inc
diff --git a/recipes/ipsec-tools/ipsec-tools_0.6.7.bb b/recipes/ipsec-tools/ipsec-tools_0.6.7.bb
new file mode 100644
index 0000000000..3f23b198c1
--- /dev/null
+++ b/recipes/ipsec-tools/ipsec-tools_0.6.7.bb
@@ -0,0 +1,3 @@
+PR = "r0"
+
+require ipsec-tools.inc