aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/irssi
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/irssi
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/irssi')
-rw-r--r--recipes/irssi/files/autofoo.patch87
-rw-r--r--recipes/irssi/irssi_0.8.10.bb66
-rw-r--r--recipes/irssi/irssi_svn.bb74
-rw-r--r--recipes/irssi/xirssi_cvs.bb15
4 files changed, 242 insertions, 0 deletions
diff --git a/recipes/irssi/files/autofoo.patch b/recipes/irssi/files/autofoo.patch
new file mode 100644
index 0000000000..303122bc1d
--- /dev/null
+++ b/recipes/irssi/files/autofoo.patch
@@ -0,0 +1,87 @@
+upstream: http://bugs.irssi.org/index.php?do=details&task_id=590
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- irssi/configure.in~autofoo
++++ irssi/configure.in
+@@ -280,39 +280,24 @@
+ AC_CHECK_SIZEOF(long long)
+
+ dnl * older autoconfs don't include sys/types.h, so do it manually
+-AC_MSG_CHECKING([size of off_t])
+-AC_TRY_RUN([
+- #include <stdio.h>
+- #include <sys/types.h>
+- int main() {
+- FILE *f=fopen("conftestval", "w");
+- if (!f) exit(1);
+- fprintf(f, "%d\n", sizeof(off_t));
+- return 0;
+- }
+-], [
+- sizeof_off_t=`cat conftestval`
+- rm -f conftestval
+-], [
+- AC_ERROR([Unsupported off_t size])
+-])
+-AC_MSG_RESULT($sizeof_off_t)
++dnl * we use current autotools, so do it properly. --CL
++AC_CHECK_SIZEOF(off_t)
+
+-if test $sizeof_off_t = 8; then
++if test $ac_cv_sizeof_off_t = 8; then
+ offt_64bit=yes
+ else
+ offt_64bit=no
+ fi
+
+-if test x$sizeof_off_t = x$ac_cv_sizeof_long; then
++if test x$ac_cv_sizeof_off_t = x$ac_cv_sizeof_long; then
+ # try to use unsigned long always first
+ AC_DEFINE_UNQUOTED(PRIuUOFF_T, "lu")
+ AC_DEFINE(UOFF_T_LONG)
+-elif test x$sizeof_off_t = x$ac_cv_sizeof_int; then
++elif test x$ac_cv_sizeof_off_t = x$ac_cv_sizeof_int; then
+ # next try int
+ AC_DEFINE_UNQUOTED(PRIuUOFF_T, "u")
+ AC_DEFINE(UOFF_T_INT)
+-elif test x$sizeof_off_t = x$ac_cv_sizeof_long_long; then
++elif test x$ac_cv_sizeof_off_t = x$ac_cv_sizeof_long_long; then
+ # and finally long long
+ AC_DEFINE_UNQUOTED(PRIuUOFF_T, "llu")
+ AC_DEFINE(UOFF_T_LONG_LONG)
+@@ -541,13 +526,13 @@
+ int modfunc(){return (int)floor(1.2);}
+ EOF
+
+-./libtool --mode=compile $CC $CFLAGS -c conftest.c 2> /dev/null > /dev/null
++./*libtool --mode=compile $CC $CFLAGS -c conftest.c 2>log >&2
+ if test ! -s conftest.lo; then
+ AC_ERROR([error compiling test module])
+ fi
+
+ dnl ** link to library
+-./libtool --mode=link $CC $CFLAGS $LDFLAGS -rpath /usr/lib conftest.lo -lm -o libconftest.la > /dev/null
++./*libtool --mode=link $CC $CFLAGS $LDFLAGS -rpath /usr/lib conftest.lo -lm -o libconftest.la > /dev/null
+ if test ! -s .libs/libconftest.a; then
+ AC_ERROR([error, can't even find .a library])
+ fi
+@@ -755,14 +740,14 @@
+ perl_module_fe_lib=
+ perl_static_lib=libperl_core_static.la
+ perl_static_fe_lib=libfe_perl_static.la
+- PERL_LIBTOOL='$(SHELL) $(top_builddir)/libtool'
++ PERL_LIBTOOL="$LIBTOOL"
+ else
+ dnl * build dynamic library of perl module
+ perl_module_lib=libperl_core.la
+ perl_module_fe_lib=libfe_perl.la
+ perl_static_lib=
+ perl_static_fe_lib=
+- PERL_LIBTOOL='$(SHELL) $(top_builddir)/libtool'
++ PERL_LIBTOOL="$LIBTOOL"
+ fi
+
+ if test "x$want_staticperllib" = "xyes"; then
diff --git a/recipes/irssi/irssi_0.8.10.bb b/recipes/irssi/irssi_0.8.10.bb
new file mode 100644
index 0000000000..f67e8fe9c5
--- /dev/null
+++ b/recipes/irssi/irssi_0.8.10.bb
@@ -0,0 +1,66 @@
+DESCRIPTION = "Irssi is a modular IRC client with Perl scripting."
+HOMEPAGE = "http://irssi.org/"
+SECTION = "console/network"
+LICENSE = "GPL"
+DEPENDS += "ncurses glib-2.0"
+PR = "r2"
+
+PACKAGES += "${PN}-common"
+FILES_${PN} = "${bindir}/irssi"
+FILES_${PN}-common = "${datadir}/irssi ${sysconfdir}"
+RDEPENDS_${PN} += "${PN}-common"
+
+inherit autotools
+
+SRC_URI = "http://www.irssi.org/files/${P}.tar.bz2 \
+ file://autofoo.patch;patch=1"
+
+EXTRA_OECONF = "--enable-ipv6 \
+ --disable-ssl \
+ --disable-glibtest \
+ --without-socks \
+ --with-textui \
+ --without-bot \
+ --without-proxy \
+ --without-glib1 \
+ --with-glib2 \
+ --with-perl=no \
+ --with-glib-prefix=${STAGING_LIBDIR}/.. \
+ --with-glib-exec-prefix=${STAGING_LIBDIR}/.. \
+ --with-ncurses=${STAGING_LIBDIR}/.."
+
+do_configure () {
+ # create help files
+ echo "Creating help files..."
+ perl syntax.pl
+
+ files=`echo docs/help/in/*.in|sed -e 's,docs/help/in/Makefile.in ,,' -e 's,docs/help/in/,!,g' -e 's/\.in /.in ?/g'`
+ cat docs/help/in/Makefile.am.gen|sed "s/@HELPFILES@/$files/g"|sed 's/?/\\?/g'|tr '!?' '\t\n' > docs/help/in/Makefile.am
+
+ files=`echo $files|sed 's/\.in//g'`
+ cat docs/help/Makefile.am.gen|sed "s/@HELPFILES@/$files/g"|sed 's/?/\\?/g'|tr '!?' '\t\n' > docs/help/Makefile.am
+
+ # .HTML -> .txt with lynx
+ # echo "Documentation: html -> txt..."
+ # lynx -dump -nolist docs/faq.html|perl -pe 's/^ *//; if ($_ eq "\n" && $state eq "Q") { $_ = ""; } elsif (/^([QA]):/) { $state = $1 } elsif ($_ ne "\n") { $_ = " $_"; };' > docs/faq.txt
+ > docs/faq.txt
+
+ autotools_do_configure
+}
+
+do_stage () {
+ find . -name \*.h | for h in `cat`; do
+ install -d ${STAGING_LIBDIR}/../irssi/`dirname $h`
+ install -m 0644 $h ${STAGING_LIBDIR}/../irssi/$h
+ done
+ find . -name lib\*.a | for l in `cat`; do
+ install -d ${STAGING_LIBDIR}/../irssi/`dirname $l`
+ install -m 0644 $l ${STAGING_LIBDIR}/../irssi/$l
+ done
+ install -m 0644 irssi-config ${STAGING_LIBDIR}/../irssi/
+}
+
+do_install () {
+ autotools_do_install
+ rm -f ${D}${docdir}/irssi/faq.txt
+}
diff --git a/recipes/irssi/irssi_svn.bb b/recipes/irssi/irssi_svn.bb
new file mode 100644
index 0000000000..1fc31515d9
--- /dev/null
+++ b/recipes/irssi/irssi_svn.bb
@@ -0,0 +1,74 @@
+DESCRIPTION = "Irssi is a modular IRC client with Perl scripting."
+HOMEPAGE = "http://irssi.org/"
+SECTION = "console/network"
+LICENSE = "GPL"
+DEPENDS += "ncurses glib-2.0"
+PV = "0.8.11+svn${SRCDATE}"
+PR = "r4"
+
+DEFAULT_PREFERENCE = "-1"
+
+PACKAGES += "${PN}-common"
+FILES_${PN} = "${bindir}/irssi"
+FILES_${PN}-common = "${datadir}/irssi ${sysconfdir}"
+RDEPENDS_${PN} += "${PN}-common"
+
+inherit autotools
+
+SVN_REPO_URI = "http://svn.irssi.org/repos/irssi/trunk"
+SRC_URI = "svn://svn.irssi.org/repos/irssi/;module=trunk;proto=http \
+ "
+S = "${WORKDIR}/trunk"
+
+EXTRA_OECONF = "--enable-ipv6 \
+ --disable-ssl \
+ --disable-glibtest \
+ --without-socks \
+ --with-textui \
+ --without-bot \
+ --without-proxy \
+ --without-glib1 \
+ --with-glib2 \
+ --with-perl=no \
+ --with-glib-prefix=${STAGING_LIBDIR}/.. \
+ --with-glib-exec-prefix=${STAGING_LIBDIR}/.. \
+ --with-ncurses=${STAGING_LIBDIR}/.."
+
+do_configure () {
+ # create the ChangeLog file that hold irssi date and time version
+ TZ=UTC svn log -v "${SVN_REPO_URI}" > ChangeLog
+
+ # create help files
+ echo "Creating help files..."
+ perl syntax.pl
+
+ files=`echo docs/help/in/*.in|sed -e 's,docs/help/in/Makefile.in ,,' -e 's,docs/help/in/,!,g' -e 's/\.in /.in ?/g'`
+ cat docs/help/in/Makefile.am.gen|sed "s/@HELPFILES@/$files/g"|sed 's/?/\\?/g'|tr '!?' '\t\n' > docs/help/in/Makefile.am
+
+ files=`echo $files|sed 's/\.in//g'`
+ cat docs/help/Makefile.am.gen|sed "s/@HELPFILES@/$files/g"|sed 's/?/\\?/g'|tr '!?' '\t\n' > docs/help/Makefile.am
+
+ # .HTML -> .txt with lynx
+ # echo "Documentation: html -> txt..."
+ # lynx -dump -nolist docs/faq.html|perl -pe 's/^ *//; if ($_ eq "\n" && $state eq "Q") { $_ = ""; } elsif (/^([QA]):/) { $state = $1 } elsif ($_ ne "\n") { $_ = " $_"; };' > docs/faq.txt
+ > docs/faq.txt
+
+ autotools_do_configure
+}
+
+do_stage () {
+ find . -name \*.h | for h in `cat`; do
+ install -d ${STAGING_LIBDIR}/../irssi/`dirname $h`
+ install -m 0644 $h ${STAGING_LIBDIR}/../irssi/$h
+ done
+ find . -name lib\*.a | for l in `cat`; do
+ install -d ${STAGING_LIBDIR}/../irssi/`dirname $l`
+ install -m 0644 $l ${STAGING_LIBDIR}/../irssi/$l
+ done
+ install -m 0644 irssi-config ${STAGING_LIBDIR}/../irssi/
+}
+
+do_install () {
+ autotools_do_install
+ rm -f ${D}${docdir}/irssi/faq.txt
+}
diff --git a/recipes/irssi/xirssi_cvs.bb b/recipes/irssi/xirssi_cvs.bb
new file mode 100644
index 0000000000..e6c0057fb9
--- /dev/null
+++ b/recipes/irssi/xirssi_cvs.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Xirssi is an X frontend to the modular IRC client irssi."
+HOMEPAGE = "http://irssi.org/"
+SECTION = "x11/network"
+LICENSE = "GPL"
+DEPENDS += "irssi gtk+"
+RDEPENDS_${PN} += "irssi-common"
+PV = "0.0+cvs${SRCDATE}"
+PR = "r2"
+
+inherit autotools
+
+SRC_URI = "cvs://anonymous:@cvs.irssi.org/home/cvs;module=xirssi"
+S = "${WORKDIR}/xirssi"
+
+EXTRA_OECONF = "--with-irssi=${STAGING_LIBDIR}/../irssi"