aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ivman/ivman_0.6.14.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ivman/ivman_0.6.14.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ivman/ivman_0.6.14.bb')
-rw-r--r--recipes/ivman/ivman_0.6.14.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/ivman/ivman_0.6.14.bb b/recipes/ivman/ivman_0.6.14.bb
new file mode 100644
index 0000000000..ecc4665b9b
--- /dev/null
+++ b/recipes/ivman/ivman_0.6.14.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Daemon to mount/unmount devices, based on info from HAL"
+HOMEPAGE = "http://ivman.sf.net"
+LICENSE = "GPLv2"
+PR = "r1"
+
+DEPENDS = "hal libxml2"
+RDEPENDS = "hal pmount-hal"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ivman/${P}.tar.bz2 \
+ file://ivman-0.6-hotpluggable.patch;patch=1 \
+ file://ivman-launch.patch;patch=1 "
+
+inherit autotools
+
+# Add user ivman into group plugdev
+pkg_postinst_${PN} () {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+
+ grep "^ivman:" /etc/passwd > /dev/null || \
+ adduser --disabled-password --system --home /dev/null \
+ --no-create-home --ingroup plugdev -s /bin/false \
+ -g "IVMAN" ivman
+ /etc/init.d/populate-volatile.sh update
+}
+
+pkg_postrm_${PN} () {
+ deluser ivman || true
+}