aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jakarta-libs
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:39:36 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:39:36 +0200
commita80a0cb84d7b898d4fd8d560136b28f526915327 (patch)
tree021c52eef3f622bbd3ab52c25dca77dd697c855a /recipes/jakarta-libs
parent4e0f215f2be53b7471d86681765a0c8c1e95d98c (diff)
downloadopenembedded-a80a0cb84d7b898d4fd8d560136b28f526915327.tar.gz
logkit 1.2.2: New recipe (from Jalimo SVN).
logkit-native 1.2.2: Dito.
Diffstat (limited to 'recipes/jakarta-libs')
-rw-r--r--recipes/jakarta-libs/logkit-native_1.2.2.bb6
-rw-r--r--recipes/jakarta-libs/logkit_1.2.2.bb25
2 files changed, 31 insertions, 0 deletions
diff --git a/recipes/jakarta-libs/logkit-native_1.2.2.bb b/recipes/jakarta-libs/logkit-native_1.2.2.bb
new file mode 100644
index 0000000000..479f597a32
--- /dev/null
+++ b/recipes/jakarta-libs/logkit-native_1.2.2.bb
@@ -0,0 +1,6 @@
+require logkit_${PV}.bb
+
+inherit java-native
+
+DEPENDS = "fastjar-native oro-native servlet2.3-native gnumail-native gnujaf-native log4j1.2-native avalon-framework-api-native"
+
diff --git a/recipes/jakarta-libs/logkit_1.2.2.bb b/recipes/jakarta-libs/logkit_1.2.2.bb
new file mode 100644
index 0000000000..58d496cd08
--- /dev/null
+++ b/recipes/jakarta-libs/logkit_1.2.2.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Logging toolkit designed for secure performance orientated logging in Java applications"
+LICENSE = "AL2.0"
+AUTHOR = "Apache Software Foundation"
+
+SRC_URI = "http://www.apache.org/dist/avalon/logkit/source/${BP}-src.tar.gz"
+
+inherit java-library
+
+S = "${WORKDIR}/${BP}-dev"
+
+DEPENDS = "fastjar-native oro servlet2.3 gnumail gnujaf log4j1.2 avalon-framework-api"
+
+do_compile() {
+ mkdir -p build
+
+ oe_makeclasspath cp -s oro servlet-2.3 activation gnumail log4j-1.2 avalon-framework-api
+
+ # Built everything but the JMS and JMX classes (like in Debian)
+ javac -encoding ISO8859-1 -sourcepath src/java -cp $cp -d build \
+ `find src/java -name \*.java -and -not \( -iwholename "*jms*" -or -wholename "*test*" \)`
+
+ (cd src/java && find . -name "*.properties" -exec cp {} ../../build/{} \;)
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}