aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jakarta-libs
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-18 16:43:51 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-18 16:43:51 +0200
commitf6c552dcea001e78ec461bfa488508404fcbcdac (patch)
treeaaf6125c09ff50e17dcb20bce53ac488822332cf /recipes/jakarta-libs
parent2e7c334a4f6b0882ee90c8be91f81d24e4d82496 (diff)
downloadopenembedded-f6c552dcea001e78ec461bfa488508404fcbcdac.tar.gz
poi 3.0: New recipe (from Jalimo SVN).
Diffstat (limited to 'recipes/jakarta-libs')
-rw-r--r--recipes/jakarta-libs/poi_3.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/jakarta-libs/poi_3.0.bb b/recipes/jakarta-libs/poi_3.0.bb
new file mode 100644
index 0000000000..9538861930
--- /dev/null
+++ b/recipes/jakarta-libs/poi_3.0.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Java library for manipulating various file formats based upon Microsoft's OLE 2 Compound Document"
+LICENSE = "AL2.0"
+AUTHOR = "Apache Software Foundation"
+
+SRC_URI = "http://www.apache.org/dist/jakarta/poi/release/src/${BPN}-src-${PV}-FINAL-20070503.tar.gz"
+
+S = "${WORKDIR}/${BPN}-3.0-rc4"
+
+inherit java-library
+
+DEPENDS = "fastjar-native commons-collections3 commons-logging commons-lang commons-beanutils log4j1.2 xalan-j"
+
+do_compile() {
+ mkdir -p build
+
+ oe_makeclasspath cp -s commons-collections3 commons-logging commons-lang commons-beanutils log4j-1.2 xalan2
+
+ javac -sourcepath src/java -cp $cp -d build \
+ `find src/java -name \*.java`
+
+ (cd src/java && find . -name "*.properties" -exec cp {} ../../build/{} \;)
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}