aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jhead
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/jhead
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/jhead')
-rw-r--r--recipes/jhead/jhead_2.6.0.bb18
-rw-r--r--recipes/jhead/makefile.patch22
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes/jhead/jhead_2.6.0.bb b/recipes/jhead/jhead_2.6.0.bb
new file mode 100644
index 0000000000..3779c1ec34
--- /dev/null
+++ b/recipes/jhead/jhead_2.6.0.bb
@@ -0,0 +1,18 @@
+SECTION = "apps"
+PR = "r0"
+
+SRC_URI = "http://www.sentex.net/~mwandel/jhead/jhead-2.6.tar.gz \
+ file://makefile.patch;patch=1"
+
+S = "${WORKDIR}/jhead-2.6"
+
+inherit autotools
+
+do_configure() {
+ :
+}
+
+do_install() {
+ install -d ${D}/bin
+ autotools_do_install
+}
diff --git a/recipes/jhead/makefile.patch b/recipes/jhead/makefile.patch
new file mode 100644
index 0000000000..1d7b8e0f11
--- /dev/null
+++ b/recipes/jhead/makefile.patch
@@ -0,0 +1,22 @@
+--- jhead-2.6/makefile 2006-04-29 16:14:59.000000000 -0700
++++ jhead-2.6/makefile 2006-08-17 07:59:14.000000000 -0700
+@@ -3,13 +3,18 @@
+ #--------------------------------
+ OBJ=.
+ SRC=.
++DESTDIR=/usr
++bindir=/bin
+
+ all: jhead
+
+ objs = $(OBJ)/jhead.o $(OBJ)/jpgfile.o $(OBJ)/exif.o $(OBJ)/gpsinfo.o $(OBJ)/makernote.o
+
+ $(OBJ)/%.o:$(SRC)/%.c
+- ${CC} -O3 -Wall -c $< -o $@
++ ${CC} ${CFLAGS} -c $< -o $@
+
+ jhead: $(objs) jhead.h
+ ${CC} -o jhead $(objs) -lm
++
++install: jhead
++ install -m 755 jhead $(DESTDIR)$(bindir)/jhead