aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jikes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-05-14 17:36:41 +0200
committerKoen Kooi <koen@openembedded.org>2010-05-14 18:16:01 +0200
commit5267ad977d6242e507e4537769b0c04c1f6831ff (patch)
treef0d0f896ee93f0fdd8f269cfb609153cdde6de5c /recipes/jikes
parenta7756ec75b735de3900627f7786a74f9d91d3971 (diff)
downloadopenembedded-5267ad977d6242e507e4537769b0c04c1f6831ff.tar.gz
jikes-initial: make it build with new style staging
Diffstat (limited to 'recipes/jikes')
-rw-r--r--recipes/jikes/jikes-initial.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes/jikes/jikes-initial.bb b/recipes/jikes/jikes-initial.bb
index 0e2f4d0748..bf2fdd1168 100644
--- a/recipes/jikes/jikes-initial.bb
+++ b/recipes/jikes/jikes-initial.bb
@@ -2,8 +2,6 @@ SUMMARY = "Initial Java 1.4-compatible (and not higher) compiler"
DEPENDS = "jikes-native classpath-initial"
-SRC_URI = ""
-
S = "${WORKDIR}"
inherit native
@@ -17,7 +15,9 @@ do_compile() {
echo "${STAGING_BINDIR_NATIVE}/jikes -bootclasspath ${STAGING_DATADIR_NATIVE}/classpath-initial/glibj.zip \$@" >> jikes-initial
}
-do_stage() {
- install -d ${STAGING_BINDIR}
- install -m 0755 jikes-initial ${STAGING_BINDIR}
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 jikes-initial ${D}${bindir}
}
+
+NATIVE_INSTALL_WORKS = "1"