aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jikes
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/jikes
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/jikes')
-rw-r--r--recipes/jikes/files/dummy0
-rw-r--r--recipes/jikes/files/javac.jikes2
-rw-r--r--recipes/jikes/jikes-initial.bb23
-rw-r--r--recipes/jikes/jikes-native_1.21.bb9
-rw-r--r--recipes/jikes/jikes_1.21.bb16
-rw-r--r--recipes/jikes/jikes_1.22.bb27
6 files changed, 77 insertions, 0 deletions
diff --git a/recipes/jikes/files/dummy b/recipes/jikes/files/dummy
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/recipes/jikes/files/dummy
diff --git a/recipes/jikes/files/javac.jikes b/recipes/jikes/files/javac.jikes
new file mode 100644
index 0000000000..8650d177a9
--- /dev/null
+++ b/recipes/jikes/files/javac.jikes
@@ -0,0 +1,2 @@
+#!/bin/sh
+jikes -bootclasspath /usr/share/classpath/glibj.zip $@
diff --git a/recipes/jikes/jikes-initial.bb b/recipes/jikes/jikes-initial.bb
new file mode 100644
index 0000000000..0e2f4d0748
--- /dev/null
+++ b/recipes/jikes/jikes-initial.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Initial Java 1.4-compatible (and not higher) compiler"
+
+DEPENDS = "jikes-native classpath-initial"
+
+SRC_URI = ""
+
+S = "${WORKDIR}"
+
+inherit native
+
+do_configure() {
+ :
+}
+
+do_compile() {
+ echo "#!/bin/sh" > jikes-initial
+ echo "${STAGING_BINDIR_NATIVE}/jikes -bootclasspath ${STAGING_DATADIR_NATIVE}/classpath-initial/glibj.zip \$@" >> jikes-initial
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 0755 jikes-initial ${STAGING_BINDIR}
+}
diff --git a/recipes/jikes/jikes-native_1.21.bb b/recipes/jikes/jikes-native_1.21.bb
new file mode 100644
index 0000000000..b95cbfcd75
--- /dev/null
+++ b/recipes/jikes/jikes-native_1.21.bb
@@ -0,0 +1,9 @@
+inherit native
+require jikes_${PV}.bb
+
+S = "${WORKDIR}/jikes-${PV}"
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 755 src/jikes ${STAGING_BINDIR}
+}
diff --git a/recipes/jikes/jikes_1.21.bb b/recipes/jikes/jikes_1.21.bb
new file mode 100644
index 0000000000..c7a8c6afe7
--- /dev/null
+++ b/recipes/jikes/jikes_1.21.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Java compiler adhering to language and VM specifications"
+HOMEPAGE = "http://jikes.sourceforge.net/"
+PRIORITY = "optional"
+SECTION = "devel"
+LICENSE = "IBM"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/jikes/jikes-${PV}.tar.bz2"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-fp-emulation"
+
+# configure script incorrectly defines these when cross compiling for ARM
+CXXFLAGS_append_arm += "-UHAVE_64BIT_TYPES -DWORDS_BIGENDIAN=1"
+
diff --git a/recipes/jikes/jikes_1.22.bb b/recipes/jikes/jikes_1.22.bb
new file mode 100644
index 0000000000..02de9d577e
--- /dev/null
+++ b/recipes/jikes/jikes_1.22.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Java compiler adhering to language and VM specifications"
+HOMEPAGE = "http://jikes.sourceforge.net/"
+PRIORITY = "optional"
+SECTION = "devel"
+LICENSE = "IBM"
+PR = "r1"
+
+RDEPENDS = "classpath"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/jikes/jikes-${PV}.tar.bz2"
+
+inherit autotools update-alternatives
+
+EXTRA_OECONF = "--disable-fp-emulation --enable-source15"
+
+# configure script incorrectly defines these when cross compiling for ARM
+CXXFLAGS_append_arm += "-UHAVE_64BIT_TYPES -DWORDS_BIGENDIAN=1"
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+ ln -s ${bindir}/jikes ${D}${bindir}/javac.jikes
+}
+
+PROVIDES = "virtual/javac"
+ALTERNATIVE_NAME = "javac"
+ALTERNATIVE_LINK = "/usr/bin/javac"
+ALTERNATIVE_PATH = "${bindir}/javac.jikes"