aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jpeg
diff options
context:
space:
mode:
authorDmitry Artamonow <mad_soft@inbox.ru>2010-06-23 07:00:36 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-08-20 08:37:05 +0200
commit6dc630a920d058616cc2f685237a08f30b7b7f19 (patch)
tree1947c75cea3ae41471328101924e05a2148ce09f /recipes/jpeg
parentcd50f53c6def80f2ec014b5e7492d580ffc1291a (diff)
downloadopenembedded-6dc630a920d058616cc2f685237a08f30b7b7f19.tar.gz
openjpeg-1.3: new recipe
The OpenJPEG library is an open-source JPEG 2000 codec written in C language. Signed-off-by: Dmitry Artamonow <mad_soft@inbox.ru> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/jpeg')
-rw-r--r--recipes/jpeg/openjpeg-1.3/fix_installdir.patch19
-rw-r--r--recipes/jpeg/openjpeg_1.3.bb21
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes/jpeg/openjpeg-1.3/fix_installdir.patch b/recipes/jpeg/openjpeg-1.3/fix_installdir.patch
new file mode 100644
index 0000000000..f04a81e6e0
--- /dev/null
+++ b/recipes/jpeg/openjpeg-1.3/fix_installdir.patch
@@ -0,0 +1,19 @@
+* status: pending
+* origin:
+ http://groups.google.com/group/openjpeg/browse_thread/thread/4cd7b53fbaab2822
+* comment: slightly modified patch by Patrick Reynolds, borrowed from
+ the thread above. Seems that it's not in upstream yet.
+ Had to modify header location from /usr/include/openjpeg/openjpeg.h to
+ /usr/include/openjpeg.h , as it's the only one header file anyway and
+ most of its users expect #include <openjpeg.h> to work.
+
+Index: libopenjpeg/CMakeLists.txt
+===================================================================
+--- a/libopenjpeg/CMakeLists.txt (revision 541)
++++ b/libopenjpeg/CMakeLists.txt (working copy)
+@@ -41,4 +41,4 @@
+
+ # Install includes files
+ INSTALL(FILES openjpeg.h
+- DESTINATION ${INCLUDE_INSTALL_DIR}/openjpeg)
++ DESTINATION include)
diff --git a/recipes/jpeg/openjpeg_1.3.bb b/recipes/jpeg/openjpeg_1.3.bb
new file mode 100644
index 0000000000..c72090f015
--- /dev/null
+++ b/recipes/jpeg/openjpeg_1.3.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Open-source JPEG 2000 codec written in C language"
+HOMEPAGE = "http://www.openjpeg.org"
+SECTION = "libs"
+LICENSE = "BSD"
+PR = "r0"
+BBCLASSEXTEND = "native"
+
+SRC_URI = "http://openjpeg.googlecode.com/files/openjpeg_v1_3.tar.gz \
+ file://fix_installdir.patch"
+
+S = "${WORKDIR}/OpenJPEG_v1_3"
+
+inherit cmake
+
+EXTRA_OECMAKE="-DBUILD_SHARED_LIBS:BOOL=ON"
+
+PACKAGES =+ "openjpeg-tools "
+FILES_openjpeg-tools = "${bindir}/*"
+
+SRC_URI[md5sum] = "f9a3ccfa91ac34b589e9bf7577ce8ff9"
+SRC_URI[sha256sum] = "3bca2e1e040f9dcbbcb1e0627f17a76eeb95e153bf663d082070c044a21202bd"