aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jpeg
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-03-28 12:08:29 +0200
committerKoen Kooi <koen@openembedded.org>2010-03-28 12:08:29 +0200
commit76021992e1a7ddfb98f55a1c75deb780146542a0 (patch)
tree123c2269a65514c112f8e6684e17a1d9af824309 /recipes/jpeg
parentab33236cff6f5520c9e6c277984100bb4fc79eb1 (diff)
downloadopenembedded-76021992e1a7ddfb98f55a1c75deb780146542a0.tar.gz
jpeg: convert to new-style staging and use BBCLASSEXTEND for -native
Diffstat (limited to 'recipes/jpeg')
-rw-r--r--recipes/jpeg/jpeg-native_6b.bb14
-rw-r--r--recipes/jpeg/jpeg_6b.bb14
2 files changed, 3 insertions, 25 deletions
diff --git a/recipes/jpeg/jpeg-native_6b.bb b/recipes/jpeg/jpeg-native_6b.bb
deleted file mode 100644
index 450e4b36a7..0000000000
--- a/recipes/jpeg/jpeg-native_6b.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-SECTION = "libs"
-require jpeg_${PV}.bb
-inherit native
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/jpeg-${PV}"
-DEPENDS = ""
-
-do_stage() {
- install -m 644 jconfig.h ${STAGING_INCDIR}/jconfig.h
- install -m 644 jpeglib.h ${STAGING_INCDIR}/jpeglib.h
- install -m 644 jmorecfg.h ${STAGING_INCDIR}/jmorecfg.h
- install -m 644 jerror.h ${STAGING_INCDIR}/jerror.h
- install -m 644 jpegint.h ${STAGING_INCDIR}/jpegint.h
- oe_libinstall -so libjpeg ${STAGING_LIBDIR}
-}
diff --git a/recipes/jpeg/jpeg_6b.bb b/recipes/jpeg/jpeg_6b.bb
index fde5272dbc..d676ef843a 100644
--- a/recipes/jpeg/jpeg_6b.bb
+++ b/recipes/jpeg/jpeg_6b.bb
@@ -6,7 +6,7 @@ PRIORITY = "required"
DEPENDS = "libtool-cross"
RPROVIDES_${PN} = "jpeg"
-PR = "r8"
+PR = "r9"
#SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
SRC_URI = "ftp://aeneas.mit.edu/pub/gnu/ghostscript/jpegsrc.v${PV}.tar.gz \
@@ -28,15 +28,6 @@ do_configure_prepend () {
rm -f ${S}/ltmain.sh
}
-do_stage() {
- install -m 644 jconfig.h ${STAGING_INCDIR}/jconfig.h
- install -m 644 jpeglib.h ${STAGING_INCDIR}/jpeglib.h
- install -m 644 jmorecfg.h ${STAGING_INCDIR}/jmorecfg.h
- install -m 644 jerror.h ${STAGING_INCDIR}/jerror.h
- install -m 644 jpegint.h ${STAGING_INCDIR}/jpegint.h
- oe_libinstall -so libjpeg ${STAGING_LIBDIR}
-}
-
do_install() {
install -d ${D}${bindir} ${D}${includedir} \
${D}${mandir}/man1 ${D}${libdir}
@@ -46,4 +37,5 @@ do_install() {
PACKAGES =+ "jpeg-tools "
FILES_jpeg-tools = "${bindir}/*"
-
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"