summaryrefslogtreecommitdiffstats
path: root/recipes/juce/juce_1.29.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/juce/juce_1.29.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/juce/juce_1.29.bb')
-rw-r--r--recipes/juce/juce_1.29.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/juce/juce_1.29.bb b/recipes/juce/juce_1.29.bb
new file mode 100644
index 0000000000..6aca160262
--- /dev/null
+++ b/recipes/juce/juce_1.29.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "JUCE is a cross-platform application framework"
+HOMEPAGE = "http://www.rawmaterialsoftware.com/juce"
+AUTHOR = "Julian Stoerer"
+LICENSE = "GPL"
+DEPENDS = "alsa-lib freetype virtual/libx11"
+PR = "r0"
+
+#FIXME the patches are a) HACKS and b) something's wrong with lineend conversion
+SRC_URI = "http://downloads.openmoko.org/sources/juce_${@bb.data.getVar('PV',d,1).split('.')[0]}_${@bb.data.getVar('PV',d,1).split('.')[1]}.zip \
+ file://remove-x86isms.patch;patch=1 \
+ file://no-opengl.patch;patch=1"
+S = "${WORKDIR}/juce"
+
+LIB = "libjuce_debug"
+
+do_compile() {
+ cd ${S}/build/linux && oe_runmake
+ cd ${S}/demo/build/linux && oe_runmake
+}
+
+do_stage() {
+ oe_libinstall -a -C bin ${LIB} ${STAGING_LIBDIR}
+ #FIXME add includes
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0655 demo/build/linux/build/jucedemo ${D}${bindir}
+}
+
+PACKAGES = "${PN}-dbg jucedemo ${PN}"
+FILES_jucedemo = "${bindir}"
+