aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kanatest
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/kanatest
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/kanatest')
-rw-r--r--recipes/kanatest/files/kanatest.desktop12
-rw-r--r--recipes/kanatest/kanatest.inc14
-rw-r--r--recipes/kanatest/kanatest_0.3.6.bb8
3 files changed, 34 insertions, 0 deletions
diff --git a/recipes/kanatest/files/kanatest.desktop b/recipes/kanatest/files/kanatest.desktop
new file mode 100644
index 0000000000..9f31bffb33
--- /dev/null
+++ b/recipes/kanatest/files/kanatest.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Hiragana and Katakana Test
+Name[es]=Prueba de Hiragana y Katakana
+Comment=Hiragana and Katakana drill tool
+Comment[es]=Herramienta de entrenamiento en Hiragana y Katakana
+Exec=kanatest
+Icon=kanatest.png
+Terminal=false
+Type=Application
+StartupNotify=true
+Categories=Application;Game;
diff --git a/recipes/kanatest/kanatest.inc b/recipes/kanatest/kanatest.inc
new file mode 100644
index 0000000000..254091c60c
--- /dev/null
+++ b/recipes/kanatest/kanatest.inc
@@ -0,0 +1,14 @@
+SECTION = "gpe/games"
+DESCRIPTION = "Hiragana and Katakana drill tool"
+LICENSE = "GPL"
+
+DEPENDS = "gtk+"
+
+FILES_${PN} = "${bindir}/${PN} ${datadir}/${PN} ${datadir}/pixmaps ${datadir}/applications"
+
+inherit autotools gettext
+
+do_install_append () {
+ install -d ${D}${datadir}/applications/
+ install -m 0644 ${WORKDIR}/${PN}.desktop ${D}${datadir}/applications/${PN}.desktop
+}
diff --git a/recipes/kanatest/kanatest_0.3.6.bb b/recipes/kanatest/kanatest_0.3.6.bb
new file mode 100644
index 0000000000..f0b17a2af9
--- /dev/null
+++ b/recipes/kanatest/kanatest_0.3.6.bb
@@ -0,0 +1,8 @@
+PR = "r0"
+
+SRC_URI = "http://clay.ll.pl/download/${PN}-${PV}.tar.gz file://${PN}.desktop"
+
+require kanatest.inc
+
+CFLAGS += "-D_GNU_SOURCE"
+