aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kanjipad
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/kanjipad
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/kanjipad')
-rw-r--r--recipes/kanjipad/files/Makefile-kpengine-only.patch38
-rw-r--r--recipes/kanjipad/kanjipad.inc13
-rw-r--r--recipes/kanjipad/kanjipad_svn.bb12
-rw-r--r--recipes/kanjipad/kpengine_0.1.bb9
4 files changed, 72 insertions, 0 deletions
diff --git a/recipes/kanjipad/files/Makefile-kpengine-only.patch b/recipes/kanjipad/files/Makefile-kpengine-only.patch
new file mode 100644
index 0000000000..5ea650e4e7
--- /dev/null
+++ b/recipes/kanjipad/files/Makefile-kpengine-only.patch
@@ -0,0 +1,38 @@
+--- kanjipad-2.0.0.orig/Makefile 2002-08-25 21:00:54 +0200
++++ kanjipad-2.0.0/Makefile 2005-08-07 23:04:03 +0200
+@@ -5,7 +5,7 @@
+ GTKLIBS=$(shell pkg-config --libs gtk+-2.0)
+ GLIBLIBS=$(shell pkg-config --libs glib-2.0)
+
+-PREFIX=/usr/local
++PREFIX=/usr
+ DATADIR=$(PREFIX)/share
+
+ # location in which binaries are installed
+@@ -28,7 +28,7 @@
+ OBJS = kpengine.o scoring.o util.o
+ CFLAGS = $(OPTIMIZE) $(GTKINC) -DFOR_PILOT_COMPAT -DKP_LIBDIR=\"$(LIBDIR)\" -DBINDIR=\"$(BINDIR)\"
+
+-all: kpengine kanjipad jdata.dat
++all: kpengine jdata.dat
+
+ scoring.o: jstroke/scoring.c
+ $(CC) -c -o scoring.o $(CFLAGS) -Ijstroke jstroke/scoring.c
+@@ -45,9 +45,8 @@
+ jdata.dat: jstroke/strokedata.h conv_jdata.pl
+ perl conv_jdata.pl < jstroke/strokedata.h > jdata.dat
+
+-install: kanjipad kpengine jdata.dat
++install: kpengine jdata.dat
+ install -d $(DESTDIR)$(BINDIR)
+- install -m 0755 kanjipad $(DESTDIR)$(BINDIR)/kanjipad
+ install -m 0755 kpengine $(DESTDIR)$(BINDIR)/kpengine
+ install -d $(DESTDIR)$(LIBDIR)
+ install -m 0644 jdata.dat $(DESTDIR)$(LIBDIR)/jdata.dat
+@@ -75,4 +74,4 @@
+ cd .. && \
+ rm -rf $$distdir
+
+-.PHONY: dist distcheck
+\ No newline at end of file
++.PHONY: dist distcheck
diff --git a/recipes/kanjipad/kanjipad.inc b/recipes/kanjipad/kanjipad.inc
new file mode 100644
index 0000000000..bebd753495
--- /dev/null
+++ b/recipes/kanjipad/kanjipad.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "Hand-writing recognition for Japanese Kanji characters (no kana)"
+AUTHOR = "Owen Taylor <otaylor@fishsoup.net>"
+HOMEPAGE = "http://fishsoup.net/software/kanjipad/"
+SECTION = "inputmethods"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gtk+"
+
+SRC_URI="http://fishsoup.net/software/kanjipad/kanjipad-2.0.0.tar.gz"
+
+S = ${WORKDIR}/kanjipad-2.0.0/
+
+inherit autotools pkgconfig
diff --git a/recipes/kanjipad/kanjipad_svn.bb b/recipes/kanjipad/kanjipad_svn.bb
new file mode 100644
index 0000000000..73c6ddba0f
--- /dev/null
+++ b/recipes/kanjipad/kanjipad_svn.bb
@@ -0,0 +1,12 @@
+require kanjipad.inc
+
+DEPENDS += "perl-native"
+PV = "2.0.0+svn${SRCDATE}"
+PR = "r1"
+
+SRC_URI = "svn://svn.gnome.org/svn/${PN}/;module=trunk"
+S = "${WORKDIR}/trunk"
+
+do_compile_prepend() {
+ export CFLAGS='${TARGET_CFLAGS} -DFOR_PILOT_COMPAT -DKP_LIBDIR="${libdir}/kanjipad" -DBINDIR="${bindir}" `pkg-config --cflags gtk+-2.0` `pkg-config --cflags glib-2.0`'
+}
diff --git a/recipes/kanjipad/kpengine_0.1.bb b/recipes/kanjipad/kpengine_0.1.bb
new file mode 100644
index 0000000000..d9a6fee7d6
--- /dev/null
+++ b/recipes/kanjipad/kpengine_0.1.bb
@@ -0,0 +1,9 @@
+require kanjipad.inc
+
+DESCRIPTION = "Japanese HWR engine used by a number of programs. Original algorithms by Todd Ruddick."
+SECTION = "inputmethods"
+PR = "r1"
+
+SRC_URI += "file://Makefile-kpengine-only.patch;patch=1"
+
+FILES_${PN} = "${bindir}/kpengine ${datadir}"