aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kexecboot/linux-kexecboot_2.6.32.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-01-11 20:40:48 +0100
committerKoen Kooi <koen@openembedded.org>2010-01-11 20:41:39 +0100
commit8de6a61d4c0492b9b06b75f0ded80156105b3699 (patch)
tree7af1f682ea4c82b9e836d258c4d74fe8821bf8bf /recipes/kexecboot/linux-kexecboot_2.6.32.bb
parente6dd3f754d6bd130ce5a0dbbaad3dc0d06718746 (diff)
downloadopenembedded-8de6a61d4c0492b9b06b75f0ded80156105b3699.tar.gz
linux-kexecboot 2.6.32: add omap3 support
Diffstat (limited to 'recipes/kexecboot/linux-kexecboot_2.6.32.bb')
-rw-r--r--recipes/kexecboot/linux-kexecboot_2.6.32.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/kexecboot/linux-kexecboot_2.6.32.bb b/recipes/kexecboot/linux-kexecboot_2.6.32.bb
index 2839ff2928..fb137bb7ba 100644
--- a/recipes/kexecboot/linux-kexecboot_2.6.32.bb
+++ b/recipes/kexecboot/linux-kexecboot_2.6.32.bb
@@ -1,6 +1,7 @@
require linux-kexecboot.inc
S = "${WORKDIR}/linux-${PV}"
+S_omap3 = "${WORKDIR}/git"
# Mark archs/machines that this kernel supports
DEFAULT_PREFERENCE = "-1"
@@ -11,6 +12,9 @@ DEFAULT_PREFERENCE_poodle = "-1"
DEFAULT_PREFERENCE_spitz = "-1"
DEFAULT_PREFERENCE_tosa = "-1"
+DEFAULT_PREFERENCE_omap3 = "1"
+
+
SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2;name=kernel \
# file://v3-1-4-Add-support-for-LZO-compressed-kernels.patch;patch=1;status=pending \
# file://v3-2-4-Add-support-for-LZO-compressed-kernels-for-ARM.patch;patch=1;status=pending \
@@ -35,3 +39,32 @@ SRC_URI_append_collie = "${ZAURUSPATCHES}"
SRC_URI_append_poodle = "${ZAURUSPATCHES}"
SRC_URI_append_spitz = "${ZAURUSPATCHES}"
SRC_URI_append_tosa = "${ZAURUSPATCHES}"
+
+
+SRC_URI_append_omap3 = " git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git;rev=6833f1a8cdcb65a370f898bde6b6af63f81962df \
+file://defconfig \
+file://sctp-fix.patch;patch=1 \
+file://cm-t35/0001-omap3-cm-t35-add-mux-initialization.patch;patch=1 \
+file://cm-t35/0001-OMAP-DSS2-add-Toppoly-TDO35S-panel.patch;patch=1 \
+file://cm-t35/0002-omap3-cm-t35-add-DSS2-display-support.patch;patch=1 \
+file://cm-t35/0003-omap3-cm-t35-update-defconfig-for-DSS2.patch;patch=1 \
+file://cm-t35/0006-omap3-cm-t35-update-defconfig.patch;patch=1 \
+file://0001-ARM-OMAP-Overo-Add-support-for-second-ethernet-po.patch;patch=1 \
+file://0003-drivers-net-smsc911x-return-ENODEV-if-device-is-n.patch;patch=1 \
+file://0004-drivers-input-touchscreen-ads7846-return-ENODEV.patch;patch=1 \
+file://0005-ARM-OMAP-add-support-for-TCT-Zippy-to-Beagle-board.patch;patch=1 \
+file://0006-ARM-OMAP-Make-beagle-u-boot-partition-writable.patch;patch=1 \
+file://0007-ASoC-enable-audio-capture-by-default-for-twl4030.patch;patch=1 \
+file://0009-MTD-NAND-omap2-proper-fix-for-subpage-read-ECC-error.patch;patch=1 \
+file://madc/0009-drivers-mfd-add-twl4030-madc-driver.patch;patch=1 \
+file://madc/0010-ARM-OMAP-Add-twl4030-madc-support-to-Overo.patch;patch=1 \
+file://madc/0011-ARM-OMAP-Add-twl4030-madc-support-to-Beagle.patch;patch=1 \
+file://madc/0013-ARM-OMAP-Add-missing-twl4030-madc-header-file.patch;patch=1 \
+file://dss2/0012-OMAP-DSS2-Add-support-for-LG-Philips-LB035Q02-pane.patch;patch=1 \
+#file://dss2/0014-OMAP-DSS-Add-DSS2-support-for-Overo.patch;patch=1 \
+file://dss2/0015-OMAP-DSS-Add-DSS2-support-for-Beagle.patch;patch=1 \
+file://dss2/0016-video-add-timings-for-hd720.patch;patch=1 \
+"
+
+
+