aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kexecboot
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2010-10-10 01:41:11 +0200
committerAndrea Adami <andrea.adami@gmail.com>2010-10-21 00:48:39 +0200
commitac6200745d158e7dec283b698f6af763d2d8d010 (patch)
treea4597a98008b1a896dc602d5f20abb7312cb9edb /recipes/kexecboot
parent455a48017a2c23a845110bbedbbe404daea01eed (diff)
downloadopenembedded-ac6200745d158e7dec283b698f6af763d2d8d010.tar.gz
kexecboot: split kexecboot-klibc recipe and oe-stylize
Diffstat (limited to 'recipes/kexecboot')
-rw-r--r--recipes/kexecboot/kexecboot-cfg_0.1.bb33
-rw-r--r--recipes/kexecboot/kexecboot-klibc_git.bb13
-rw-r--r--recipes/kexecboot/kexecboot.inc25
-rw-r--r--recipes/kexecboot/kexecboot_git.bb3
4 files changed, 35 insertions, 39 deletions
diff --git a/recipes/kexecboot/kexecboot-cfg_0.1.bb b/recipes/kexecboot/kexecboot-cfg_0.1.bb
index 0287cc910d..ef16f31d36 100644
--- a/recipes/kexecboot/kexecboot-cfg_0.1.bb
+++ b/recipes/kexecboot/kexecboot-cfg_0.1.bb
@@ -1,44 +1,32 @@
-LICENSE = "GPL"
-SECTION = "base"
DESCRIPTION = "Configuration file for kexecboot"
-
+SECTION = "base"
+LICENSE = "GPL"
PR = "r9"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
SRC_URI = "file://icon.xpm"
CMDLINE_CON = "console=ttyS0,115200n8 console=tty1 noinitrd"
CMDLINE_CON_collie = "console=ttySA0,115200n8 console=tty1 noinitrd rw"
CMDLINE_CON_qemuarm = "console=ttyAMA0,115200n8 console=tty1 noinitrd"
-
CMDLINE_MEM = ""
CMDLINE_MEM_collie = "mem=64M"
-
CMDLINE_ROTATE = ""
CMDLINE_ROTATE_spitz = "fbcon=rotate:1"
CMDLINE_ROTATE_akita = "fbcon=rotate:1"
CMDLINE_ROTATE_collie = "fbcon=rotate:1"
CMDLINE_ROTATE_poodle = "fbcon=rotate:1"
-
-#CMDLINE_OTHER = "dyntick=enable"
CMDLINE_OTHER = ""
-
-CMDLINE_DEBUG = '${@base_conditional("DISTRO_TYPE", "release", "quiet", "debug",d)}'
-
-CMDLINE = ${CMDLINE_CON}
-CMDLINE += ${CMDLINE_MEM}
-CMDLINE += ${CMDLINE_ROTATE}
-CMDLINE += ${CMDLINE_OTHER}
-CMDLINE += ${CMDLINE_DEBUG}
-
-FILES_${PN} += "/boot/*"
+CMDLINE_DEBUG = "${@base_conditional('DISTRO_TYPE', 'release', 'quiet', 'debug',d)}"
+CMDLINE = "${CMDLINE_CON}"
+CMDLINE += "${CMDLINE_MEM}"
+CMDLINE += "${CMDLINE_ROTATE}"
+CMDLINE += "${CMDLINE_OTHER}"
+CMDLINE += "${CMDLINE_DEBUG}"
do_configure_prepend () {
install -m 0644 ${WORKDIR}/icon.xpm ${S}
}
-
do_install_prepend () {
-
echo '# Show this label in kexecboot menu.
LABEL=${DISTRO}
#
@@ -61,9 +49,12 @@ APPEND=${CMDLINE}
# PRIORITY=10
#' >> ${S}/boot.cfg
}
-
do_install () {
install -d ${D}/boot
install -m 0644 boot.cfg ${D}/boot/boot.cfg
install -m 0644 icon.xpm ${D}/boot/icon.xpm
}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+FILES_${PN} += "/boot/*"
diff --git a/recipes/kexecboot/kexecboot-klibc_git.bb b/recipes/kexecboot/kexecboot-klibc_git.bb
new file mode 100644
index 0000000000..d57f7e45d4
--- /dev/null
+++ b/recipes/kexecboot/kexecboot-klibc_git.bb
@@ -0,0 +1,13 @@
+RDEPENDS_${PN} = "kexec-klibc"
+PV = "0.5"
+PR = "r19+gitr${SRCREV}"
+
+SRC_URI = "git://git.linuxtogo.org/home/groups/kexecboot/kexecboot.git;protocol=git "
+
+SRCREV = "cd52db828d24a239698f142e9b028c6bc0d6a21a"
+S = "${WORKDIR}/git"
+
+# the binary is statically linked against klibc
+inherit klibc
+
+require kexecboot.inc
diff --git a/recipes/kexecboot/kexecboot.inc b/recipes/kexecboot/kexecboot.inc
index bdbc3a52bf..a55ff83b37 100644
--- a/recipes/kexecboot/kexecboot.inc
+++ b/recipes/kexecboot/kexecboot.inc
@@ -1,23 +1,13 @@
LICENSE = "GPL"
-# the binary is statically linked against klibc
-inherit klibc
-inherit autotools
-
-RDEPENDS_${PN} = "kexec-klibc"
-
-# The binary itself is not machine-specific
-# but the EXTRA_OECONF overrides have this effect
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
# You can create your own *-img.h by doing
# ./make-image-header.sh <file>.png HAND
+# Defaults as in ver 0.5+0.6b
-SRC_URI += "file://logo-img.h \
- file://logo.png \
- "
+SRC_URI += "file://logo-img.h file://logo.png"
+
+inherit autotools
-# Defaults as in ver 0.5+0.6b
#############################
# Optional Features:
# --disable-option-checking ignore unrecognized --enable/--with options
@@ -54,22 +44,23 @@ EXTRA_OECONF_c7x0 = "--with-zaurus"
EXTRA_OECONF_spitz = "--with-zaurus"
EXTRA_OECONF_poodle = "--with-zaurus"
EXTRA_OECONF_tosa = "--with-zaurus"
-
EXTRA_OECONF_omap3 = "--with-uimage"
do_configure_prepend () {
install -m 0644 ${WORKDIR}/logo-img.h ${S}/res/
install -m 0644 ${WORKDIR}/logo.png ${S}/res/
}
-
do_install () {
install -d ${D}${bindir}
install -m 0755 kexecboot ${D}${bindir}/
-
install -d ${D}/proc
install -d ${D}/mnt
}
+# The binary itself is not machine-specific
+# but the EXTRA_OECONF overrides have this effect
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt"
pkg_postinst_${PN} () {
diff --git a/recipes/kexecboot/kexecboot_git.bb b/recipes/kexecboot/kexecboot_git.bb
index 8a282a07c6..6a3f8fd59b 100644
--- a/recipes/kexecboot/kexecboot_git.bb
+++ b/recipes/kexecboot/kexecboot_git.bb
@@ -1,9 +1,10 @@
+RDEPENDS_${PN} = "kexec"
PV = "0.5"
PR = "r19+gitr${SRCREV}"
SRC_URI = "git://git.linuxtogo.org/home/groups/kexecboot/kexecboot.git;protocol=git "
-SRCREV = "cd52db828d24a239698f142e9b028c6bc0d6a21a"
+SRCREV = "cd52db828d24a239698f142e9b028c6bc0d6a21a"
S = "${WORKDIR}/git"
require kexecboot.inc