aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/keylaunch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/keylaunch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/keylaunch')
-rw-r--r--recipes/keylaunch/files/makefile-fix.patch15
-rw-r--r--recipes/keylaunch/files/unbreak-keyevents.patch24
-rw-r--r--recipes/keylaunch/keylaunch-conf/80chvt-SUID25
-rw-r--r--recipes/keylaunch/keylaunch-conf/akita/keylaunchrc28
-rw-r--r--recipes/keylaunch/keylaunch-conf/c7x0/keylaunchrc6
-rw-r--r--recipes/keylaunch/keylaunch-conf/collie/keylaunchrc0
-rw-r--r--recipes/keylaunch/keylaunch-conf/corgie/keylaunchrc6
-rw-r--r--recipes/keylaunch/keylaunch-conf/husky/keylaunchrc6
-rw-r--r--recipes/keylaunch/keylaunch-conf/keylaunchrc31
-rw-r--r--recipes/keylaunch/keylaunch-conf/shepherd/keylaunchrc6
-rw-r--r--recipes/keylaunch/keylaunch-conf/spitz/keylaunchrc28
-rw-r--r--recipes/keylaunch/keylaunch-conf_2.0.10.bb27
-rw-r--r--recipes/keylaunch/keylaunch_2.0.10.bb24
13 files changed, 226 insertions, 0 deletions
diff --git a/recipes/keylaunch/files/makefile-fix.patch b/recipes/keylaunch/files/makefile-fix.patch
new file mode 100644
index 0000000000..d9c57e05ac
--- /dev/null
+++ b/recipes/keylaunch/files/makefile-fix.patch
@@ -0,0 +1,15 @@
+--- keylaunch-2.0.10/Makefile.orig 2007-05-25 18:13:39.000000000 +0200
++++ keylaunch-2.0.10/Makefile 2007-05-25 18:15:47.000000000 +0200
+@@ -31,8 +31,10 @@
+ $(CC) $(LDFLAGS) $(OBJS) $(LIBS) -o $@
+
+ install-program: all
+- install -sD $(PROG) $(DESTDIR)$(PREFIX)/bin/$(PROG)
+- install -D -m 644 $(PROG)rc $(DESTDIR)/etc/$(PROG)rc
++ install -d $(DESTDIR)$(PREFIX)/bin
++ install -s $(PROG) $(DESTDIR)$(PREFIX)/bin/$(PROG)
++ install -d $(DESTDIR)/etc
++ install -m 644 $(PROG)rc $(DESTDIR)/etc/$(PROG)rc
+ install -d $(DESTDIR)/etc/X11/Xsession.d
+ install 90$(PROG) $(DESTDIR)/etc/X11/Xsession.d/90$(PROG)
+ install -d $(DESTDIR)/etc/X11/Xinit.d
diff --git a/recipes/keylaunch/files/unbreak-keyevents.patch b/recipes/keylaunch/files/unbreak-keyevents.patch
new file mode 100644
index 0000000000..ee13cc9a63
--- /dev/null
+++ b/recipes/keylaunch/files/unbreak-keyevents.patch
@@ -0,0 +1,24 @@
+upstream: http://bugs.linuxtogo.org/show_bug.cgi?id=123
+
+# HG changeset patch
+# User "Paul Sokolovsky <pfalcon@users.sourceforge.net>"
+# Date 1196027570 -7200
+# Node ID 282176e5c55dba673756b4707716f06a5c8b37e2
+# Parent 833c989472a7987681ea3b8cbd6f9eb77293177a
+We of course still want to receive key events even after subscribing to
+property events. This fixes when keylaunch doesn't receive forwarded
+power buttons events from gpe-login --autolock in its locked state.
+In plain words: now power button works with autolock screen.
+
+diff -r 833c989472a7 -r 282176e5c55d keylaunch.c
+--- a/keylaunch.c Sun Nov 25 22:04:29 2007 +0200
++++ b/keylaunch.c Sun Nov 25 23:52:50 2007 +0200
+@@ -682,7 +682,7 @@ main (int argc, char *argv[])
+ {
+ initialize (argc, argv);
+
+- XSelectInput (dpy, DefaultRootWindow (dpy), PropertyChangeMask);
++ XSelectInput (dpy, DefaultRootWindow (dpy), PropertyChangeMask | KeyPressMask | KeyReleaseMask);
+ gpe_launch_monitor_display (dpy);
+
+ signal (SIGCHLD, SIG_IGN);
diff --git a/recipes/keylaunch/keylaunch-conf/80chvt-SUID b/recipes/keylaunch/keylaunch-conf/80chvt-SUID
new file mode 100644
index 0000000000..e3b4efef5d
--- /dev/null
+++ b/recipes/keylaunch/keylaunch-conf/80chvt-SUID
@@ -0,0 +1,25 @@
+#! /bin/sh
+#
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
+# License: GPL (see http://www.gnu.org/licenses/gpl.txt for a copy of the license)
+#
+# Filename: chvt-SUID.sh
+# Date: 28-May-06
+
+
+#
+# Sets the SUID bit on chvt to allow changing to the VT from inside X by
+# any user. Since a SUID binary still is a security risk, we chmod only
+# when keylaunch is used and not by default.
+#
+
+for target in /usr/bin/chvt.console-tools
+do
+ if test "`ls -l "$target" | awk '{print $1}'|cut -c 2-4`" != "rws"
+ then
+ echo "Making [$target] SUID root..."
+ chmod u+s "$target"
+ else
+ echo "Ignoring [$target]"
+ fi
+done
diff --git a/recipes/keylaunch/keylaunch-conf/akita/keylaunchrc b/recipes/keylaunch/keylaunch-conf/akita/keylaunchrc
new file mode 100644
index 0000000000..9bb64db066
--- /dev/null
+++ b/recipes/keylaunch/keylaunch-conf/akita/keylaunchrc
@@ -0,0 +1,28 @@
+key=....F9:-:gpe-calendar
+key=....F10:-:gpe-contacts
+key=....F13:-:sylpheed
+key=....F12:-:~matchbox-remote -next
+key=...*F12:-:~matchbox-remote -desktop
+key=....F11:-:~matchbox-remote -menu
+#key=...*1:-:~zoom out
+#key=...*2:-:~zoom in
+key=...*3:-:~display-brightness.sh down
+key=...*4:-:~display-brightness.sh up
+
+# LCD Softkeys
+# Please note that the space _between_ two softkeys can be used, too ;)
+#key=....F20:-:
+key=....F21:-:~matchbox-remote -next
+#key=....F22:-:
+key=....F23:-:sylpheed
+#key=....F24:-:
+key=....F25:-:gpe-contacts
+#key=....F26:-:
+key=....F27:-:gpe-calendar
+#key=....F28:-:
+#key=....F29:-:
+#key=....F30:-:
+
+# VT changing
+key=...*Left:-:~chvt 1
+key=...*Right:-:~chvt 3
diff --git a/recipes/keylaunch/keylaunch-conf/c7x0/keylaunchrc b/recipes/keylaunch/keylaunch-conf/c7x0/keylaunchrc
new file mode 100644
index 0000000000..e0b729a508
--- /dev/null
+++ b/recipes/keylaunch/keylaunch-conf/c7x0/keylaunchrc
@@ -0,0 +1,6 @@
+key=....F9:-:gpe-calendar
+key=....F10:-:gpe-contacts
+key=....F13:-:sylpheed
+key=....F12:-:gpe-mini-browser
+key=...*F18:-:display-brightness.sh down
+key=...*F19:-:display-brightness.sh up
diff --git a/recipes/keylaunch/keylaunch-conf/collie/keylaunchrc b/recipes/keylaunch/keylaunch-conf/collie/keylaunchrc
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/recipes/keylaunch/keylaunch-conf/collie/keylaunchrc
diff --git a/recipes/keylaunch/keylaunch-conf/corgie/keylaunchrc b/recipes/keylaunch/keylaunch-conf/corgie/keylaunchrc
new file mode 100644
index 0000000000..e0b729a508
--- /dev/null
+++ b/recipes/keylaunch/keylaunch-conf/corgie/keylaunchrc
@@ -0,0 +1,6 @@
+key=....F9:-:gpe-calendar
+key=....F10:-:gpe-contacts
+key=....F13:-:sylpheed
+key=....F12:-:gpe-mini-browser
+key=...*F18:-:display-brightness.sh down
+key=...*F19:-:display-brightness.sh up
diff --git a/recipes/keylaunch/keylaunch-conf/husky/keylaunchrc b/recipes/keylaunch/keylaunch-conf/husky/keylaunchrc
new file mode 100644
index 0000000000..e0b729a508
--- /dev/null
+++ b/recipes/keylaunch/keylaunch-conf/husky/keylaunchrc
@@ -0,0 +1,6 @@
+key=....F9:-:gpe-calendar
+key=....F10:-:gpe-contacts
+key=....F13:-:sylpheed
+key=....F12:-:gpe-mini-browser
+key=...*F18:-:display-brightness.sh down
+key=...*F19:-:display-brightness.sh up
diff --git a/recipes/keylaunch/keylaunch-conf/keylaunchrc b/recipes/keylaunch/keylaunch-conf/keylaunchrc
new file mode 100644
index 0000000000..c84fa25137
--- /dev/null
+++ b/recipes/keylaunch/keylaunch-conf/keylaunchrc
@@ -0,0 +1,31 @@
+# Format:
+# "key=" <ModState> [<Event>] <Keysym>+ ":" [ <Window> ":" ] <Command>
+# ModState:
+# "????" - any modifier (don't care)
+# "...." - no modifer
+# "*..." - Shift
+# ".*.." - Control
+# "..*." - Alt
+# "...*" - AltGr
+# Shift/Control/Alt/AltGr can be combined (e.g. ".**." == Control+Alt)
+# Event:
+# <empty> - Normal keytouch (short keypress followed by release)
+# Held - Long keytouch (pressed and held for some time)
+# Special Events (use with care):
+# Pressed - Key was just pressed (note: other events may match too, e.g.
+# normal/Held)
+# Released - Key was just released (note: other events may match too)
+# Combine - Several keys pressed together (note: other events may match too)
+# Keysym: One or more (for Combine only) X keysyms
+# Window: Ignored, do not use
+# Command: Command line to execute, if starts with ~, suppress X startup notification
+# (use for non-X apps).
+#
+key=????XF86AudioRecord:gpe-soundbite record --autogenerate-filename $HOME_VOLATILE
+key=????XF86Calendar:gpe-calendar
+key=????telephone:gpe-contacts
+key=????XF86Mail:gpe-taskmanager
+key=????XF86Start:~matchbox-remote -desktop
+key=????XF86PowerDown:~apm --suspend
+key=????Held XF86PowerDown:~bl toggle
+key=????Combine XF86Calendar XF86Start:gpe-keylock
diff --git a/recipes/keylaunch/keylaunch-conf/shepherd/keylaunchrc b/recipes/keylaunch/keylaunch-conf/shepherd/keylaunchrc
new file mode 100644
index 0000000000..e0b729a508
--- /dev/null
+++ b/recipes/keylaunch/keylaunch-conf/shepherd/keylaunchrc
@@ -0,0 +1,6 @@
+key=....F9:-:gpe-calendar
+key=....F10:-:gpe-contacts
+key=....F13:-:sylpheed
+key=....F12:-:gpe-mini-browser
+key=...*F18:-:display-brightness.sh down
+key=...*F19:-:display-brightness.sh up
diff --git a/recipes/keylaunch/keylaunch-conf/spitz/keylaunchrc b/recipes/keylaunch/keylaunch-conf/spitz/keylaunchrc
new file mode 100644
index 0000000000..9bb64db066
--- /dev/null
+++ b/recipes/keylaunch/keylaunch-conf/spitz/keylaunchrc
@@ -0,0 +1,28 @@
+key=....F9:-:gpe-calendar
+key=....F10:-:gpe-contacts
+key=....F13:-:sylpheed
+key=....F12:-:~matchbox-remote -next
+key=...*F12:-:~matchbox-remote -desktop
+key=....F11:-:~matchbox-remote -menu
+#key=...*1:-:~zoom out
+#key=...*2:-:~zoom in
+key=...*3:-:~display-brightness.sh down
+key=...*4:-:~display-brightness.sh up
+
+# LCD Softkeys
+# Please note that the space _between_ two softkeys can be used, too ;)
+#key=....F20:-:
+key=....F21:-:~matchbox-remote -next
+#key=....F22:-:
+key=....F23:-:sylpheed
+#key=....F24:-:
+key=....F25:-:gpe-contacts
+#key=....F26:-:
+key=....F27:-:gpe-calendar
+#key=....F28:-:
+#key=....F29:-:
+#key=....F30:-:
+
+# VT changing
+key=...*Left:-:~chvt 1
+key=...*Right:-:~chvt 3
diff --git a/recipes/keylaunch/keylaunch-conf_2.0.10.bb b/recipes/keylaunch/keylaunch-conf_2.0.10.bb
new file mode 100644
index 0000000000..aeb9c862ca
--- /dev/null
+++ b/recipes/keylaunch/keylaunch-conf_2.0.10.bb
@@ -0,0 +1,27 @@
+RDEPENDS_append_spitz = " display-brightness"
+RDEPENDS_append_akita = " display-brightness"
+RDEPENDS_append_c7x0 = " display-brightness"
+
+SECTION = "gpe"
+LICENSE = "GPL"
+DESCRIPTION = "Device-specific keylaunch configuration"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+PR = "r2"
+
+SRC_URI = " file://keylaunchrc"
+SRC_URI += " file://80chvt-SUID"
+
+do_install () {
+ install -d ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/X11/Xinit.d
+ install -m 0644 ${WORKDIR}/keylaunchrc ${D}${sysconfdir}/keylaunchrc.matchbox
+ install ${WORKDIR}/80chvt-SUID ${D}${sysconfdir}/X11/Xinit.d
+}
+
+pkg_postinst_${PN}() {
+ update-alternatives --install /etc/keylaunchrc keylaunchrc /etc/keylaunchrc.matchbox 10
+}
+
+pkg_postrm_${PN}() {
+ update-alternatives --remove keylaunchrc /etc/keylaunchrc.matchbox
+}
diff --git a/recipes/keylaunch/keylaunch_2.0.10.bb b/recipes/keylaunch/keylaunch_2.0.10.bb
new file mode 100644
index 0000000000..2afba67f16
--- /dev/null
+++ b/recipes/keylaunch/keylaunch_2.0.10.bb
@@ -0,0 +1,24 @@
+inherit gpe
+
+DEPENDS = "virtual/xserver libxtst libxau libxpm libgpelaunch keylaunch-conf"
+RDEPENDS = "keylaunch-conf"
+
+SECTION = "gpe"
+LICENSE = "GPL"
+DESCRIPTION = "A small utility for binding commands to a hot key.\
+ Keylaunch is a minimal utility for associating commands with hot keys. This\
+ GPE version is intended for use with the special keys found on most handheld\
+ computers. You can connect each key to a program of your choice; if the\
+ program is already running, keylaunch can bring its window to the front\
+ rather than just running another copy."
+PR = "r14"
+
+SRC_URI += " file://makefile-fix.patch;patch=1 file://unbreak-keyevents.patch;patch=1"
+
+export CVSBUILD="no"
+
+do_install_append() {
+ # Remove random crap
+ rm ${D}/etc/keylaunchrc
+ rm -rf ${D}/etc/X11/Xinit.d/
+}