aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kobodeluxe
diff options
context:
space:
mode:
authorRobert Schuster <rschus@tarub.tarent.buero>2011-03-08 18:50:16 +0100
committerRobert Schuster <rschus@tarub.tarent.buero>2011-03-12 09:07:36 +0100
commit3e2ca37a1e5346cf7457efbf142e443ea7ee8f37 (patch)
tree82f1d1ad35e4aaeb00d8c3a9e5dd17b46bec8316 /recipes/kobodeluxe
parentf9e26cb590ad84f0d95a70567ad252409d0a6226 (diff)
downloadopenembedded-3e2ca37a1e5346cf7457efbf142e443ea7ee8f37.tar.gz
kobodeluxe: added fix which renames a symbol that clashes with a std C one
Diffstat (limited to 'recipes/kobodeluxe')
-rw-r--r--recipes/kobodeluxe/files/buildfix.patch66
-rw-r--r--recipes/kobodeluxe/kobodeluxe_0.5.1.bb3
2 files changed, 68 insertions, 1 deletions
diff --git a/recipes/kobodeluxe/files/buildfix.patch b/recipes/kobodeluxe/files/buildfix.patch
new file mode 100644
index 0000000000..f75f11c339
--- /dev/null
+++ b/recipes/kobodeluxe/files/buildfix.patch
@@ -0,0 +1,66 @@
+Index: KoboDeluxe-0.5.1/enemies.h
+===================================================================
+--- KoboDeluxe-0.5.1.orig/enemies.h
++++ KoboDeluxe-0.5.1/enemies.h
+@@ -72,7 +72,7 @@ extern const enemy_kind bombdeto;
+ extern const enemy_kind cannon;
+ extern const enemy_kind pipe1;
+ extern const enemy_kind core;
+-extern const enemy_kind pipe2;
++extern const enemy_kind kobo_pipe2;
+ extern const enemy_kind rock;
+ extern const enemy_kind ring;
+ extern const enemy_kind enemy_m1;
+@@ -430,7 +430,7 @@ inline int _enemy::realize()
+
+ inline int _enemy::is_pipe()
+ {
+- return ((_state != notuse) && ((ek == &pipe1) || (ek == &pipe2)));
++ return ((_state != notuse) && ((ek == &pipe1) || (ek == &kobo_pipe2)));
+ }
+
+
+Index: KoboDeluxe-0.5.1/enemy.cpp
+===================================================================
+--- KoboDeluxe-0.5.1.orig/enemy.cpp
++++ KoboDeluxe-0.5.1/enemy.cpp
+@@ -755,10 +755,10 @@ void _enemy::move_core()
+
+ void _enemy::kill_core()
+ {
+- enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 3);
+- enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 7);
+- enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 1);
+- enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 5);
++ enemies.make(&kobo_pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 3);
++ enemies.make(&kobo_pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 7);
++ enemies.make(&kobo_pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 1);
++ enemies.make(&kobo_pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 5);
+ enemies.make(&explosion4, CS2PIXEL(x), CS2PIXEL(y));
+ sound.g_base_core_explo(x, y);
+ release();
+@@ -978,19 +978,19 @@ void _enemy::move_pipe2()
+ }
+ p ^= a;
+ if(p & U_MASK)
+- enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 1);
++ enemies.make(&kobo_pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 1);
+ if(p & R_MASK)
+- enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 3);
++ enemies.make(&kobo_pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 3);
+ if(p & D_MASK)
+- enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 5);
++ enemies.make(&kobo_pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 5);
+ if(p & L_MASK)
+- enemies.make(&pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 7);
++ enemies.make(&kobo_pipe2, CS2PIXEL(x), CS2PIXEL(y), 0, 0, 7);
+ manage.add_score(10);
+ release();
+ }
+
+
+-const enemy_kind pipe2 = {
++const enemy_kind kobo_pipe2 = {
+ 0,
+ &_enemy::make_pipe2,
+ &_enemy::move_pipe2,
diff --git a/recipes/kobodeluxe/kobodeluxe_0.5.1.bb b/recipes/kobodeluxe/kobodeluxe_0.5.1.bb
index 9327215f33..617b00876c 100644
--- a/recipes/kobodeluxe/kobodeluxe_0.5.1.bb
+++ b/recipes/kobodeluxe/kobodeluxe_0.5.1.bb
@@ -5,7 +5,7 @@ LICENSE = "GPL"
AUTHOR = "David Olofson <david@olofson.net>"
HOMEPAGE = "http://olofson.net/kobodl"
-PR = "r5"
+PR = "r6"
DEPENDS = "libsdl-image virtual/libsdl"
@@ -18,6 +18,7 @@ SRC_URI = "http://olofson.net/kobodl/download/KoboDeluxe-${PV}.tar.bz2 \
file://kobodeluxe-sysconf-support.patch \
file://kobodeluxe-menu-pointer.patch \
file://kobodeluxe-dimension-autoswap.patch \
+ file://buildfix.patch \
file://default-config \
"