aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lame
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-11-04 23:03:20 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-11-04 23:03:20 +0000
commit3d79f309ec2a75a3e6606a2899260e4d05c22500 (patch)
treed091dce75c27fa7511149b5f28d0ad35b02408a0 /recipes/lame
parenta74f86eab3b1482e3528c6ec61edde8f68f34917 (diff)
downloadopenembedded-3d79f309ec2a75a3e6606a2899260e4d05c22500.tar.gz
lame: Update to version 3.98.2.
Diffstat (limited to 'recipes/lame')
-rw-r--r--recipes/lame/lame-3.98.2/ldflags-qa.patch43
-rw-r--r--recipes/lame/lame-3.98.2/no-gtk1.patch18
-rw-r--r--recipes/lame/lame_3.98.2.bb26
3 files changed, 87 insertions, 0 deletions
diff --git a/recipes/lame/lame-3.98.2/ldflags-qa.patch b/recipes/lame/lame-3.98.2/ldflags-qa.patch
new file mode 100644
index 0000000000..c4df610bb2
--- /dev/null
+++ b/recipes/lame/lame-3.98.2/ldflags-qa.patch
@@ -0,0 +1,43 @@
+https://sourceforge.net/tracker/?func=detail&aid=2892273&group_id=290&atid=300290
+
+Depending on configure arguments libmp3lame may be built only as a
+shared library. But lame frntends link command using this library
+has -static.
+
+Such clash may cause ugly libtool behavior.
+
+In context of lame, linking should probably respect configure flags
+and link frontend dynamically if shared linking is enabled.
+
+As a consequence of bug in libtool, this combination
+with --disable-static may create incorrect binary. For more see:
+http://lists.gnu.org/archive/html/bug-libtool/2009-11/msg00004.html
+
+Signed-off-by: Stanislav Brabec <utx@penguin.cz>
+
+Index: lame-398-2/frontend/Makefile.am
+===================================================================
+--- lame-398-2.orig/frontend/Makefile.am
++++ lame-398-2/frontend/Makefile.am
+@@ -52,7 +52,7 @@ mp3x_SOURCES = mp3x.c gtkanal.c gpkplott
+ endif
+
+ CFLAGS = @CFLAGS@ @GTK_CFLAGS@ @FRONTEND_CFLAGS@ @SNDFILE_CFLAGS@
+-LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@ @SNDFILE_LIBS@ -static
++LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@ @SNDFILE_LIBS@
+
+ INCLUDES = -I$(top_srcdir)/libmp3lame -I$(top_srcdir)/include -I$(top_builddir)
+
+Index: lame-398-2/frontend/Makefile.in
+===================================================================
+--- lame-398-2.orig/frontend/Makefile.in
++++ lame-398-2/frontend/Makefile.in
+@@ -152,7 +152,7 @@ LDADD = @LDADD@ \
+ $(top_builddir)/libmp3lame/libmp3lame.la \
+ @FRONTEND_LDADD@
+
+-LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@ @SNDFILE_LIBS@ -static
++LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@ @SNDFILE_LIBS@
+ LIBOBJS = @LIBOBJS@
+ LIBS = @LIBS@
+ LIBTOOL = @LIBTOOL@
diff --git a/recipes/lame/lame-3.98.2/no-gtk1.patch b/recipes/lame/lame-3.98.2/no-gtk1.patch
new file mode 100644
index 0000000000..3cc06308f5
--- /dev/null
+++ b/recipes/lame/lame-3.98.2/no-gtk1.patch
@@ -0,0 +1,18 @@
+Index: lame-398-2/configure.in
+===================================================================
+--- lame-398-2.orig/configure.in
++++ lame-398-2/configure.in
+@@ -385,7 +385,12 @@ CONFIG_MATH_LIB="${USE_LIBM}"
+
+ dnl configure use of features
+
+-AM_PATH_GTK(1.2.0, HAVE_GTK="yes", HAVE_GTK="no")
++dnl AM_PATH_GTK(1.2.0, HAVE_GTK="yes", HAVE_GTK="no")
++HAVE_GTK="no"
++GTK_CFLAGS=""
++GTK_LIBS=""
++AC_SUBST(GTK_CFLAGS)
++AC_SUBST(GTK_LIBS)
+
+ dnl ElectricFence malloc debugging
+ AC_MSG_CHECKING(use of ElectricFence malloc debugging)
diff --git a/recipes/lame/lame_3.98.2.bb b/recipes/lame/lame_3.98.2.bb
new file mode 100644
index 0000000000..f279857810
--- /dev/null
+++ b/recipes/lame/lame_3.98.2.bb
@@ -0,0 +1,26 @@
+SECTION = "console/utils"
+DESCRIPTION = "Not an MP3 encoder"
+LICENSE = "LGPL"
+PR = "r0"
+
+S = "${WORKDIR}/${PN}-398-2"
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-398-2.tar.gz \
+ file://no-gtk1.patch;patch=1 \
+ file://ldflags-qa.patch;patch=1"
+
+inherit autotools_stage
+
+PACKAGES += "libmp3lame libmp3lame-dev"
+FILES_${PN} = "${bindir}/lame"
+FILES_libmp3lame = "${libdir}/libmp3lame.so.*"
+FILES_libmp3lame-dev = "${includedir} ${libdir}/*"
+FILES_${PN}-dev = ""
+
+do_configure() {
+ # no autoreconf please
+ aclocal
+ autoconf
+ libtoolize --force
+ gnu-configize --force
+ oe_runconf
+}