summaryrefslogtreecommitdiffstats
path: root/recipes/lcd4linux
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/lcd4linux
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/lcd4linux')
-rw-r--r--recipes/lcd4linux/files/lcd4linux.init56
-rw-r--r--recipes/lcd4linux/files/libusb-compat.diff95
-rw-r--r--recipes/lcd4linux/lcd4linux_0.10.0.bb27
-rw-r--r--recipes/lcd4linux/lcd4linux_0.11.0-SVN.bb29
4 files changed, 207 insertions, 0 deletions
diff --git a/recipes/lcd4linux/files/lcd4linux.init b/recipes/lcd4linux/files/lcd4linux.init
new file mode 100644
index 0000000000..c27ee37a1b
--- /dev/null
+++ b/recipes/lcd4linux/files/lcd4linux.init
@@ -0,0 +1,56 @@
+#! /bin/sh
+
+### BEGIN INIT INFO
+# Provides: lcd4linux
+# Required-Start:
+# Required-Stop:
+# Default-Start: 2 3 4 5
+# Default-Stop: 0 1 6
+# Short-Description: daemon for driving LCD based displays
+# Description: LCD4Linux is a small program that grabs information from
+# the kernel and some subsystems and displays it on an
+# external liquid crystal display.
+### END INIT INFO
+
+PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
+DAEMON=/usr/bin/lcd4linux
+NAME=lcd4linux
+DESC=lcd4linux
+
+test -x $DAEMON || exit 0
+test -f /etc/lcd4linux.conf || exit 0
+
+set -e
+
+case "$1" in
+ start)
+ echo -n "Starting $DESC: "
+ chmod 600 /etc/lcd4linux.conf
+ start-stop-daemon --start --quiet --pidfile /var/run/$NAME.pid \
+ --exec $DAEMON -- $DAEMON_OPTS
+ echo "$NAME."
+ ;;
+ stop)
+ echo -n "Stopping $DESC: "
+ start-stop-daemon --stop --quiet --pidfile /var/run/$NAME.pid \
+ --exec $DAEMON || true
+ echo "$NAME."
+ ;;
+ restart|force-reload)
+ echo -n "Restarting $DESC: "
+ start-stop-daemon --stop --quiet --pidfile \
+ /var/run/$NAME.pid --exec $DAEMON
+ sleep 1
+ start-stop-daemon --start --quiet --pidfile \
+ /var/run/$NAME.pid --exec $DAEMON -- $DAEMON_OPTS
+ echo "$NAME."
+ ;;
+ *)
+ N=/etc/init.d/$NAME
+ # echo "Usage: $N {start|stop|restart|reload|force-reload}" >&2
+ echo "Usage: $N {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes/lcd4linux/files/libusb-compat.diff b/recipes/lcd4linux/files/libusb-compat.diff
new file mode 100644
index 0000000000..43d7cb9f63
--- /dev/null
+++ b/recipes/lcd4linux/files/libusb-compat.diff
@@ -0,0 +1,95 @@
+diff -Nurd lcd4linux-0.10.1-RC2.orig/drv_BWCT.c lcd4linux-0.10.1-RC2/drv_BWCT.c
+--- lcd4linux-0.10.1-RC2.orig/drv_BWCT.c 2007-02-25 13:39:09.000000000 +0100
++++ lcd4linux-0.10.1-RC2/drv_BWCT.c 2008-06-22 11:57:01.000000000 +0200
+@@ -72,7 +72,6 @@
+ static usb_dev_handle *lcd;
+ static int interface;
+
+-extern int usb_debug;
+ extern int got_signal;
+
+
+@@ -89,7 +88,6 @@
+
+ info("%s: scanning USB for BWCT LCD...", Name);
+
+- usb_debug = 0;
+
+ usb_init();
+ usb_find_busses();
+diff -Nurd lcd4linux-0.10.1-RC2.orig/drv_LCD2USB.c lcd4linux-0.10.1-RC2/drv_LCD2USB.c
+--- lcd4linux-0.10.1-RC2.orig/drv_LCD2USB.c 2007-02-25 13:39:10.000000000 +0100
++++ lcd4linux-0.10.1-RC2/drv_LCD2USB.c 2008-06-22 11:57:47.000000000 +0200
+@@ -98,7 +98,6 @@
+ static usb_dev_handle *lcd;
+ static int controllers = 0;
+
+-extern int usb_debug;
+ extern int got_signal;
+
+ /****************************************/
+@@ -120,7 +119,6 @@
+ if (device_id != NULL)
+ info("%s: scanning for device id: %s", Name, device_id);
+
+- usb_debug = 0;
+
+ usb_init();
+ usb_find_busses();
+diff -Nurd lcd4linux-0.10.1-RC2.orig/drv_picoLCD.c lcd4linux-0.10.1-RC2/drv_picoLCD.c
+--- lcd4linux-0.10.1-RC2.orig/drv_picoLCD.c 2007-02-25 13:39:10.000000000 +0100
++++ lcd4linux-0.10.1-RC2/drv_picoLCD.c 2008-06-22 11:58:10.000000000 +0200
+@@ -75,7 +75,6 @@
+ static char *BufPtr;
+
+ static usb_dev_handle *lcd;
+-extern int usb_debug;
+
+
+
+@@ -97,7 +96,6 @@
+
+ info("%s: scanning for picoLCD...", Name);
+
+- usb_debug = 0;
+
+ usb_init();
+ usb_find_busses();
+diff -Nurd lcd4linux-0.10.1-RC2.orig/drv_Trefon.c lcd4linux-0.10.1-RC2/drv_Trefon.c
+--- lcd4linux-0.10.1-RC2.orig/drv_Trefon.c 2007-02-25 13:39:10.000000000 +0100
++++ lcd4linux-0.10.1-RC2/drv_Trefon.c 2008-06-22 11:58:50.000000000 +0200
+@@ -72,7 +72,6 @@
+ static usb_dev_handle *lcd;
+ static int interface;
+
+-extern int usb_debug;
+
+
+ /****************************************/
+@@ -88,7 +87,6 @@
+
+ info("%s: scanning USB for TREFON LCD...", Name);
+
+- usb_debug = 0;
+
+ usb_init();
+ usb_find_busses();
+diff -Nurd lcd4linux-0.10.1-RC2.orig/drv_USBLCD.c lcd4linux-0.10.1-RC2/drv_USBLCD.c
+--- lcd4linux-0.10.1-RC2.orig/drv_USBLCD.c 2007-02-25 13:39:10.000000000 +0100
++++ lcd4linux-0.10.1-RC2/drv_USBLCD.c 2008-06-22 11:58:57.000000000 +0200
+@@ -86,7 +86,6 @@
+ static usb_dev_handle *lcd;
+ static int interface;
+
+-extern int usb_debug;
+
+ #endif
+
+@@ -107,7 +106,6 @@
+
+ info("%s: scanning for USBLCD...", Name);
+
+- usb_debug = 0;
+
+ usb_init();
+ usb_find_busses();
diff --git a/recipes/lcd4linux/lcd4linux_0.10.0.bb b/recipes/lcd4linux/lcd4linux_0.10.0.bb
new file mode 100644
index 0000000000..fe73954fe5
--- /dev/null
+++ b/recipes/lcd4linux/lcd4linux_0.10.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "LCD4Linux is a small program that grabs information from the kernel and some subsystems and displays it on an external liquid crystal display."
+LICENSE = "GPLv2"
+
+DEPENDS = "libusb-compat ncurses readline virtual/libx11"
+
+PV = "0.10.0+0.10.1-RC2"
+PR = "r4"
+
+SRC_URI = "http://ssl.bulix.org/projects/lcd4linux/raw-attachment/wiki/Download/lcd4linux-0.10.1-RC2.tar.gz \
+ file://libusb-compat.diff;patch=1 \
+ file://lcd4linux.init"
+
+S = "${WORKDIR}/lcd4linux-0.10.1-RC2"
+
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "lcd4linux"
+CONFFILES_${PN} += "${sysconfdir}/lcd4linux.conf"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}
+ install -m 0600 ${S}/lcd4linux.conf.sample ${D}/${sysconfdir}/lcd4linux.conf
+ install -d ${D}/${INIT_D_DIR}
+ install -m 0755 ${WORKDIR}/lcd4linux.init ${D}/${INIT_D_DIR}/lcd4linux
+}
+
diff --git a/recipes/lcd4linux/lcd4linux_0.11.0-SVN.bb b/recipes/lcd4linux/lcd4linux_0.11.0-SVN.bb
new file mode 100644
index 0000000000..01471bdfc1
--- /dev/null
+++ b/recipes/lcd4linux/lcd4linux_0.11.0-SVN.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "LCD4Linux is a small program that grabs information from the kernel and some subsystems and displays it on an external liquid crystal display."
+LICENSE = "GPLv2"
+
+DEPENDS = "libusb-compat ncurses readline virtual/libx11"
+
+PV = "0.11.0-SVN"
+PR = "r0"
+
+EXTRA_OECONF = " --with-glib-prefix=${STAGING_LIBDIR}/.. \
+ --with-glib-exec-prefix=${STAGING_LIBDIR}/.. \
+ --with-ncurses=${STAGING_LIBDIR}/.."
+SRC_URI = " http://ssl.bulix.org/projects/lcd4linux/raw-attachment/wiki/Download/lcd4linux-0.11.0-SVN.tar.bz2 \
+ file://lcd4linux.init"
+
+S = "${WORKDIR}/lcd4linux-0.11.0-SVN"
+
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "lcd4linux"
+CONFFILES_${PN} += "${sysconfdir}/lcd4linux.conf"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}
+ install -m 0600 ${S}/lcd4linux.conf.sample ${D}/${sysconfdir}/lcd4linux.conf
+ install -d ${D}/${INIT_D_DIR}
+ install -m 0755 ${WORKDIR}/lcd4linux.init ${D}/${INIT_D_DIR}/lcd4linux
+}
+