aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/liba52
diff options
context:
space:
mode:
authorPaul Menzel <paulepanter@users.sourceforge.net>2010-03-15 04:55:56 +0000
committerPhilip Balister <philip@balister.org>2010-03-15 18:17:53 -0400
commitf92b2201ab4974bc1e2fed1b6ee9906774baf928 (patch)
tree77c52cb011fb7fa8f50222970c85880d1099aab7 /recipes/liba52
parentdf63fa123c0da7cdfa35c4c935667bf767e8b892 (diff)
downloadopenembedded-f92b2201ab4974bc1e2fed1b6ee9906774baf928.tar.gz
liba52: Disable `-prefer-non-pic` to enable `-fPIC`.
Using GCC 4.4.2 and Binutils 2.20 gives the following error. …/bin/ld: .libs/imdct.o: relocation R_ARM_MOVW_ABS_NC against `a local symbol' can not be used when making a shared object; recompile with -fPIC Therefore enable `-fPIC` with this patch taken from Debian [1]. [1] http://patch-tracker.debian.org/patch/series/view/a52dec/0.7.4-13/01-enable-pic.diff Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net> Signed-off-by: Philip Balister <philip@balister.org>
Diffstat (limited to 'recipes/liba52')
-rw-r--r--recipes/liba52/files/01-enable-pic.diff23
-rw-r--r--recipes/liba52/liba52_0.7.4.bb5
2 files changed, 26 insertions, 2 deletions
diff --git a/recipes/liba52/files/01-enable-pic.diff b/recipes/liba52/files/01-enable-pic.diff
new file mode 100644
index 0000000000..ed1accd37a
--- /dev/null
+++ b/recipes/liba52/files/01-enable-pic.diff
@@ -0,0 +1,23 @@
+Description: Disabling -prefer-non-pic which enables -fPIC
+Bug-Debian: http://bugs.debian.org/401590
+Author: Daniel Baumann <daniel@debian.org>, Dmitrijs Ledkovs <dmitrij.ledkov@gmail.com>
+
+
+---
+ liba52/configure.incl | 3 ---
+ 1 files changed, 0 insertions(+), 3 deletions(-)
+
+Index: a52dec-deb/liba52/configure.incl
+===================================================================
+--- a52dec-deb.orig/liba52/configure.incl 2009-12-05 02:52:12.000000000 +0000
++++ a52dec-deb/liba52/configure.incl 2009-12-05 03:23:45.000000000 +0000
+@@ -1,9 +1,6 @@
+ AC_SUBST([LIBA52_CFLAGS])
+ AC_SUBST([LIBA52_LIBS])
+
+-dnl avoid -fPIC when possible
+-LIBA52_CFLAGS="$LIBA52_CFLAGS -prefer-non-pic"
+-
+ AC_ARG_ENABLE([double],
+ [ --enable-double use double-precision samples])
+ if test x"$enable_double" = x"yes"; then
diff --git a/recipes/liba52/liba52_0.7.4.bb b/recipes/liba52/liba52_0.7.4.bb
index 743fa30f83..ea87cbef4f 100644
--- a/recipes/liba52/liba52_0.7.4.bb
+++ b/recipes/liba52/liba52_0.7.4.bb
@@ -2,11 +2,12 @@ DESCRIPTION = "Library for reading some sort of media format."
LICENSE = "GPL"
SECTION = "libs"
PRIORITY = "optional"
-PR = "r1"
+PR = "r2"
inherit autotools
-SRC_URI = "http://liba52.sourceforge.net/files/a52dec-${PV}.tar.gz"
+SRC_URI = "http://liba52.sourceforge.net/files/a52dec-${PV}.tar.gz \
+ file://01-enable-pic.diff;patch=1"
S = "${WORKDIR}/a52dec-${PV}"
EXTRA_OECONF = " --enable-shared "