aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libaio/libaio_0.3.106.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libaio/libaio_0.3.106.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libaio/libaio_0.3.106.bb')
-rw-r--r--recipes/libaio/libaio_0.3.106.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/libaio/libaio_0.3.106.bb b/recipes/libaio/libaio_0.3.106.bb
new file mode 100644
index 0000000000..bc70bbe8d2
--- /dev/null
+++ b/recipes/libaio/libaio_0.3.106.bb
@@ -0,0 +1,17 @@
+DESCRIPTION="Asynchronous input/output library that uses the kernels native interface"
+LICENSE = "LGPL"
+PR = "r2"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/liba/libaio/libaio_${PV}.orig.tar.gz \
+ file://00_arches.patch;patch=1 \
+ file://destdir.patch;patch=1"
+
+do_stage() {
+ install -d ${STAGING_INCDIR} ${STAGING_LIBDIR}
+ install -m 0644 src/libaio.h ${STAGING_INCDIR}
+ oe_libinstall -so -C src libaio ${STAGING_LIBDIR}
+}
+
+do_install () {
+ oe_runmake install DESTDIR=${D}
+}