aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libarena
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libarena
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libarena')
-rw-r--r--recipes/libarena/libarena_0.2.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes/libarena/libarena_0.2.bb b/recipes/libarena/libarena_0.2.bb
new file mode 100644
index 0000000000..9cd0e21c73
--- /dev/null
+++ b/recipes/libarena/libarena_0.2.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "libarena is a custom memory allocator interface and implementation. \
+Three allocators are provided: flat "LIFO" arena allocator, object pool allocator and a malloc(3) wrapper."
+HOMEPAGE = "http://www.25thandclement.com/~william/projects/libarena.html"
+SECTION = "libs"
+LICENSE = "${PN}"
+
+SRC_URI = "http://www.25thandclement.com/~william/projects/releases/libarena-${PV}.tgz"
+
+do_stage() {
+ oe_libinstall -C src -a libarena ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/arena
+ install src/*.h ${STAGING_INCDIR}/arena
+}
+