aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libcap
diff options
context:
space:
mode:
authorPaul Menzel <paulepanter@users.sourceforge.net>2010-01-16 14:41:03 +0100
committerPhil Blundell <philb@gnu.org>2010-01-21 22:15:04 +0000
commitb84a8334ffab66e74abf751532afd693f17f98fe (patch)
tree1ad24108e34373d139f35eed0b9706d4ac2cde13 /recipes/libcap
parentb6f9a84fd99c89ac074aaed90cdd3d064c534492 (diff)
downloadopenembedded-b84a8334ffab66e74abf751532afd693f17f98fe.tar.gz
libcap: Append `-fPIC` to `CFLAGS` to fix compilation on newer binutils/ld.
Doing `bitbake libcap` with PREFERRED_VERSION_binutils = "2.20" PREFERRED_VERSION_binutils-cross = "2.20" PREFERRED_VERSION_binutils-cross-sdk = "2.20" PREFERRED_VERSION_gcc = "4.4.2" PREFERRED_VERSION_gcc-cross = "4.4.2" PREFERRED_VERSION_gcc-cross-sdk = "4.4.2" PREFERRED_VERSION_gcc-cross-initial = "4.4.2" PREFERRED_VERSION_gcc-cross-intermediate = "4.4.2" in `local.conf` made `do_compile` error out with the following message [1]. arm-angstrom-linux-gnueabi-ld -soname libcap.so.1 -x -shared -o libcap.so.1.10 cap_alloc.o cap_proc.o cap_extint.o cap_flag.o cap_text.o cap_sys.o arm-angstrom-linux-gnueabi-ld: cap_text.o: relocation R_ARM_MOVW_ABS_NC against `a local symbol' can not be used when making a shared object; recompile with -fPIC Khem Raj explained it the following way [2]. Am Mittwoch, den 13.01.2010, 02:27 -0800 schrieb Khem Raj: > > I also get the same error which I did not get before with GCC 4.1.1. > > Older versions of binutils/ld can not detect MOVT/MOVW relocations which > are absolute and cant be used in PIC code. > hence even if the error was there it remained latent. Therefore just append `-fPIC` to the CFLAGS and bump the PR variable. The strange thing is still, that other distributions seem to have patched libcap to build with `-fPIC` long ago [3–5]. [1] http://lists.linuxtogo.org/pipermail/openembedded-devel/2010-January/016142.html [2] http://lists.linuxtogo.org/pipermail/openembedded-devel/2010-January/016211.html [3] http://www.linuxfromscratch.org/patches/downloads/libcap/libcap-1.10-fedora_fixes-1.patch [4] http://frugalware.org/pipermail/frugalware-darcs/2005-May/000824.html [5] http://cvs.fedoraproject.org/viewvc/rpms/libcap/F-7/libcap-1.10-fPIC.patch?revision=1.1&view=markup Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
Diffstat (limited to 'recipes/libcap')
-rw-r--r--recipes/libcap/libcap_1.10.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes/libcap/libcap_1.10.bb b/recipes/libcap/libcap_1.10.bb
index 172acaca6e..241529e865 100644
--- a/recipes/libcap/libcap_1.10.bb
+++ b/recipes/libcap/libcap_1.10.bb
@@ -3,9 +3,9 @@ PRIORITY = "optional"
SECTION = "libs"
LICENSE = "GPL"
DEPENDS = "bison-native flex-native"
-PR = "r1"
+PR = "r2"
-CFLAGS_append = " -I${S}/libcap/include"
+CFLAGS_append = " -I${S}/libcap/include -fPIC"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/libs/security/linux-privs/kernel-2.4/${PN}-${PV}.tar.bz2 \
file://makenames.patch;patch=1 \