aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libdes
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libdes
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libdes')
-rw-r--r--recipes/libdes/libdes-4.01/cross-compile.patch35
-rw-r--r--recipes/libdes/libdes_4.01.bb16
2 files changed, 51 insertions, 0 deletions
diff --git a/recipes/libdes/libdes-4.01/cross-compile.patch b/recipes/libdes/libdes-4.01/cross-compile.patch
new file mode 100644
index 0000000000..23fb518246
--- /dev/null
+++ b/recipes/libdes/libdes-4.01/cross-compile.patch
@@ -0,0 +1,35 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- libdes/Makefile~cross-compile 1997-01-13 18:27:30.000000000 +0100
++++ libdes/Makefile 2004-02-15 01:57:46.000000000 +0100
+@@ -42,10 +42,10 @@
+ #DES_ENC=asm/dx86-sol.o # solaris format x86
+ #DES_ENC=asm/dx86bsdi.o # bsdi format x86
+
+-LIBDIR=/usr/local/lib
+-BINDIR=/usr/local/bin
+-INCDIR=/usr/local/include
+-MANDIR=/usr/local/man
++LIBDIR=$(DESTDIR)/usr/lib
++BINDIR=$(DESTDIR)/usr/bin
++INCDIR=$(DESTDIR)/usr/include
++MANDIR=$(DESTDIR)/usr/man
+ MAN1=1
+ MAN3=3
+ SHELL=/bin/sh
+@@ -94,10 +94,8 @@
+
+ $(DLIB): $(OBJS)
+ /bin/rm -f $(DLIB)
+- ar cr $(DLIB) $(OBJS)
+- -if test -s /bin/ranlib; then /bin/ranlib $(DLIB); \
+- else if test -s /usr/bin/ranlib; then /usr/bin/ranlib $(DLIB); \
+- else exit 0; fi; fi
++ $(AR) cr $(DLIB) $(OBJS)
++ $(RANLIB) $(DLIB)
+
+ des_opts: des_opts.o libdes.a
+ $(CC) $(CFLAGS) -o des_opts des_opts.o libdes.a
diff --git a/recipes/libdes/libdes_4.01.bb b/recipes/libdes/libdes_4.01.bb
new file mode 100644
index 0000000000..4e81ff9fb6
--- /dev/null
+++ b/recipes/libdes/libdes_4.01.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "A DES encryption library"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "libdes"
+SRC_URI = "http://www.agentpp.com/libdes-l-${PV}.tar.gz \
+ file://cross-compile.patch;patch=1"
+S = "${WORKDIR}/libdes"
+
+do_compile() {
+ oe_runmake libdes.a
+}
+
+do_stage() {
+ oe_libinstall -a libdes ${STAGING_LIBDIR}
+ install -m 0644 ${S}/des.h ${STAGING_INCDIR}/
+}