aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libdlo/kernel-module-udlfb.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-30 16:42:41 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-30 16:42:41 +0200
commitec01c7be7f7863a399b5a68c24e05c8ec83ddc63 (patch)
tree862361609d94cf09d6782161dc2e8285d0770df0 /recipes/libdlo/kernel-module-udlfb.bb
parent13ee19b077addb5f0c78e7ba8f6a6507c11c1bab (diff)
downloadopenembedded-ec01c7be7f7863a399b5a68c24e05c8ec83ddc63.tar.gz
displaylink: add kernel-module-udlfb and libdlo, which are 2 ways of controlling displaylink based usb devices
Diffstat (limited to 'recipes/libdlo/kernel-module-udlfb.bb')
-rw-r--r--recipes/libdlo/kernel-module-udlfb.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/libdlo/kernel-module-udlfb.bb b/recipes/libdlo/kernel-module-udlfb.bb
new file mode 100644
index 0000000000..f1352ef0c1
--- /dev/null
+++ b/recipes/libdlo/kernel-module-udlfb.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Framebuffer console driver for displaylink based usb devices"
+LICENSE = "GPLv2"
+
+PV = "0.2"
+
+SRC_URI = "file://udlfb.c \
+ file://dlfb.h \
+ file://Makefile \
+"
+
+inherit module
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/drivers/usb/
+ install -m 0644 *.ko ${D}/lib/modules/${KERNEL_VERSION}/drivers/usb/
+}
+