aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libdlo
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-02-22 09:31:43 +0100
committerKoen Kooi <koen@openembedded.org>2010-02-22 09:31:43 +0100
commit065929309232c346ae2ca0665dbc3a53c39b3514 (patch)
tree1717cb232064db60e412806823c3e0c52c12cb7d /recipes/libdlo
parentc478cd48ccc9bdffc013d216ef25808c9b740509 (diff)
downloadopenembedded-065929309232c346ae2ca0665dbc3a53c39b3514.tar.gz
kernel-module-udlfb: add git version
* the recipe has hints for the needed kernel config * doesn't require special Xserver, fbdev works
Diffstat (limited to 'recipes/libdlo')
-rw-r--r--recipes/libdlo/kernel-module-udlfb_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/libdlo/kernel-module-udlfb_git.bb b/recipes/libdlo/kernel-module-udlfb_git.bb
new file mode 100644
index 0000000000..24dc2f36dd
--- /dev/null
+++ b/recipes/libdlo/kernel-module-udlfb_git.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Framebuffer console driver for displaylink based usb devices"
+LICENSE = "GPLv2"
+
+# Make sure you have:
+# CONFIG_FB_DEFERRED_IO=y
+# CONFIG_FB_VIRTUAL=y
+# CONFIG_FB_MODE_HELPERS=y
+# CONFIG_FB_SYS_IMAGEBLIT=y
+# CONFIG_FB_SYS_IMAGEBLIT_MODULE=y
+# CONFIG_FB_SYS_COPYAREA=y
+# CONFIG_FB_SYS_COPYAREA_MODULE=y
+# CONFIG_FB_SYS_FILLRECT=y
+# CONFIG_FB_SYS_FILLRECT_MODULE=y
+# enabled in your kernel
+
+PV = "0.4"
+PR_append = "b+gitr${SRCREV}"
+
+SRCREV = "c01f96f2de105c1898cbd1708fe5472ca0f7a7e2"
+SRC_URI = "git://git.plugable.com/webdav/udlfb;protocol=http;branch=master"
+
+inherit module
+
+S = "${WORKDIR}/git"
+
+MODULE_MAKE_FLAGS += " -C ${STAGING_KERNEL_DIR} SUBDIRS=${S}"
+
+