aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libdotconf
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libdotconf
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libdotconf')
-rw-r--r--recipes/libdotconf/files/srcMakefile.am_00.patch9
-rw-r--r--recipes/libdotconf/libdotconf_1.0.13.bb25
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes/libdotconf/files/srcMakefile.am_00.patch b/recipes/libdotconf/files/srcMakefile.am_00.patch
new file mode 100644
index 0000000000..500f1fd2d7
--- /dev/null
+++ b/recipes/libdotconf/files/srcMakefile.am_00.patch
@@ -0,0 +1,9 @@
+--- dotconf-1.0.13/src/Makefile.am.orig 2008-01-02 11:48:16.000000000 +0000
++++ dotconf-1.0.13/src/Makefile.am 2008-01-02 11:48:22.000000000 +0000
+@@ -1,5 +1,5 @@
+
+-INCLUDES = -I. -I$(includedir)
++INCLUDES = -I.
+
+ include_HEADERS = dotconf.h
+ noinst_HEADERS = readdir.h
diff --git a/recipes/libdotconf/libdotconf_1.0.13.bb b/recipes/libdotconf/libdotconf_1.0.13.bb
new file mode 100644
index 0000000000..05520519b6
--- /dev/null
+++ b/recipes/libdotconf/libdotconf_1.0.13.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = " dot.conf is an easy to use and powerful configuration file parser library"
+HOMEPAGE = "http://www.azzit.de/dotconf/"
+LICENSE = "LGPLv2"
+
+PR = "r0"
+
+inherit autotools
+
+SRC_URI = "http://www.azzit.de/dotconf/download/v1.0/dotconf-${PV}.tar.gz \
+ file://srcMakefile.am_00.patch;patch=1"
+
+S = "${WORKDIR}/dotconf-${PV}"
+
+do_install() {
+ install -d ${D}${libdir}
+ install -d ${D}${includedir}
+
+ install -m 0644 ${S}/src/dotconf.h ${D}${includedir}
+ oe_libinstall -C src -so libdotconf ${D}${libdir}
+}
+
+do_stage() {
+ install -m 0644 ${S}/src/dotconf.h ${STAGING_INCDIR}/
+ oe_libinstall -C src -so libdotconf ${STAGING_LIBDIR}/
+}