aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libetpan
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libetpan
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libetpan')
-rw-r--r--recipes/libetpan/files/honor-oe-lflags.patch16
-rw-r--r--recipes/libetpan/files/libetpan-autoreconf.patch12
-rw-r--r--recipes/libetpan/libetpan_0.46.bb23
-rw-r--r--recipes/libetpan/libetpan_0.48.bb23
-rw-r--r--recipes/libetpan/libetpan_0.57.bb23
5 files changed, 97 insertions, 0 deletions
diff --git a/recipes/libetpan/files/honor-oe-lflags.patch b/recipes/libetpan/files/honor-oe-lflags.patch
new file mode 100644
index 0000000000..15a1535bfa
--- /dev/null
+++ b/recipes/libetpan/files/honor-oe-lflags.patch
@@ -0,0 +1,16 @@
+
+#
+# Signed off by Michael 'Mickey' Lauer <mickey@Vanille.de>
+#
+
+--- libetpan-0.46/configure.in~honor-oe-lflags
++++ libetpan-0.46/configure.in
+@@ -361,7 +361,7 @@
+ LDFLAGS="-$flag $LDFLAGS"
+ AC_TRY_LINK([], [pthread_create();],
+ [pthflag=yes; checkpthread=no],
+- [pthflag=no; LDFLAGS="$OLDCFLAGS"])
++ [pthflag=no; LDFLAGS="$OLDFLAGS"])
+ AC_MSG_RESULT($pthflag)
+ fi
+ done
diff --git a/recipes/libetpan/files/libetpan-autoreconf.patch b/recipes/libetpan/files/libetpan-autoreconf.patch
new file mode 100644
index 0000000000..d05967da31
--- /dev/null
+++ b/recipes/libetpan/files/libetpan-autoreconf.patch
@@ -0,0 +1,12 @@
+Index: libetpan-0.57/configure.ac
+===================================================================
+--- libetpan-0.57.orig/configure.ac 2008-10-08 19:54:20.000000000 +0000
++++ libetpan-0.57/configure.ac 2008-11-11 16:34:33.000000000 +0000
+@@ -106,6 +106,7 @@
+
+ # Check the C compiler.
+ AC_PROG_CC
++AC_PROG_CXX
+
+ # Compiler flags.
+ AC_ARG_ENABLE(debug, [ --enable-debug setup flags (gcc) for debugging (default=no)],
diff --git a/recipes/libetpan/libetpan_0.46.bb b/recipes/libetpan/libetpan_0.46.bb
new file mode 100644
index 0000000000..dfef3b19c6
--- /dev/null
+++ b/recipes/libetpan/libetpan_0.46.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "libetpan is a library for communicating with mail and news servers. \
+It supports the protocols SMTP, POP3, IMAP and NNTP."
+HOMEPAGE = "http://www.etpan.org"
+SECTION = "libs"
+DEPENDS = "gnutls"
+LICENSE = "BSD"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libetpan/libetpan-${PV}.tar.gz \
+ file://honor-oe-lflags.patch;patch=1"
+
+inherit autotools pkgconfig gettext binconfig
+
+EXTRA_OECONF = "--without-openssl --with-gnutls --disable-db"
+
+PARALLEL_MAKE = ""
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev = "${bindir} ${includedir} ${libdir}/lib*.so ${libdir}/*.la ${libdir}/*.a ${libdir}/pkgconfig"
diff --git a/recipes/libetpan/libetpan_0.48.bb b/recipes/libetpan/libetpan_0.48.bb
new file mode 100644
index 0000000000..dfef3b19c6
--- /dev/null
+++ b/recipes/libetpan/libetpan_0.48.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "libetpan is a library for communicating with mail and news servers. \
+It supports the protocols SMTP, POP3, IMAP and NNTP."
+HOMEPAGE = "http://www.etpan.org"
+SECTION = "libs"
+DEPENDS = "gnutls"
+LICENSE = "BSD"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libetpan/libetpan-${PV}.tar.gz \
+ file://honor-oe-lflags.patch;patch=1"
+
+inherit autotools pkgconfig gettext binconfig
+
+EXTRA_OECONF = "--without-openssl --with-gnutls --disable-db"
+
+PARALLEL_MAKE = ""
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev = "${bindir} ${includedir} ${libdir}/lib*.so ${libdir}/*.la ${libdir}/*.a ${libdir}/pkgconfig"
diff --git a/recipes/libetpan/libetpan_0.57.bb b/recipes/libetpan/libetpan_0.57.bb
new file mode 100644
index 0000000000..e0108f9fbd
--- /dev/null
+++ b/recipes/libetpan/libetpan_0.57.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "libetpan is a library for communicating with mail and news servers. \
+It supports the protocols SMTP, POP3, IMAP and NNTP."
+HOMEPAGE = "http://www.etpan.org"
+SECTION = "libs"
+DEPENDS = "gnutls"
+LICENSE = "BSD"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libetpan/libetpan-${PV}.tar.gz \
+ file://libetpan-autoreconf.patch;patch=1"
+
+inherit autotools pkgconfig gettext binconfig
+
+EXTRA_OECONF = "--without-openssl --with-gnutls --disable-db"
+
+PARALLEL_MAKE = ""
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev = "${bindir} ${includedir} ${libdir}/lib*.so ${libdir}/*.la ${libdir}/*.a ${libdir}/pkgconfig"