aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libfribidi
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libfribidi
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libfribidi')
-rw-r--r--recipes/libfribidi/files/libtool-update.patch11
-rw-r--r--recipes/libfribidi/libfribidi_0.10.4.bb29
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes/libfribidi/files/libtool-update.patch b/recipes/libfribidi/files/libtool-update.patch
new file mode 100644
index 0000000000..c7031008fd
--- /dev/null
+++ b/recipes/libfribidi/files/libtool-update.patch
@@ -0,0 +1,11 @@
+--- fribidi-0.10.4/configure.in~ 2002-05-19 11:06:48.000000000 +0100
++++ fribidi-0.10.4/configure.in 2004-08-03 17:42:28.000000000 +0100
+@@ -50,7 +50,7 @@
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+-AC_PROG_RANLIB
++#AC_PROG_RANLIB
+ AC_PATH_PROG(SED, sed, $PATH)
+
+
diff --git a/recipes/libfribidi/libfribidi_0.10.4.bb b/recipes/libfribidi/libfribidi_0.10.4.bb
new file mode 100644
index 0000000000..57aaf48bed
--- /dev/null
+++ b/recipes/libfribidi/libfribidi_0.10.4.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Fribidi library for bidirectional text"
+SECTION = "libs"
+PRIORITY = "optional"
+
+inherit autotools pkgconfig
+
+PR = "r0"
+
+S = "${WORKDIR}/fribidi-${PV}"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/fribidi/fribidi-${PV}.tar.bz2 \
+ file://libtool-update.patch;patch=1"
+
+#PACKAGES += " ${PN}-bin"
+FILES_${PN} = "${libdir}/lib*.so.*"
+#FILES_${PN}-bin = "${libdir}/uu*"
+
+do_configure_prepend () {
+# this version of libtool is old - we have to nobble this file to get it to litoolize
+ rm ltconfig
+ rm aclocal.m4
+ rm acinclude.m4
+}
+
+do_stage () {
+ oe_libinstall -a -so -C .libs libfribidi ${STAGING_LIBDIR}
+ autotools_stage_includes
+}
+