aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libgsm/libgsm_1.0.12.bb
diff options
context:
space:
mode:
authorwoglinde <heinold@inf.fu-berlin.de>2009-03-28 16:24:07 +0100
committerwoglinde <heinold@inf.fu-berlin.de>2009-03-31 10:01:05 +0200
commitf09ab9e93d09f6b82cfb975a955473c94625c544 (patch)
tree9d0f296e0495da90b05a7ed5851afc9b86c26b2d /recipes/libgsm/libgsm_1.0.12.bb
parent56b8436c3b3ed57df16d0e3d01d16a2193b89c42 (diff)
downloadopenembedded-f09ab9e93d09f6b82cfb975a955473c94625c544.tar.gz
libgsm: update to version 1.0.12
* all the patches are stolen from debian
Diffstat (limited to 'recipes/libgsm/libgsm_1.0.12.bb')
-rw-r--r--recipes/libgsm/libgsm_1.0.12.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes/libgsm/libgsm_1.0.12.bb b/recipes/libgsm/libgsm_1.0.12.bb
new file mode 100644
index 0000000000..9c96f4d39f
--- /dev/null
+++ b/recipes/libgsm/libgsm_1.0.12.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "GSM Audio Library"
+SECTION = "libs"
+PRIORITY = "optional"
+#DEPENDS = ""
+LICENSE = "libgsm"
+
+PR = "r0"
+
+SRC_URI = "http://user.cs.tu-berlin.de/~jutta/gsm/gsm-${PV}.tar.gz \
+ file://01_makefile.patch;patch=1 \
+ file://02_cplusplus.patch;patch=1 \
+ file://03_config.patch;patch=1 \
+ file://04_includes.patch;patch=1 \
+ file://05_compiler_warnings.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/gsm-1.0-pl12/"
+
+CFLAGS += "-c -g -fPIC -Wall -D_GNU_SOURCE -D_REENTRANT -DNeedFunctionPrototypes=1 -DWAV49 -I./inc"
+
+PARALLEL_MAKE = ""
+
+do_compile() {
+ unset LD
+ oe_runmake CCFLAGS="${CFLAGS}"
+}
+
+do_install() {
+ oe_libinstall -a -C lib libgsm ${D}${libdir}
+ oe_libinstall -so -C lib libgsm ${D}${libdir}
+ install -d ${D}/usr/include/gsm
+ install -m 0644 ${S}/inc/gsm.h ${D}/usr/include/gsm/
+ cd ${D}/usr/include/
+ ln -s gsm/gsm.h gsm.h
+}
+
+do_stage () {
+ oe_libinstall -a -C lib libgsm ${STAGING_LIBDIR}
+ oe_libinstall -so -C lib libgsm ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/gsm
+ install -m 0644 ${S}/inc/gsm.h ${STAGING_INCDIR}/gsm/
+ rm -f ${STAGING_INCDIR}/gsm.h
+ ln -s ${STAGING_INCDIR}/gsm/gsm.h ${STAGING_INCDIR}/gsm.h
+}
+