aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libidl/libidl_0.8.3.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libidl/libidl_0.8.3.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libidl/libidl_0.8.3.bb')
-rw-r--r--recipes/libidl/libidl_0.8.3.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/libidl/libidl_0.8.3.bb b/recipes/libidl/libidl_0.8.3.bb
new file mode 100644
index 0000000000..c4586f94f8
--- /dev/null
+++ b/recipes/libidl/libidl_0.8.3.bb
@@ -0,0 +1,17 @@
+require libidl.inc
+
+DEPENDS = "glib-2.0"
+
+PR = "r3"
+
+# Firefox uses the libIDL-config-2 script instead of pkgconfig (for some
+# strange reason - so we do some sed fu to fix the path there
+
+do_stage_prepend() {
+ cp ${STAGING_BINDIR}/libIDL-config-2 ${STAGING_BINDIR}/libIDL-config-2.orig
+ cat ${STAGING_BINDIR}/libIDL-config-2.orig | sed -e 's:${includedir}:${STAGING_INCDIR}:' > ${STAGING_BINDIR}/libIDL-config-2
+
+ if [ "${STAGING_BINDIR}" != "${STAGING_BINDIR_CROSS}" ]; then
+ mv ${STAGING_BINDIR}/libIDL-config-2 ${STAGING_BINDIR_CROSS}/libIDL-config-2
+ fi
+}