aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libidn
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2009-06-13 09:44:46 +0100
committerPhil Blundell <philb@gnu.org>2009-06-13 09:44:46 +0100
commitde8f4ecb08e75b207c8bf9704bac4dc60e2a84aa (patch)
treebc4217591fb7bec5ea82a7d1c252525f1a533cd2 /recipes/libidn
parent03f3d62589145b2a855d499f17ea81e91af03a4b (diff)
downloadopenembedded-de8f4ecb08e75b207c8bf9704bac4dc60e2a84aa.tar.gz
libidn: add 1.15
Diffstat (limited to 'recipes/libidn')
-rw-r--r--recipes/libidn/libidn_1.15.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/libidn/libidn_1.15.bb b/recipes/libidn/libidn_1.15.bb
new file mode 100644
index 0000000000..0a68a796c7
--- /dev/null
+++ b/recipes/libidn/libidn_1.15.bb
@@ -0,0 +1,19 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Implementation of the Stringprep, Punycode and IDNA specifications defined by the IETF Internationalized Domain Names (IDN) working group."
+SECTION = "libs"
+PRIORITY = "optional"
+PR = "r0"
+
+inherit pkgconfig autotools
+
+SRC_URI = "${GNU_MIRROR}/${PN}/${P}.tar.gz"
+
+EXTRA_OECONF = " --disable-tld"
+
+do_configure_prepend () {
+ autoreconf -f -i -s
+}
+
+do_stage () {
+ autotools_stage_all
+}