summaryrefslogtreecommitdiffstats
path: root/recipes/liblockfile
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/liblockfile
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/liblockfile')
-rw-r--r--recipes/liblockfile/liblockfile-1.06/configure.patch25
-rw-r--r--recipes/liblockfile/liblockfile-1.06/glibc-2.4.patch70
-rw-r--r--recipes/liblockfile/liblockfile-1.06/install.patch48
-rw-r--r--recipes/liblockfile/liblockfile-1.06/ldflags.patch21
-rw-r--r--recipes/liblockfile/liblockfile_1.06.bb24
5 files changed, 188 insertions, 0 deletions
diff --git a/recipes/liblockfile/liblockfile-1.06/configure.patch b/recipes/liblockfile/liblockfile-1.06/configure.patch
new file mode 100644
index 0000000000..ea13e11d25
--- /dev/null
+++ b/recipes/liblockfile/liblockfile-1.06/configure.patch
@@ -0,0 +1,25 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- liblockfile-1.05/./configure.in~configure
++++ liblockfile-1.05/./configure.in
+@@ -1,4 +1,5 @@
+-AC_INIT(lockfile.c)
++AC_INIT
++AC_CONFIG_SRCDIR([lockfile.c])
+ AC_CONFIG_HEADER(autoconf.h)
+ AC_REVISION($Revision: 1.0 $)dnl
+
+@@ -111,7 +112,8 @@
+ AC_SUBST(INSTALL_TARGETS)
+ AC_SUBST(nfslockdir)
+
+-AC_OUTPUT(\
++AC_CONFIG_FILES([\
+ ./Makefile \
+ ./maillock.h \
+-)
++])
++AC_OUTPUT
diff --git a/recipes/liblockfile/liblockfile-1.06/glibc-2.4.patch b/recipes/liblockfile/liblockfile-1.06/glibc-2.4.patch
new file mode 100644
index 0000000000..e3c4aaae5f
--- /dev/null
+++ b/recipes/liblockfile/liblockfile-1.06/glibc-2.4.patch
@@ -0,0 +1,70 @@
+The local function eaccess conflicts with a glibc function of the same name.
+Rename the function so that this can be build under glibc 2.4, and older
+revisions, without any problems.
+
+--- liblockfile-1.06/dotlockfile.c 2006/07/10 03:17:40 1.1
++++ liblockfile-1.06/dotlockfile.c 2006/07/10 03:18:26
+@@ -42,7 +42,7 @@
+ extern int optind;
+ #endif
+
+-extern int eaccess(char *, gid_t, struct stat *);
++extern int xeaccess(char *, gid_t, struct stat *);
+
+ /*
+ * Sleep for an amout of time while regulary checking if
+@@ -252,14 +252,14 @@
+ return L_ERROR;
+ }
+ gid = getgid();
+- if (eaccess(dir, gid, &st) < 0) {
++ if (xeaccess(dir, gid, &st) < 0) {
+ if (errno == ENOENT) {
+ enoent:
+ if (!quiet) fprintf(stderr,
+ "dotlockfile: %s: no such directory\n", dir);
+ return L_TMPLOCK;
+ }
+- if ((r = eaccess(dir, getegid(), &st) < 0) && errno == ENOENT)
++ if ((r = xeaccess(dir, getegid(), &st) < 0) && errno == ENOENT)
+ goto enoent;
+ if (r < 0 || !ismaillock(lockfile, pwd->pw_name)) {
+ if (!quiet) fprintf(stderr,
+@@ -272,7 +272,7 @@
+ /*
+ * Now we should be able to chdir() to the lock directory.
+ * When we stat("."), it should be the same as at the
+- * eaccess() check or someone played symlink() games on us.
++ * xeaccess() check or someone played symlink() games on us.
+ */
+ if (chdir(dir) < 0 || stat(".", &st2) < 0) {
+ if (!quiet) fprintf(stderr,
+--- liblockfile-1.06/lockfile.c 2006/07/10 03:17:40 1.1
++++ liblockfile-1.06/lockfile.c 2006/07/10 03:18:26
+@@ -54,7 +54,7 @@
+ #ifdef LIB
+ static
+ #endif
+-int eaccess(char *fn, gid_t gid, struct stat *st)
++int xeaccess(char *fn, gid_t gid, struct stat *st)
+ {
+ struct stat tmp;
+ uid_t uid = geteuid();
+@@ -96,7 +96,7 @@
+ *p = 0;
+ else
+ strcpy(dir, ".");
+- if (eaccess(dir, egid, NULL) >= 0) {
++ if (xeaccess(dir, egid, NULL) >= 0) {
+ free(dir);
+ return 0;
+ }
+@@ -111,7 +111,7 @@
+ return 0;
+ mailgid = st.st_gid;
+ }
+- ret = eaccess(dir, mailgid, NULL) >= 0;
++ ret = xeaccess(dir, mailgid, NULL) >= 0;
+ free (dir);
+ return ret;
+ }
diff --git a/recipes/liblockfile/liblockfile-1.06/install.patch b/recipes/liblockfile/liblockfile-1.06/install.patch
new file mode 100644
index 0000000000..a9319ff1e3
--- /dev/null
+++ b/recipes/liblockfile/liblockfile-1.06/install.patch
@@ -0,0 +1,48 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- liblockfile-1.05/Makefile.in~install
++++ liblockfile-1.05/Makefile.in
+@@ -20,6 +20,7 @@
+ includedir = @includedir@
+
+ MAILGROUP = @MAILGROUP@
++INSTGRP = $(if $(MAILGROUP),-g $(MAILGROUP))
+
+ all: @TARGETS@
+ install: @INSTALL_TARGETS@
+@@ -50,25 +51,27 @@
+ $(CC) $(CFLAGS) -c lockfile.c -o xlockfile.o
+
+ install_static: static install_common
++ install -d $(ROOT)$(libdir)
+ install -m 644 liblockfile.a $(ROOT)$(libdir)
+
+ install_shared: shared install_common
++ install -d $(ROOT)$(libdir)
+ install -m 755 liblockfile.so \
+ $(ROOT)$(libdir)/liblockfile.so.$(VER)
+ ln -s liblockfile.so.$(VER) $(ROOT)$(libdir)/liblockfile.so
+ if test "$(ROOT)" = ""; then @LDCONFIG@; fi
+
+ install_common:
++ install -d $(ROOT)$(includedir)
+ install -m 644 lockfile.h maillock.h $(ROOT)$(includedir)
+- if [ "$(MAILGROUP)" != "" ]; then\
+- install -g $(MAILGROUP) -m 2755 dotlockfile $(ROOT)$(bindir);\
+- else \
+- install -g root -m 755 dotlockfile $(ROOT)$(bindir); \
+- fi
++ install -d $(ROOT)$(bindir)
++ install -m 755 $(INSTGRP) dotlockfile $(ROOT)$(bindir)
++ install -d $(ROOT)$(mandir)/man1 $(ROOT)$(mandir)/man3
+ install -m 644 *.1 $(ROOT)$(mandir)/man1
+ install -m 644 *.3 $(ROOT)$(mandir)/man3
+
+ install_nfslib: nfslib
++ install -d $(ROOT)$(nfslockdir)
+ install -m 755 nfslock.so.$(VER) $(ROOT)$(nfslockdir)
+ if test "$(ROOT)" = ""; then @LDCONFIG@; fi
+
diff --git a/recipes/liblockfile/liblockfile-1.06/ldflags.patch b/recipes/liblockfile/liblockfile-1.06/ldflags.patch
new file mode 100644
index 0000000000..eb1d1478b8
--- /dev/null
+++ b/recipes/liblockfile/liblockfile-1.06/ldflags.patch
@@ -0,0 +1,21 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- liblockfile-1.05/Makefile.in~ldflags
++++ liblockfile-1.05/Makefile.in
+@@ -34,11 +34,11 @@
+
+ liblockfile.so: liblockfile.a
+ $(CC) -fPIC -shared -Wl,-soname,liblockfile.so.1 \
+- -o liblockfile.so lockfile.o -lc
++ -o liblockfile.so lockfile.o $(LDFLAGS) -lc
+
+ nfslock.so.$(VER): nfslock.o
+ $(CC) -fPIC -shared -Wl,-soname,nfslock.so.0 \
+- -o nfslock.so.$(NVER) nfslock.o
++ -o nfslock.so.$(NVER) nfslock.o $(LDFLAGS)
+
+ dotlockfile: dotlockfile.o xlockfile.o
+ $(CC) $(LDFLAGS) -o dotlockfile dotlockfile.o xlockfile.o
diff --git a/recipes/liblockfile/liblockfile_1.06.bb b/recipes/liblockfile/liblockfile_1.06.bb
new file mode 100644
index 0000000000..a59259cc62
--- /dev/null
+++ b/recipes/liblockfile/liblockfile_1.06.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "File locking library."
+SECTION = "libs"
+LICENSE = "LGPL"
+PR ="r1"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/libl/liblockfile/liblockfile_${PV}.tar.gz \
+ file://install.patch;patch=1 \
+ file://configure.patch;patch=1 \
+ file://ldflags.patch;patch=1 \
+ file://glibc-2.4.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-shared --enable-static"
+
+do_stage () {
+ install -m 644 ${S}/lockfile.h ${S}/maillock.h ${STAGING_INCDIR}/
+ oe_libinstall -a -so liblockfile ${STAGING_LIBDIR}
+# oe_libinstall -so nfslock ${STAGING_LIBDIR}
+}
+
+do_install () {
+ oe_runmake 'ROOT=${D}' INSTGRP='' install
+}