aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libmikmod/libmikmod_3.2.0-beta2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libmikmod/libmikmod_3.2.0-beta2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libmikmod/libmikmod_3.2.0-beta2.bb')
-rw-r--r--recipes/libmikmod/libmikmod_3.2.0-beta2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/libmikmod/libmikmod_3.2.0-beta2.bb b/recipes/libmikmod/libmikmod_3.2.0-beta2.bb
new file mode 100644
index 0000000000..07e3af9a40
--- /dev/null
+++ b/recipes/libmikmod/libmikmod_3.2.0-beta2.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "libmikmod is a module player library supporting many formats, including mod, s3m, it, and xm."
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "\
+ http://mikmod.raphnet.net/files/libmikmod-${PV}.tar.gz \
+ file://m4.patch;patch=1 \
+ file://autofoo.patch;patch=1 \
+"
+
+inherit autotools binconfig
+
+EXTRA_OECONF = "\
+ --disable-af \
+ --enable-alsa \
+ --disable-esd \
+ --enable-oss \
+ --disable-sam9407 \
+ --disable-ultra \
+ --disable-esdtest \
+ --enable-threads \
+"
+
+do_stage() {
+ oe_libinstall -a -so -C libmikmod libmikmod ${STAGING_LIBDIR}
+ install -m 0644 ${S}/include/mikmod.h ${STAGING_INCDIR}/
+ install -d ${STAGING_DATADIR}/aclocal/
+ install -m 0644 libmikmod.m4 ${STAGING_DATADIR}/aclocal/
+}