summaryrefslogtreecommitdiffstats
path: root/recipes/libnet
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2010-03-29 15:00:16 -0700
committerKoen Kooi <koen@openembedded.org>2010-03-30 17:46:12 +0200
commite8052e4cb7830519eb6e06aac083f00150d8fb43 (patch)
treee93c4552f91a0f87f498079d2816d6588e40b34e /recipes/libnet
parentc90bdc8faf4ac4771cf8954f1934ff06f9056cb0 (diff)
downloadopenembedded-e8052e4cb7830519eb6e06aac083f00150d8fb43.tar.gz
libnet: convert to new staging
Diffstat (limited to 'recipes/libnet')
-rw-r--r--recipes/libnet/libnet_1.1.2.1.bb11
1 files changed, 5 insertions, 6 deletions
diff --git a/recipes/libnet/libnet_1.1.2.1.bb b/recipes/libnet/libnet_1.1.2.1.bb
index cb7700ac93..0c71b83317 100644
--- a/recipes/libnet/libnet_1.1.2.1.bb
+++ b/recipes/libnet/libnet_1.1.2.1.bb
@@ -6,7 +6,7 @@ LICENSE = "BSD"
DEPENDS = "libpcap"
# There are major API changes beween libnet v1.0 and libnet v1.1
PROVIDES = "libnet-1.1"
-PR = "r3"
+PR = "r4"
SRC_URI = "${DEBIAN_MIRROR}/main/libn/libnet/libnet_${PV}.orig.tar.gz \
file://support-uclibc.patch;patch=1 \
@@ -20,17 +20,16 @@ inherit autotools binconfig
do_configure_prepend() {
rm -f aclocal.m4 Makefile.am ltmain.sh
}
+
do_install_append () {
+ oe_runmake -C src 'DESTDIR=${D}${libdir}/' 'libdir=' install-libLIBRARIES
+ oe_runmake -C include 'DESTDIR=${D}${includedir}/' 'includedir=' install-includeHEADERS
+ oe_runmake -C include/libnet 'DESTDIR=${D}${includedir}/' 'includedir=' install-libnetincludeHEADERS
install -d ${D}${datadir}/man/man3/
install -d ${D}${bindir}
install -m 0644 ${S}/doc/man/man3/*.3 ${D}${datadir}/man/man3/
install -m 0755 ${S}/libnet-config ${D}${bindir}
}
-do_stage () {
- oe_runmake -C src 'DESTDIR=${STAGING_LIBDIR}' 'libdir=' install-libLIBRARIES
- oe_runmake -C include 'DESTDIR=${STAGING_INCDIR}' 'includedir=' install-includeHEADERS
- oe_runmake -C include/libnet 'DESTDIR=${STAGING_INCDIR}' 'includedir=' install-libnetincludeHEADERS
-}
#static build
FILES_${PN} = ""