aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libnfo
diff options
context:
space:
mode:
authorPaul Menzel <paulepanter@users.sourceforge.net>2010-03-19 04:38:46 +0000
committerKoen Kooi <koen@openembedded.org>2010-03-27 09:33:41 +0100
commita8656f0d6763b67a1bf8bb097998086a3c0521aa (patch)
treee4a1a77d56ab028693c61141c0604658da0884ed /recipes/libnfo
parentc4b15bc76bf22ef0f8da5d752d187fa6395bbbcf (diff)
downloadopenembedded-a8656f0d6763b67a1bf8bb097998086a3c0521aa.tar.gz
libnfo: Add libnfo hg.
1. `--enable-pic` is needed for non-x86 architectures. 2. Put test programs in separate package `${PN}-bin`. Manual pages are in `${PN}-doc` though. 3. Build tested with GCC 4.4.3 and Binutils 2.20.1 for `MACHINE = "beagleboard"`. 4. I did not use release 1.0.0 since `configure` in that version does not have the option `--enable-pic`. [ fixed SRC_URI and PV - Koen ] Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/libnfo')
-rw-r--r--recipes/libnfo/libnfo.inc26
-rw-r--r--recipes/libnfo/libnfo_hg.bb9
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes/libnfo/libnfo.inc b/recipes/libnfo/libnfo.inc
new file mode 100644
index 0000000000..c58f145593
--- /dev/null
+++ b/recipes/libnfo/libnfo.inc
@@ -0,0 +1,26 @@
+DESCRIPTION = "GeeXboX libNFO is a small library aiming at parsing and writing NFO files."
+HOMEPAGE = "http://libnfo.geexbox.org/"
+SECTION = "libs/multimedia"
+LICENSE = "LGPLv2+"
+DEPENDS = "libxml2"
+
+INC_PR = "r0"
+
+SRC_URI = "http://libnfo.geexbox.org/releases/${PN}.tar.bz2;name=${PN}"
+
+inherit autotools pkgconfig
+
+# the configure script is hand-crafted, it rejects some of the usual
+# configure arguments
+do_configure() {
+ ${S}/configure \
+ --prefix=${prefix} \
+ --disable-strip \
+ --cross-compile \
+ --enable-pic \
+ --enable-doc
+}
+
+PACKAGES =+ "${PN}-bin"
+
+FILES_${PN}-bin = "${bindir}/*"
diff --git a/recipes/libnfo/libnfo_hg.bb b/recipes/libnfo/libnfo_hg.bb
new file mode 100644
index 0000000000..a70ac38f98
--- /dev/null
+++ b/recipes/libnfo/libnfo_hg.bb
@@ -0,0 +1,9 @@
+require libnfo.inc
+PV = "1.0.0+hg"
+PR = "${INC_PR}.0"
+
+SRCREV = "8f6237741f72"
+
+SRC_URI = "hg://hg.geexbox.org;module=${PN};rev=${SRCREV}"
+
+S = "${WORKDIR}/${PN}"