aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libnss-mdns
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libnss-mdns
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libnss-mdns')
-rw-r--r--recipes/libnss-mdns/libnss-mdns_0.9.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/libnss-mdns/libnss-mdns_0.9.bb b/recipes/libnss-mdns/libnss-mdns_0.9.bb
new file mode 100644
index 0000000000..171ff5113b
--- /dev/null
+++ b/recipes/libnss-mdns/libnss-mdns_0.9.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "NSS module for Multicast DNS name resolution"
+HOMEPAGE = "http://0pointer.de/lennart/projects/nss-mdns/"
+LICENSE = "GPL"
+SECTION = "libs"
+PRIORITY = "optional"
+
+RRECOMMENDS_${PN} = "zeroconf"
+PR = "r0"
+
+EXTRA_OECONF = "--libdir=/lib"
+S = "${WORKDIR}/nss-mdns-${PV}"
+
+SRC_URI = "http://0pointer.de/lennart/projects/nss-mdns/nss-mdns-${PV}.tar.gz"
+
+inherit autotools
+
+pkg_postinst () {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+ cat /etc/nsswitch.conf | grep "hosts:\s*files dns$" > /dev/null && {
+ cat /etc/nsswitch.conf | sed 's/\(hosts:\s*files \)dns/\1mdns4_minimal [NOTFOUND=return] dns mdns4/' > /tmp/nsswitch.conf
+ mv /tmp/nsswitch.conf /etc/nsswitch.conf
+ }
+}
+
+pkg_prerm () {
+ cat /etc/nsswitch.conf | grep "hosts:\s*files dns mdns$" > /dev/null && {
+ cat /etc/nsswitch.conf | sed 's/\(hosts:\s*files \)mdns4_minimal [NOTFOUND=return] dns mdns4/\1dns/' > /tmp/nsswitch.conf
+ mv /tmp/nsswitch.conf /etc/nsswitch.conf
+ }
+}