aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libopieobex
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libopieobex
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libopieobex')
-rw-r--r--recipes/libopieobex/files/disable-bt-check.patch19
-rw-r--r--recipes/libopieobex/libopieobex0.inc22
-rw-r--r--recipes/libopieobex/libopieobex0_1.2.2.bb5
-rw-r--r--recipes/libopieobex/libopieobex0_1.2.3.bb6
-rw-r--r--recipes/libopieobex/libopieobex0_1.2.4.bb6
-rw-r--r--recipes/libopieobex/libopieobex0_cvs.bb7
6 files changed, 65 insertions, 0 deletions
diff --git a/recipes/libopieobex/files/disable-bt-check.patch b/recipes/libopieobex/files/disable-bt-check.patch
new file mode 100644
index 0000000000..067af145f7
--- /dev/null
+++ b/recipes/libopieobex/files/disable-bt-check.patch
@@ -0,0 +1,19 @@
+--- obex/obex.pro 2007-07-20 23:44:06.000000000 +1200
++++ obex/obex.pro 2007-10-18 17:57:15.000000000 +1300
+@@ -13,12 +13,12 @@
+ include( $(OPIEDIR)/include.pro )
+ target.path = $$prefix/plugins/applets
+
+-#FIXME: These parameters are used if bluetooth is used
+-CONFTEST = $$system( echo $CONFIG_LIBOPIETOOTH )
+-contains( CONFTEST, y ){
++#FIXME: This test does not work under OE. Instead, just always enable bluetooth.
++#CONFTEST = $$system( echo $CONFIG_LIBOPIETOOTH )
++#contains( CONFTEST, y ){
+ HEADERS += btobex.h
+ SOURCES += btobex.cpp
+ INCLUDEPATH += $(OPIEDIR)/noncore/net/opietooth/lib
+ LIBS += -lopietooth1 -lbluetooth
+ DEFINES += BLUETOOTH
+-}
++#}
diff --git a/recipes/libopieobex/libopieobex0.inc b/recipes/libopieobex/libopieobex0.inc
new file mode 100644
index 0000000000..3fe3d533e5
--- /dev/null
+++ b/recipes/libopieobex/libopieobex0.inc
@@ -0,0 +1,22 @@
+DESCRIPTION = "IrDA obex support library"
+SECTION = "opie/libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "libopietooth1 opie-taskbar openobex-apps"
+RDEPENDS = "openobex-apps"
+APPNAME = "obex"
+
+S = "${WORKDIR}/obex"
+
+inherit opie
+
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${STAGING_INCDIR}/opietooth"
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/ ${D}${palmtopdir}/plugins/obex/
+ install -m 0644 ${WORKDIR}/pics/backup/check.png ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+ oe_libinstall -so libopieobex ${D}${palmtopdir}/plugins/obex/
+}
+
+FILES_${PN} = "${palmtopdir}/plugins/obex/ ${palmtopdir}/pics/obex/"
diff --git a/recipes/libopieobex/libopieobex0_1.2.2.bb b/recipes/libopieobex/libopieobex0_1.2.2.bb
new file mode 100644
index 0000000000..eeaeb7bb70
--- /dev/null
+++ b/recipes/libopieobex/libopieobex0_1.2.2.bb
@@ -0,0 +1,5 @@
+require libopieobex0.inc
+
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/obex \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/pics "
diff --git a/recipes/libopieobex/libopieobex0_1.2.3.bb b/recipes/libopieobex/libopieobex0_1.2.3.bb
new file mode 100644
index 0000000000..047dcee6e6
--- /dev/null
+++ b/recipes/libopieobex/libopieobex0_1.2.3.bb
@@ -0,0 +1,6 @@
+require libopieobex0.inc
+PR = "r1"
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/obex \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/pics \
+ file://disable-bt-check.patch;patch=1"
diff --git a/recipes/libopieobex/libopieobex0_1.2.4.bb b/recipes/libopieobex/libopieobex0_1.2.4.bb
new file mode 100644
index 0000000000..5e02c8860d
--- /dev/null
+++ b/recipes/libopieobex/libopieobex0_1.2.4.bb
@@ -0,0 +1,6 @@
+require libopieobex0.inc
+PR = "r0"
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/obex \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/pics \
+ file://disable-bt-check.patch;patch=1"
diff --git a/recipes/libopieobex/libopieobex0_cvs.bb b/recipes/libopieobex/libopieobex0_cvs.bb
new file mode 100644
index 0000000000..50c36686a9
--- /dev/null
+++ b/recipes/libopieobex/libopieobex0_cvs.bb
@@ -0,0 +1,7 @@
+require libopieobex0.inc
+PV = "${OPIE_CVS_PV}"
+PR = "r7"
+
+SRC_URI = "${HANDHELDS_CVS};module=opie/core/obex \
+ ${HANDHELDS_CVS};module=opie/pics \
+ file://disable-bt-check.patch;patch=1"