aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libowl
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libowl
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libowl')
-rw-r--r--recipes/libowl/libowl_svn.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes/libowl/libowl_svn.bb b/recipes/libowl/libowl_svn.bb
new file mode 100644
index 0000000000..d5042b78a1
--- /dev/null
+++ b/recipes/libowl/libowl_svn.bb
@@ -0,0 +1,39 @@
+# This recipe builds libowl and then stages the header and static lib;
+# it intentionally does not stage the shared lib and create a package.
+#
+# Libowl is currently a 'cut and paste' library; this package makes our
+# life a touch easier by not having to patch the source directly into
+# applications; instead we add -lowl to the linker cmdline. Also, when
+# we eventually make libowl into a normal shared library, this package
+# will make that transition rather simple.
+
+DESCRIPTION = "OpenedHand Widget Library"
+HOMEPAGE = "http://www.o-hand.com"
+LICENSE = "LGPL"
+SECTION = "libs"
+DEPENDS = "gtk+"
+PV = "0.0+svnr${SRCREV}"
+PR = "r3"
+
+PACKAGES = ""
+
+SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=${PN};proto=http"
+
+S = "${WORKDIR}/${PN}"
+
+inherit autotools pkgconfig
+
+do_compile_prepend() {
+ # have to unstage the library first so that the tests build
+ rm -f ${STAGING_LIBDIR}/libowl*
+ rm -f ${STAGING_INCDIR}/owl*
+}
+
+do_stage() {
+ headers=`eval ls libowl/owl*.h`
+ for header in $headers; do
+ hdr_base=`eval basename $header`
+ install -m 644 $header ${STAGING_INCDIR}/$hdr_base
+ done
+ install -m 644 libowl/.libs/libowl.a ${STAGING_LIBDIR}/
+}