aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libpcre
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-12-13 15:41:13 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-12-13 15:41:13 +0100
commit5971f7fdc2c0098282880af56dbb6f775dd9dd93 (patch)
tree675a5b32dd8b7b2597363540fd8bba8dc2150c81 /recipes/libpcre
parentfcb6929125fdc4e1bd31aa198897cd50ca41ae9c (diff)
downloadopenembedded-5971f7fdc2c0098282880af56dbb6f775dd9dd93.tar.gz
libpcre: added do_stage becase pcre-config does not autstage
Diffstat (limited to 'recipes/libpcre')
-rw-r--r--recipes/libpcre/libpcre_7.6.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/libpcre/libpcre_7.6.bb b/recipes/libpcre/libpcre_7.6.bb
index f9c9c06cd4..f89f83d631 100644
--- a/recipes/libpcre/libpcre_7.6.bb
+++ b/recipes/libpcre/libpcre_7.6.bb
@@ -5,7 +5,7 @@ provides a POSIX calling interface to PCRE; the regular expressions \
themselves still follow Perl syntax and semantics. The header file for \
the POSIX-style functions is called pcreposix.h."
SECTION = "devel"
-PR = "r5"
+PR = "r6"
LICENSE = "BSD"
SRC_URI = "${SOURCEFORGE_MIRROR}/pcre/pcre-${PV}.tar.bz2 \
file://pcre-cross.patch;patch=1"
@@ -38,6 +38,11 @@ do_compile () {
oe_runmake CC_FOR_BUILD="${BUILD_CC}" CFLAGS_FOR_BUILD="-DLINK_SIZE=2 -I${S}/include" LINK_FOR_BUILD="${BUILD_CC} -L${S}/lib"
}
+do_stage () {
+ autotools_stage_all
+ install -d ${STAGING_BINDIR}
+ install -m 0755 ${D}${bindir}/pcre-config ${STAGING_BINDIR}/
+}
python populate_packages_prepend () {
pcre_libdir = bb.data.expand('${libdir}', d)
pcre_libdir_dbg = bb.data.expand('${libdir}/.debug', d)