aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libpixman
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libpixman
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libpixman')
-rw-r--r--recipes/libpixman/libpixman_0.1.5.bb12
-rw-r--r--recipes/libpixman/libpixman_0.1.6.bb12
-rw-r--r--recipes/libpixman/libpixman_0.10.0.bb13
-rw-r--r--recipes/libpixman/libpixman_0.9.6.bb13
-rw-r--r--recipes/libpixman/libpixman_cvs.bb16
5 files changed, 66 insertions, 0 deletions
diff --git a/recipes/libpixman/libpixman_0.1.5.bb b/recipes/libpixman/libpixman_0.1.5.bb
new file mode 100644
index 0000000000..bf23947fc1
--- /dev/null
+++ b/recipes/libpixman/libpixman_0.1.5.bb
@@ -0,0 +1,12 @@
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libx11"
+DESCRIPTION = "Cairo support library"
+LICENSE = "X11"
+SRC_URI = "http://cairographics.org/snapshots/libpixman-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ autotools_stage_all
+}
diff --git a/recipes/libpixman/libpixman_0.1.6.bb b/recipes/libpixman/libpixman_0.1.6.bb
new file mode 100644
index 0000000000..bf23947fc1
--- /dev/null
+++ b/recipes/libpixman/libpixman_0.1.6.bb
@@ -0,0 +1,12 @@
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libx11"
+DESCRIPTION = "Cairo support library"
+LICENSE = "X11"
+SRC_URI = "http://cairographics.org/snapshots/libpixman-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ autotools_stage_all
+}
diff --git a/recipes/libpixman/libpixman_0.10.0.bb b/recipes/libpixman/libpixman_0.10.0.bb
new file mode 100644
index 0000000000..fba7dc9152
--- /dev/null
+++ b/recipes/libpixman/libpixman_0.10.0.bb
@@ -0,0 +1,13 @@
+SECTION = "libs"
+PRIORITY = "optional"
+DESCRIPTION = "Low-level pixel manipulation library."
+LICENSE = "X11"
+SRC_URI = "http://cairographics.org/releases/pixman-${PV}.tar.gz"
+S = "${WORKDIR}/pixman-${PV}"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ autotools_stage_all
+}
+
diff --git a/recipes/libpixman/libpixman_0.9.6.bb b/recipes/libpixman/libpixman_0.9.6.bb
new file mode 100644
index 0000000000..fba7dc9152
--- /dev/null
+++ b/recipes/libpixman/libpixman_0.9.6.bb
@@ -0,0 +1,13 @@
+SECTION = "libs"
+PRIORITY = "optional"
+DESCRIPTION = "Low-level pixel manipulation library."
+LICENSE = "X11"
+SRC_URI = "http://cairographics.org/releases/pixman-${PV}.tar.gz"
+S = "${WORKDIR}/pixman-${PV}"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ autotools_stage_all
+}
+
diff --git a/recipes/libpixman/libpixman_cvs.bb b/recipes/libpixman/libpixman_cvs.bb
new file mode 100644
index 0000000000..a75a284bca
--- /dev/null
+++ b/recipes/libpixman/libpixman_cvs.bb
@@ -0,0 +1,16 @@
+PV = "0.0+cvs${SRCDATE}"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libx11"
+DESCRIPTION = "Cairo support library"
+LICENSE = "X11"
+SRC_URI = "cvs://anoncvs:anoncvs@cvs.cairographics.org/cvs/cairo;module=libpixman"
+S = "${WORKDIR}/libpixman"
+
+DEFAULT_PREFERENCE = "-1"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ autotools_stage_all
+}