aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libplayer
diff options
context:
space:
mode:
authorPaul Menzel <paulepanter@users.sourceforge.net>2010-03-19 04:42:08 +0000
committerKoen Kooi <koen@openembedded.org>2010-03-27 09:35:09 +0100
commit3d746df179cf33ecc0e87318e242eb23f86a9e1a (patch)
treeab6a146dfbce129bfa85822716fdba86cb3dfb64 /recipes/libplayer
parenta8656f0d6763b67a1bf8bb097998086a3c0521aa (diff)
downloadopenembedded-3d746df179cf33ecc0e87318e242eb23f86a9e1a.tar.gz
libplayer: Add libplayer hg.
1. `--enable-pic` is needed for non-x86 architectures. 2. Put test programs in separate package `${PN}-bin`. Manual pages are in `${PN}-doc` though. 3. Build tested with GCC 4.4.3 and Binutils 2.20.1 for `MACHINE = "beagleboard"`. 4. Depend on `mplayer` and `gstreamer`. Dependencies for vlc- or xine-wrappers can be added if needed. 5. I did not use release 1.0.0 since `configure` in that version does not have the option `--enable-pic`. [ fixed PV - koen ] Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/libplayer')
-rw-r--r--recipes/libplayer/libplayer.inc26
-rw-r--r--recipes/libplayer/libplayer_hg.bb9
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes/libplayer/libplayer.inc b/recipes/libplayer/libplayer.inc
new file mode 100644
index 0000000000..a986a211ed
--- /dev/null
+++ b/recipes/libplayer/libplayer.inc
@@ -0,0 +1,26 @@
+DESCRIPTION = "libplayer is a multimedia A/V abstraction layer API. Its goal is to interact with Enna Media Center."
+HOMEPAGE = "http://libplayer.geexbox.org/"
+SECTION = "libs/multimedia"
+LICENSE = "LGPLv2.1+"
+DEPENDS = "mplayer gstreamer"
+
+INC_PR = "r0"
+
+SRC_URI = "http://libplayer.geexbox.org/releases/${P}.tar.bz2;name=${PN}"
+
+inherit autotools pkgconfig
+
+# the configure script is hand-crafted, it rejects some of the usual
+# configure arguments
+do_configure() {
+ ${S}/configure \
+ --prefix=${prefix} \
+ --disable-strip \
+ --cross-compile \
+ --enable-pic \
+ --enable-doc
+}
+
+PACKAGES =+ "${PN}-bin"
+
+FILES_${PN}-bin = "${bindir}/*"
diff --git a/recipes/libplayer/libplayer_hg.bb b/recipes/libplayer/libplayer_hg.bb
new file mode 100644
index 0000000000..cfe150b308
--- /dev/null
+++ b/recipes/libplayer/libplayer_hg.bb
@@ -0,0 +1,9 @@
+require libplayer.inc
+PV = "1.0.0+hg"
+PR = "${INC_PR}.0"
+
+SRCREV = "a628f49d952a"
+
+SRC_URI = "hg://hg.geexbox.org;module=${PN};rev=${SRCREV}"
+
+S = "${WORKDIR}/${PN}"