aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libqpe
diff options
context:
space:
mode:
authorPaul Eggleton <bluelightning@bluelightning.org>2009-12-27 05:00:26 +0000
committerPaul Eggleton <bluelightning@bluelightning.org>2010-10-19 00:46:43 +0100
commite133b6e71fc3d08727749cc92a5ed37bbece4353 (patch)
tree314098c8d89ce962aea636f31be24f86d84eee86 /recipes/libqpe
parent463a4f992db344a39861bd67600e79e30fe41b18 (diff)
downloadopenembedded-e133b6e71fc3d08727749cc92a5ed37bbece4353.tar.gz
Build development versions of Opie from git instead of CVS.
Note that this change requires a version of BitBake with the "git subpath" patch applied. Signed-off-by: Paul Eggleton <bluelightning@bluelightning.org>
Diffstat (limited to 'recipes/libqpe')
-rw-r--r--recipes/libqpe/libqpe-opie/unbreak-logging-2.patch21
-rw-r--r--recipes/libqpe/libqpe-opie_cvs.bb12
2 files changed, 28 insertions, 5 deletions
diff --git a/recipes/libqpe/libqpe-opie/unbreak-logging-2.patch b/recipes/libqpe/libqpe-opie/unbreak-logging-2.patch
new file mode 100644
index 0000000000..fe4bb88969
--- /dev/null
+++ b/recipes/libqpe/libqpe-opie/unbreak-logging-2.patch
@@ -0,0 +1,21 @@
+--- library/qpeapplication.cpp
++++ library/qpeapplication.cpp
+@@ -803,14 +803,14 @@ static void qtopiaMsgHandler(QtMsgType type, const char* msg)
+ {
+ switch ( type ) {
+ case QtDebugMsg:
+-#ifdef QT_DEBUG
++//#ifdef QT_DEBUG
+ fprintf( stderr, "Debug: %s\n", msg );
+-#endif
++//#endif
+ break;
+ case QtWarningMsg:
+-#ifdef QT_DEBUG
++//#ifdef QT_DEBUG
+ fprintf( stderr, "Warning: %s\n", msg );
+-#endif
++//#endif
+ break;
+ case QtFatalMsg:
+ fprintf( stderr, "Fatal: %s\n", msg );
diff --git a/recipes/libqpe/libqpe-opie_cvs.bb b/recipes/libqpe/libqpe-opie_cvs.bb
index 6ba11ce6f4..fda7ef0df1 100644
--- a/recipes/libqpe/libqpe-opie_cvs.bb
+++ b/recipes/libqpe/libqpe-opie_cvs.bb
@@ -1,15 +1,17 @@
require ${PN}.inc
-# OPIE_CVS_PV is defined in opie.bbclass
+# OPIE_GIT_PV is defined in opie.bbclass
# but this recipe does not inherit opie
-# so any updates to OPIE_CVS_PV should happen
+# so any updates to OPIE_GIT_PV should happen
# in both places.
-OPIE_CVS_PV ?= "1.2.2+cvs${SRCDATE}"
-PV = "${OPIE_CVS_PV}"
+OPIE_GIT_PV ?= "1.2.2+cvs${SRCDATE}"
+PV = "${OPIE_GIT_PV}"
PR = "${INC_PR}.0"
-SRC_URI = "${HANDHELDS_CVS};module=opie/library \
+DEPENDS += " sysfsutils"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=library \
file://fix-titleheight.patch \
file://unbreak-logging.patch \
file://citytime-path-2.patch \