aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libsamplerate
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-03-23 16:30:55 +0800
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-03-23 16:30:55 +0800
commitdd651f27f6c62a043e06025c9825f38264245229 (patch)
tree7ff76543692f5cfe6425ed13155bb348cfc3c2ce /recipes/libsamplerate
parent0c77e1f49fdbf22cce43f2e794393bcf34cc652c (diff)
downloadopenembedded-dd651f27f6c62a043e06025c9825f38264245229.tar.gz
libsamplerate0-0.1.7: Fix configure run with recent autoconf
* Remove the oe_runconf overload and just go through the normal autoreconf process * Take gentoo patch to fix the quoting of the macro and make building go past the configure task.
Diffstat (limited to 'recipes/libsamplerate')
-rw-r--r--recipes/libsamplerate/files/libsamplerate-0.1.7-macro-quoting.patch21
-rw-r--r--recipes/libsamplerate/files/libsamplerate-0.1.7-tests.patch23
-rw-r--r--recipes/libsamplerate/libsamplerate0_0.1.7.bb13
3 files changed, 50 insertions, 7 deletions
diff --git a/recipes/libsamplerate/files/libsamplerate-0.1.7-macro-quoting.patch b/recipes/libsamplerate/files/libsamplerate-0.1.7-macro-quoting.patch
new file mode 100644
index 0000000000..df49e0b883
--- /dev/null
+++ b/recipes/libsamplerate/files/libsamplerate-0.1.7-macro-quoting.patch
@@ -0,0 +1,21 @@
+From gentoo
+
+--- acinclude.m4.old 2009-02-16 20:40:05.000000000 +0000
++++ acinclude.m4 2009-02-16 20:43:42.000000000 +0000
+@@ -135,7 +135,6 @@
+ fi
+
+ )
+-]
+
+ if test $ac_cv_c_byte_order = big ; then
+ ac_cv_c_big_endian=1
+@@ -154,7 +153,7 @@
+ AC_MSG_WARN([[*****************************************************************]])
+ fi
+
+-)# AC_C_FIND_ENDIAN
++])# AC_C_FIND_ENDIAN
+
+
+
diff --git a/recipes/libsamplerate/files/libsamplerate-0.1.7-tests.patch b/recipes/libsamplerate/files/libsamplerate-0.1.7-tests.patch
new file mode 100644
index 0000000000..337be1d01a
--- /dev/null
+++ b/recipes/libsamplerate/files/libsamplerate-0.1.7-tests.patch
@@ -0,0 +1,23 @@
+From Gentoo
+
+Patch from Erik (upstream) to fix tests on 64 bits platforms.
+
+Index: libsamplerate-0.1.7/tests/callback_test.c
+===================================================================
+--- libsamplerate-0.1.7.orig/tests/callback_test.c
++++ libsamplerate-0.1.7/tests/callback_test.c
+@@ -137,11 +137,11 @@ callback_test (int converter, double src
+
+ src_state = src_delete (src_state) ;
+
+- if (fabs (read_total - src_ratio * ARRAY_LEN (test_callback_data.data)) > src_ratio)
++ if (fabs (read_total / src_ratio - ARRAY_LEN (test_callback_data.data)) > 2.0)
+ { printf ("\n\nLine %d : input / output length mismatch.\n\n", __LINE__) ;
+ printf (" input len : %d\n", ARRAY_LEN (test_callback_data.data)) ;
+- printf (" output len : %ld (should be %g +/- %g)\n\n", read_total,
+- floor (0.5 + src_ratio * ARRAY_LEN (test_callback_data.data)), ceil (src_ratio)) ;
++ printf (" output len : %ld (should be %g +/- 2)\n\n", read_total,
++ floor (0.5 + src_ratio * ARRAY_LEN (test_callback_data.data))) ;
+ exit (1) ;
+ } ;
+
diff --git a/recipes/libsamplerate/libsamplerate0_0.1.7.bb b/recipes/libsamplerate/libsamplerate0_0.1.7.bb
index 1d377f1260..b41f97fe21 100644
--- a/recipes/libsamplerate/libsamplerate0_0.1.7.bb
+++ b/recipes/libsamplerate/libsamplerate0_0.1.7.bb
@@ -2,13 +2,12 @@ DESCRIPTION = "An audio Sample Rate Conversion library"
SECTION = "libs"
LICENSE = "GPL libsamplerate"
-SRC_URI = "http://www.mega-nerd.com/SRC/libsamplerate-${PV}.tar.gz"
-S = "${WORKDIR}/libsamplerate-${PV}"
+PR = "r1"
-inherit autotools_stage pkgconfig
+SRC_URI = "http://www.mega-nerd.com/SRC/libsamplerate-${PV}.tar.gz \
+ file://libsamplerate-0.1.7-macro-quoting.patch;patch=1;pnum=0 \
+ file://libsamplerate-0.1.7-tests.patch;patch=1 "
+S = "${WORKDIR}/libsamplerate-${PV}"
-do_configure() {
- gnu-configize --force
- oe_runconf
-}
+inherit autotools pkgconfig