aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libsdl/libsdl-native_1.2.11.bb
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-01-04 12:46:24 +0800
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-01-04 06:42:11 +0100
commitdc35d97c92c04e02a8ed46620cc8ccb249071210 (patch)
treee62e8d1cb46fb49b054f6f9a14418180cc962aee /recipes/libsdl/libsdl-native_1.2.11.bb
parent97e1b707d6504343f02e683f49eb2cb6db2cc091 (diff)
downloadopenembedded-dc35d97c92c04e02a8ed46620cc8ccb249071210.tar.gz
libsdl-native: Create libsdl-native.inc
* Create a libsdl-native.inc and make 1.2.11 and 1.2.14 use it * Convert to INC_PR scheme as well
Diffstat (limited to 'recipes/libsdl/libsdl-native_1.2.11.bb')
-rw-r--r--recipes/libsdl/libsdl-native_1.2.11.bb36
1 files changed, 4 insertions, 32 deletions
diff --git a/recipes/libsdl/libsdl-native_1.2.11.bb b/recipes/libsdl/libsdl-native_1.2.11.bb
index fb8e12a4c9..86d3a452cf 100644
--- a/recipes/libsdl/libsdl-native_1.2.11.bb
+++ b/recipes/libsdl/libsdl-native_1.2.11.bb
@@ -1,39 +1,11 @@
-DESCRIPTION = "Simple DirectMedia Layer - native Edition"
-HOMEPAGE = "http://www.libsdl.org"
-SECTION = "libs"
-LICENSE = "LGPL"
-PR = "r2"
+require ${PN}.inc
+PR = "${INC_PR}.1"
-SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
+SRC_URI_append = "\
file://acinclude.m4 \
file://kernel-asm-page.patch;patch=1 "
-S = "${WORKDIR}/SDL-${PV}"
-inherit autotools binconfig pkgconfig native
-
-PARALLEL_MAKE = ""
-
-EXTRA_OECONF = "--disable-debug --disable-cdrom --enable-threads --enable-timers --enable-endian \
- --enable-file --disable-oss --disable-alsa --disable-esd --disable-arts \
- --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
- --disable-mintaudio --disable-nasm --disable-video-x11 --disable-video-dga \
- --disable-video-fbcon --disable-video-directfb --disable-video-ps2gs \
- --disable-video-xbios --disable-video-gem --disable-video-dummy \
- --disable-video-opengl --enable-input-events --enable-pthreads \
- --disable-video-picogui --disable-video-qtopia --enable-dlopen"
-
-do_configure() {
+do_configure_prepend() {
rm -f ${S}/acinclude.m4
cp ${WORKDIR}/acinclude.m4 ${S}/
- gnu-configize
- oe_runconf
- cd ${S}
- # prevent libtool from linking libs against libstdc++, libgcc, ...
- cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
- mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
-}
-
-do_stage() {
- autotools_stage_all
- install -m 0644 build/libSDLmain.a ${STAGING_LIBDIR}
}