aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libsigc++-2.0
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libsigc++-2.0
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libsigc++-2.0')
-rw-r--r--recipes/libsigc++-2.0/libsigc++-2.0-2.0.17/define_sigc_api.patch15
-rw-r--r--recipes/libsigc++-2.0/libsigc++-2.0-2.0.6/define_sigc_api.patch12
-rw-r--r--recipes/libsigc++-2.0/libsigc++-2.0_2.0.17.bb47
-rw-r--r--recipes/libsigc++-2.0/libsigc++-2.0_2.0.6.bb45
-rw-r--r--recipes/libsigc++-2.0/libsigc++-2.0_2.2.2.bb21
5 files changed, 140 insertions, 0 deletions
diff --git a/recipes/libsigc++-2.0/libsigc++-2.0-2.0.17/define_sigc_api.patch b/recipes/libsigc++-2.0/libsigc++-2.0-2.0.17/define_sigc_api.patch
new file mode 100644
index 0000000000..ba17293733
--- /dev/null
+++ b/recipes/libsigc++-2.0/libsigc++-2.0-2.0.17/define_sigc_api.patch
@@ -0,0 +1,15 @@
+Index: libsigc++-2.0.17/configure.ac
+===================================================================
+--- libsigc++-2.0.17.orig/configure.ac 2005-12-20 08:41:21.000000000 +0000
++++ libsigc++-2.0.17/configure.ac 2007-07-11 11:33:55.000000000 +0100
+@@ -105,6 +105,10 @@
+ SIGC_CXX_HAS_NAMESPACE_STD()
+ SIGC_CXX_HAS_SUN_REVERSE_ITERATOR()
+
++dnl FIXME Define this here since it does not seem to be defined elsewhere
++AC_DEFINE(SIGC_API, [], [Empty specifier])
++AC_DEFINE(SIGC_USING_STD(Symbol), [], [Empty specifier])
++
+ if test "X$config_error" = "Xyes" ; then
+ AC_ERROR(
+ [One or more of the required compiler features is missing.
diff --git a/recipes/libsigc++-2.0/libsigc++-2.0-2.0.6/define_sigc_api.patch b/recipes/libsigc++-2.0/libsigc++-2.0-2.0.6/define_sigc_api.patch
new file mode 100644
index 0000000000..91828e1297
--- /dev/null
+++ b/recipes/libsigc++-2.0/libsigc++-2.0-2.0.6/define_sigc_api.patch
@@ -0,0 +1,12 @@
+--- libsigc++-2.0.6/configure.ac.old 2005-01-21 16:05:45.000000000 +0100
++++ libsigc++-2.0.6/configure.ac 2005-01-21 16:07:35.000000000 +0100
+@@ -74,6 +74,9 @@
+ SIGC_CXX_GCC_TEMPLATE_SPECIALIZATION_OPERATOR_OVERLOAD()
+ SIGC_CXX_MSVC_TEMPLATE_SPECIALIZATION_OPERATOR_OVERLOAD()
+
++dnl FIXME Define this here since it does not seem to be defined elsewhere
++AC_DEFINE(SIGC_API, [], [Empty specifier])
++
+ if test "X$config_error" = "Xyes" ; then
+ AC_ERROR(
+ [One or more of the required compiler features is missing.
diff --git a/recipes/libsigc++-2.0/libsigc++-2.0_2.0.17.bb b/recipes/libsigc++-2.0/libsigc++-2.0_2.0.17.bb
new file mode 100644
index 0000000000..222c5bd86a
--- /dev/null
+++ b/recipes/libsigc++-2.0/libsigc++-2.0_2.0.17.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "A library for loose coupling of C++ method calls"
+SECTION = "libs"
+PRIORITY = "optional"
+PR = "r1"
+LICENSE = "GPL LGPL"
+SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.0/libsigc++-${PV}.tar.gz \
+ file://define_sigc_api.patch;patch=1 "
+S = "${WORKDIR}/libsigc++-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_AUTORECONF = "--exclude=autoheader"
+
+FILES_${PN}-dev += "${libdir}/sigc++-*/"
+
+# acpaths = ""
+
+do_stage() {
+ install -d ${STAGING_LIBDIR}/sigc++-2.0/include
+ install -m 0644 sigc++config.h ${STAGING_LIBDIR}/sigc++-2.0/include/
+ oe_libinstall -so -C sigc++ libsigc-2.0 ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/sigc++-2.0/sigc++
+ for f in sigc++/*.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/sigc++-2.0/sigc++/
+ done
+ install -d ${STAGING_INCDIR}/sigc++-2.0/sigc++/functors
+ for f in sigc++/functors/*.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/sigc++-2.0/sigc++/functors
+ done
+
+ install -d ${STAGING_INCDIR}/sigc++-2.0/sigc++/adaptors
+ for f in sigc++/adaptors/*.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/sigc++-2.0/sigc++/adaptors
+ done
+ install -d ${STAGING_INCDIR}/sigc++-2.0/sigc++/adaptors/lambda
+ for f in sigc++/adaptors/lambda/*.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/sigc++-2.0/sigc++/adaptors/lambda
+ done
+
+
+}
+
diff --git a/recipes/libsigc++-2.0/libsigc++-2.0_2.0.6.bb b/recipes/libsigc++-2.0/libsigc++-2.0_2.0.6.bb
new file mode 100644
index 0000000000..0009990d79
--- /dev/null
+++ b/recipes/libsigc++-2.0/libsigc++-2.0_2.0.6.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "A library for loose coupling of C++ method calls"
+SECTION = "libs"
+PRIORITY = "optional"
+PR = "r1"
+LICENSE = "GPL LGPL"
+SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.0/libsigc++-${PV}.tar.gz \
+ file://define_sigc_api.patch;patch=1"
+S = "${WORKDIR}/libsigc++-${PV}"
+
+inherit autotools pkgconfig
+
+FILES_${PN}-dev += "${libdir}/sigc++-*/"
+
+# acpaths = ""
+
+do_stage() {
+ install -d ${STAGING_LIBDIR}/sigc++-2.0/include
+ install -m 0644 sigc++config.h ${STAGING_LIBDIR}/sigc++-2.0/include/
+ oe_libinstall -so -C sigc++ libsigc-2.0 ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/sigc++-2.0/sigc++
+ for f in sigc++/*.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/sigc++-2.0/sigc++/
+ done
+ install -d ${STAGING_INCDIR}/sigc++-2.0/sigc++/functors
+ for f in sigc++/functors/*.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/sigc++-2.0/sigc++/functors
+ done
+
+ install -d ${STAGING_INCDIR}/sigc++-2.0/sigc++/adaptors
+ for f in sigc++/adaptors/*.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/sigc++-2.0/sigc++/adaptors
+ done
+ install -d ${STAGING_INCDIR}/sigc++-2.0/sigc++/adaptors/lambda
+ for f in sigc++/adaptors/lambda/*.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/sigc++-2.0/sigc++/adaptors/lambda
+ done
+
+
+}
+
diff --git a/recipes/libsigc++-2.0/libsigc++-2.0_2.2.2.bb b/recipes/libsigc++-2.0/libsigc++-2.0_2.2.2.bb
new file mode 100644
index 0000000000..61d34840c9
--- /dev/null
+++ b/recipes/libsigc++-2.0/libsigc++-2.0_2.2.2.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "A library for loose coupling of C++ method calls"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL"
+SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2/libsigc++-${PV}.tar.gz \
+ "
+
+S = "${WORKDIR}/libsigc++-${PV}"
+
+inherit autotools
+
+EXTRA_AUTORECONF = "--exclude=autoheader"
+
+FILES_${PN}-dev += "${libdir}/sigc++-*/"
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+