aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libstroke
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libstroke
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libstroke')
-rw-r--r--recipes/libstroke/libstroke-0.5.1/Makefile.am.patch11
-rw-r--r--recipes/libstroke/libstroke-0.5.1/configure.in.patch24
-rw-r--r--recipes/libstroke/libstroke-0.5.1/libgstroke-Makefile.am.patch11
-rw-r--r--recipes/libstroke/libstroke-0.5.1/libstroke-Makefile.am.patch15
-rw-r--r--recipes/libstroke/libstroke-0.5.1/tests-Makefile.am.patch15
-rw-r--r--recipes/libstroke/libstroke_0.5.1.bb20
6 files changed, 96 insertions, 0 deletions
diff --git a/recipes/libstroke/libstroke-0.5.1/Makefile.am.patch b/recipes/libstroke/libstroke-0.5.1/Makefile.am.patch
new file mode 100644
index 0000000000..631da1d25a
--- /dev/null
+++ b/recipes/libstroke/libstroke-0.5.1/Makefile.am.patch
@@ -0,0 +1,11 @@
+--- libstroke-0.5.1/Makefile.am.orig 2008-06-11 14:10:49.000000000 +0400
++++ libstroke-0.5.1/Makefile.am 2008-06-11 14:12:06.000000000 +0400
+@@ -5,7 +5,7 @@
+ GSTROKE_SUBDS =
+ endif
+
+-SUBDIRS = libstroke $(GSTROKE_SUBDS) tests doc javastroke
++SUBDIRS = libstroke $(GSTROKE_SUBDS) doc
+
+ EXTRA_DIST = COPYRIGHT CREDITS README.javastroke README.libgstroke
+
diff --git a/recipes/libstroke/libstroke-0.5.1/configure.in.patch b/recipes/libstroke/libstroke-0.5.1/configure.in.patch
new file mode 100644
index 0000000000..d0ed97b88e
--- /dev/null
+++ b/recipes/libstroke/libstroke-0.5.1/configure.in.patch
@@ -0,0 +1,24 @@
+--- libstroke-0.5.1/configure.in.orig 2008-06-11 12:54:29.000000000 +0400
++++ libstroke-0.5.1/configure.in 2008-06-11 12:54:35.000000000 +0400
+@@ -83,14 +83,14 @@
+
+ dnl check for GTK
+ dnl we won't build libgstroke if it's not found
+-AC_MSG_CHECKING(gtk+ library)
+-AM_PATH_GTK(1.2.7, HAVE_LIBGTK=yes
+- AC_DEFINE(HAVE_LIBGTK, 1, [Define if libgtk is available]),
+- AC_MSG_WARN(
+-***** NOTE: The GNOME stroke support won't be built
+-)
++dnl AC_MSG_CHECKING(gtk+ library)
++dnl AM_PATH_GTK(1.2.7, HAVE_LIBGTK=yes
++dnl AC_DEFINE(HAVE_LIBGTK, 1, [Define if libgtk is available]),
++dnl AC_MSG_WARN(
++dnl ***** NOTE: The GNOME stroke support won't be built
++dnl )
+ HAVE_LIBGTK=no,
+-)
++dnl )
+ AM_CONDITIONAL(HAVE_LIBGTK, test "x$HAVE_LIBGTK" = "xyes")
+
+
diff --git a/recipes/libstroke/libstroke-0.5.1/libgstroke-Makefile.am.patch b/recipes/libstroke/libstroke-0.5.1/libgstroke-Makefile.am.patch
new file mode 100644
index 0000000000..b3251f3548
--- /dev/null
+++ b/recipes/libstroke/libstroke-0.5.1/libgstroke-Makefile.am.patch
@@ -0,0 +1,11 @@
+--- libstroke-0.5.1/libgstroke/Makefile.am.orig 2008-06-11 13:01:29.000000000 +0400
++++ libstroke-0.5.1/libgstroke/Makefile.am 2008-06-11 13:01:44.000000000 +0400
+@@ -21,7 +21,7 @@
+ INCLUDES = @GTK_CFLAGS@
+ LDADD = @GTK_LIBS@
+
+-EXTRA_DIST =
++#EXTRA_DIST =
+
+ MOSTLYCLEANFILES = core *~
+ CLEANFILES = core *~
diff --git a/recipes/libstroke/libstroke-0.5.1/libstroke-Makefile.am.patch b/recipes/libstroke/libstroke-0.5.1/libstroke-Makefile.am.patch
new file mode 100644
index 0000000000..98707faf09
--- /dev/null
+++ b/recipes/libstroke/libstroke-0.5.1/libstroke-Makefile.am.patch
@@ -0,0 +1,15 @@
+--- libstroke-0.5.1/libstroke/Makefile.am.orig 2008-06-11 13:01:54.000000000 +0400
++++ libstroke-0.5.1/libstroke/Makefile.am 2008-06-11 13:02:02.000000000 +0400
+@@ -5,10 +5,10 @@
+ # level Makefile.
+ AUTOMAKE_OPTIONS = foreign
+
+-EXTRA_DIST =
++#EXTRA_DIST =
+
+ #tclpath::
+- #echo ${ENABLE_TCL}
++# echo ${ENABLE_TCL}
+
+ #if ENABLE_TCL
+ #SEL_BIB = libstroke.la libstroke_tcl.la
diff --git a/recipes/libstroke/libstroke-0.5.1/tests-Makefile.am.patch b/recipes/libstroke/libstroke-0.5.1/tests-Makefile.am.patch
new file mode 100644
index 0000000000..abd55d676f
--- /dev/null
+++ b/recipes/libstroke/libstroke-0.5.1/tests-Makefile.am.patch
@@ -0,0 +1,15 @@
+--- libstroke-0.5.1/tests/Makefile.am.orig 2008-06-11 13:46:40.000000000 +0400
++++ libstroke-0.5.1/tests/Makefile.am 2008-06-11 13:47:23.000000000 +0400
+@@ -14,7 +14,11 @@
+ gnome_stroke_test_SOURCES = gnome_stroke_test.c
+
+ INCLUDES = -I$(top_srcdir)/libstroke -I$(top_srcdir)/libgstroke \
+- @X_CFLAGS@ @GTK_CFLAGS@
++ @X_CFLAGS@
++
++if HAVE_LIBGTK
++INCLUDES += @GTK_CFLAGS@
++endif
+
+ stroke_test_LDADD = ../libstroke/libstroke.la @X_LDFLAGS@
+ gnome_stroke_test_LDADD = ../libgstroke/libgstroke.la @GTK_LIBS@
diff --git a/recipes/libstroke/libstroke_0.5.1.bb b/recipes/libstroke/libstroke_0.5.1.bb
new file mode 100644
index 0000000000..2b1b6e7275
--- /dev/null
+++ b/recipes/libstroke/libstroke_0.5.1.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "LibStroke - a stroke translation library"
+LICENSE = "GPL"
+SECTION = "x11"
+PRIORITY = "optional"
+#DEPENDS = "virtual/libx11 libxau libxdmcp"
+DEPENDS = "virtual/libx11"
+
+SRC_URI = "http://www.etla.net/libstroke/${P}.tar.gz \
+ file://configure.in.patch;patch=1 \
+ file://libstroke-Makefile.am.patch;patch=1 \
+ file://tests-Makefile.am.patch;patch=1 \
+ "
+# file://Makefile.am.patch;patch=1 \
+# file://libgstroke-Makefile.am.patch;patch=1 \
+
+inherit autotools pkgconfig
+
+do_stage () {
+ autotools_stage_all
+}