summaryrefslogtreecommitdiffstats
path: root/recipes/libtool/libtool_2.2.6a.bb
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-08-03 15:01:12 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-08-03 15:01:12 +0000
commitdaf5409a75e97aa5a60b11e9f150e2532676889e (patch)
tree8701308ab7771fbe851a2d42ec0619f9d8ec0e71 /recipes/libtool/libtool_2.2.6a.bb
parent1b00e69d8b781394edadadd641b4adf8fc972988 (diff)
downloadopenembedded-daf5409a75e97aa5a60b11e9f150e2532676889e.tar.gz
libtool: Do not use target paths to grep and sed for cross and sdk builds.
Diffstat (limited to 'recipes/libtool/libtool_2.2.6a.bb')
-rw-r--r--recipes/libtool/libtool_2.2.6a.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes/libtool/libtool_2.2.6a.bb b/recipes/libtool/libtool_2.2.6a.bb
index 3eb2080f2f..e2996c7198 100644
--- a/recipes/libtool/libtool_2.2.6a.bb
+++ b/recipes/libtool/libtool_2.2.6a.bb
@@ -19,10 +19,12 @@ EXTRA_AUTORECONF = "--exclude=libtoolize"
do_configure_prepend () {
# Skip this for native build:
if test -n "$CONFIG_SITE" ; then
- export ac_cv_path_SED="${ac_cv_path_SED=/bin/sed}"
- export ac_cv_path_GREP="${ac_cv_path_GREP=/bin/grep}"
- export ac_cv_path_EGREP="${ac_cv_path_EGREP=/bin/grep -E}"
- export ac_cv_path_FGREP="${ac_cv_path_FGREP=/bin/grep -F}"
+ if test -z "$LIBTOOL_BB_DO_NOT_SET_PATHS" ; then
+ export ac_cv_path_SED="${ac_cv_path_SED=/bin/sed}"
+ export ac_cv_path_GREP="${ac_cv_path_GREP=/bin/grep}"
+ export ac_cv_path_EGREP="${ac_cv_path_EGREP=/bin/grep -E}"
+ export ac_cv_path_FGREP="${ac_cv_path_FGREP=/bin/grep -F}"
+ fi
fi
}