aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libtool
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-08-03 15:01:12 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-08-03 15:01:12 +0000
commitdaf5409a75e97aa5a60b11e9f150e2532676889e (patch)
tree8701308ab7771fbe851a2d42ec0619f9d8ec0e71 /recipes/libtool
parent1b00e69d8b781394edadadd641b4adf8fc972988 (diff)
downloadopenembedded-daf5409a75e97aa5a60b11e9f150e2532676889e.tar.gz
libtool: Do not use target paths to grep and sed for cross and sdk builds.
Diffstat (limited to 'recipes/libtool')
-rw-r--r--recipes/libtool/libtool-cross_2.2.4.bb7
-rw-r--r--recipes/libtool/libtool-cross_2.2.6a.bb7
-rw-r--r--recipes/libtool/libtool-sdk_2.2.4.bb7
-rw-r--r--recipes/libtool/libtool-sdk_2.2.6a.bb7
-rw-r--r--recipes/libtool/libtool_2.2.4.bb10
-rw-r--r--recipes/libtool/libtool_2.2.6a.bb10
6 files changed, 36 insertions, 12 deletions
diff --git a/recipes/libtool/libtool-cross_2.2.4.bb b/recipes/libtool/libtool-cross_2.2.4.bb
index fab8aa4d42..dd8b598fde 100644
--- a/recipes/libtool/libtool-cross_2.2.4.bb
+++ b/recipes/libtool/libtool-cross_2.2.4.bb
@@ -1,6 +1,6 @@
require libtool.inc
require libtool_${PV}.bb
-PR = "r23"
+PR = "r24"
SRC_URI += "\
file://cross_compile.patch;patch=1 \
@@ -22,6 +22,11 @@ prefix = "${STAGING_DIR_NATIVE}${layout_prefix}"
exec_prefix = "${STAGING_DIR_NATIVE}${layout_exec_prefix}"
bindir = "${STAGING_BINDIR_NATIVE}"
+# skip ac_cv_... setting for cross build: host paths must be used
+do_configure_prepend () {
+ export LIBTOOL_BB_DO_NOT_SET_PATHS=1
+}
+
do_compile () {
:
}
diff --git a/recipes/libtool/libtool-cross_2.2.6a.bb b/recipes/libtool/libtool-cross_2.2.6a.bb
index 8030df3aaa..1b2defb43f 100644
--- a/recipes/libtool/libtool-cross_2.2.6a.bb
+++ b/recipes/libtool/libtool-cross_2.2.6a.bb
@@ -1,6 +1,6 @@
require libtool.inc
require libtool_${PV}.bb
-PR = "r0"
+PR = "r1"
SRC_URI += "\
file://cross_compile.patch;patch=1 \
@@ -20,6 +20,11 @@ prefix = "${STAGING_DIR_NATIVE}${layout_prefix}"
exec_prefix = "${STAGING_DIR_NATIVE}${layout_exec_prefix}"
bindir = "${STAGING_BINDIR_NATIVE}"
+# skip ac_cv_... setting for cross build: host paths must be used
+do_configure_prepend () {
+ export LIBTOOL_BB_DO_NOT_SET_PATHS=1
+}
+
do_compile () {
:
}
diff --git a/recipes/libtool/libtool-sdk_2.2.4.bb b/recipes/libtool/libtool-sdk_2.2.4.bb
index e92c4dbfaf..f2c3c628b0 100644
--- a/recipes/libtool/libtool-sdk_2.2.4.bb
+++ b/recipes/libtool/libtool-sdk_2.2.4.bb
@@ -1,7 +1,7 @@
require libtool.inc
require libtool_${PV}.bb
-PR = "r1"
+PR = "r2"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libtool-${PV}"
SRC_URI_append = " file://cross_compile.patch;patch=1"
@@ -9,6 +9,11 @@ S = "${WORKDIR}/libtool-${PV}"
inherit sdk
+# skip ac_cv_... setting for cross build: host paths must be used
+do_configure_prepend () {
+ export LIBTOOL_BB_DO_NOT_SET_PATHS=1
+}
+
do_install () {
install -d ${D}${bindir}/
install -m 0755 libtool ${D}${bindir}/
diff --git a/recipes/libtool/libtool-sdk_2.2.6a.bb b/recipes/libtool/libtool-sdk_2.2.6a.bb
index 26248147c5..88ec4df8c0 100644
--- a/recipes/libtool/libtool-sdk_2.2.6a.bb
+++ b/recipes/libtool/libtool-sdk_2.2.6a.bb
@@ -1,11 +1,16 @@
require libtool.inc
require libtool_${PV}.bb
-PR = "r0"
+PR = "r1"
SRC_URI_append = " file://cross_compile.patch;patch=1"
inherit sdk
+# skip ac_cv_... setting for cross build: host paths must be used
+do_configure_prepend () {
+ export LIBTOOL_BB_DO_NOT_SET_PATHS=1
+}
+
do_install () {
install -d ${D}${bindir}/
install -m 0755 libtool ${D}${bindir}/
diff --git a/recipes/libtool/libtool_2.2.4.bb b/recipes/libtool/libtool_2.2.4.bb
index 842b613410..8e6682f096 100644
--- a/recipes/libtool/libtool_2.2.4.bb
+++ b/recipes/libtool/libtool_2.2.4.bb
@@ -17,10 +17,12 @@ EXTRA_AUTORECONF = "--exclude=libtoolize"
do_configure_prepend () {
# Skip this for native build:
if test -n "$CONFIG_SITE" ; then
- export ac_cv_path_SED="${ac_cv_path_SED=/bin/sed}"
- export ac_cv_path_GREP="${ac_cv_path_GREP=/bin/grep}"
- export ac_cv_path_EGREP="${ac_cv_path_EGREP=/bin/grep -E}"
- export ac_cv_path_FGREP="${ac_cv_path_FGREP=/bin/grep -F}"
+ if test -z "$LIBTOOL_BB_DO_NOT_SET_PATHS" ; then
+ export ac_cv_path_SED="${ac_cv_path_SED=/bin/sed}"
+ export ac_cv_path_GREP="${ac_cv_path_GREP=/bin/grep}"
+ export ac_cv_path_EGREP="${ac_cv_path_EGREP=/bin/grep -E}"
+ export ac_cv_path_FGREP="${ac_cv_path_FGREP=/bin/grep -F}"
+ fi
fi
}
diff --git a/recipes/libtool/libtool_2.2.6a.bb b/recipes/libtool/libtool_2.2.6a.bb
index 3eb2080f2f..e2996c7198 100644
--- a/recipes/libtool/libtool_2.2.6a.bb
+++ b/recipes/libtool/libtool_2.2.6a.bb
@@ -19,10 +19,12 @@ EXTRA_AUTORECONF = "--exclude=libtoolize"
do_configure_prepend () {
# Skip this for native build:
if test -n "$CONFIG_SITE" ; then
- export ac_cv_path_SED="${ac_cv_path_SED=/bin/sed}"
- export ac_cv_path_GREP="${ac_cv_path_GREP=/bin/grep}"
- export ac_cv_path_EGREP="${ac_cv_path_EGREP=/bin/grep -E}"
- export ac_cv_path_FGREP="${ac_cv_path_FGREP=/bin/grep -F}"
+ if test -z "$LIBTOOL_BB_DO_NOT_SET_PATHS" ; then
+ export ac_cv_path_SED="${ac_cv_path_SED=/bin/sed}"
+ export ac_cv_path_GREP="${ac_cv_path_GREP=/bin/grep}"
+ export ac_cv_path_EGREP="${ac_cv_path_EGREP=/bin/grep -E}"
+ export ac_cv_path_FGREP="${ac_cv_path_FGREP=/bin/grep -F}"
+ fi
fi
}